buildrootschalter/package/memtester/memtester.mk
Baruch Siach badd4036c5 memtester: fix rebuild
Do the edit of conf-* files only when 'cc' appears at the beginning of line,
i.e. the files has not been edited. Otherwise, the 'cc' part of the cross
toolchain gets expanded, leading to the following error on 'make
memtester-rebuild':

./compile: line 3: /home/baruch/git/buildroot/output/host/usr/bin/i686-pc-linux-gnu-g/home/baruch/git/buildroot/output/host/usr/bin/i686-pc-linux-gnu-gcc: No such file or directory
Makefile:82: recipe for target 'memtester.o' failed
make[1]: *** [memtester.o] Error 127

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-09-16 22:09:57 +02:00

24 lines
647 B
Makefile

################################################################################
#
# memtester
#
################################################################################
MEMTESTER_VERSION = 4.3.0
MEMTESTER_SITE = http://pyropus.ca/software/memtester/old-versions
MEMTESTER_LICENSE = GPLv2
MEMTESTER_LICENSE_FILES = COPYING
MEMTESTER_TARGET_INSTALL_OPTS = INSTALLPATH=$(TARGET_DIR)/usr
define MEMTESTER_BUILD_CMDS
$(SED) "s,^cc,$(TARGET_CC)," $(@D)/conf-*
$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
endef
define MEMTESTER_INSTALL_TARGET_CMDS
$(MAKE) $(MEMTESTER_TARGET_INSTALL_OPTS) -C $(@D) install
endef
$(eval $(generic-package))