buildrootschalter/package/radvd/radvd.mk
Thomas Petazzoni 1f21c9fdac radvd: use <pkg>_INSTALL_INIT_SYSV
This commit changes the radvd to use the <pkg>_INSTALL_INIT_SYSV
mechanism instead of using a post install target hook. We also use a
full destination path when calling $(INSTALL).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-12-01 22:35:55 +01:00

20 lines
608 B
Makefile

################################################################################
#
# radvd
#
################################################################################
RADVD_VERSION = 2.8
RADVD_SOURCE = radvd-$(RADVD_VERSION).tar.xz
RADVD_SITE = http://www.litech.org/radvd/dist
RADVD_DEPENDENCIES = host-bison flex host-flex host-pkgconf
RADVD_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
# We're patching configure.ac/Makefile.am.
RADVD_AUTORECONF = YES
define RADVD_INSTALL_INIT_SYSV
$(INSTALL) -D -m 0755 package/radvd/S50radvd $(TARGET_DIR)/etc/init.d/S50radvd
endef
$(eval $(autotools-package))