buildrootschalter/package/php-yaml/php-yaml.mk
Thomas De Schampheleire aaffd209fa packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS,
make the same change for FOO_CONF_OPT.

Sed command used:
   find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g'

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-04 18:54:16 +02:00

28 lines
844 B
Makefile

################################################################################
#
# php-yaml
#
################################################################################
PHP_YAML_VERSION = 1.1.1
PHP_YAML_SOURCE = yaml-$(PHP_YAML_VERSION).tgz
# pecl.php.net returns html with db connect failed
PHP_YAML_SITE = http://sources.buildroot.net
PHP_YAML_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
--with-yaml=$(STAGING_DIR)/usr
# phpize does the autoconf magic
PHP_YAML_DEPENDENCIES = libyaml php host-autoconf
PHP_YAML_LICENSE = MIT
PHP_YAML_LICENSE_FILES = LICENSE
define PHP_YAML_PHPIZE
(cd $(@D); \
PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
$(STAGING_DIR)/usr/bin/phpize)
endef
PHP_YAML_PRE_CONFIGURE_HOOKS += PHP_YAML_PHPIZE
$(eval $(autotools-package))