buildrootschalter/package/ne10/ne10.mk
Thomas Petazzoni 665e13c85e Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed
from "prefer static libraries when possible" to "use only static
libraries". The former semantic didn't make much sense, since the user
had absolutely no control/idea of which package would use static
libraries, and which packages would not. Therefore, for quite some
time, we have been starting to enforce that BR2_PREFER_STATIC_LIB
should really build everything with static libraries.

As a consequence, this patch renames BR2_PREFER_STATIC_LIB to
BR2_STATIC_LIBS, and adjust the Config.in option accordingly.

This also helps preparing the addition of other options to select
shared, shared+static or just static.

Note that we have verified that this commit can be reproduced by
simply doing a global rename of BR2_PREFER_STATIC_LIB to
BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
2014-12-11 22:48:13 +01:00

40 lines
1011 B
Makefile

################################################################################
#
# ne10
#
################################################################################
NE10_VERSION = v1.0.0
NE10_SITE = $(call github,projectNe10,Ne10,$(NE10_VERSION))
NE10_LICENSE = BSD-3c or Apache-2.0
NE10_LICENSE_FILES = doc/LICENSE
NE10_CONF_OPTS = -DGNULINUX_PLATFORM=ON
ifeq ($(BR2_STATIC_LIBS),)
NE10_CONF_OPTS += \
-DNE10_BUILD_SHARED=ON
endif
# The package does not have any install target, so have to provide
# INSTALL_STAGING_CMDS and INSTALL_TARGET_CMDS.
ifeq ($(BR2_STATIC_LIBS),)
define NE10_INSTALL_STAGING_SHARED_LIB
cp -dpf $(@D)/modules/libNE10*.so* $(STAGING_DIR)/usr/lib/
endef
endif
define NE10_INSTALL_STAGING_CMDS
cp -dpf $(@D)/inc/NE10*h $(STAGING_DIR)/usr/include/
cp -dpf $(@D)/modules/libNE10.a $(STAGING_DIR)/usr/lib/
$(NE10_INSTALL_STAGING_SHARED_LIB)
endef
define NE10_INSTALL_TARGET_CMDS
cp -dpf $(@D)/modules/libNE10*.so* $(TARGET_DIR)/usr/lib/
endef
$(eval $(cmake-package))