buildrootschalter/package/intltool/intltool.mk
Francois Perrad 2081534cd4 intltool: fix build issues
This commit fixes various build failures caused by the host-perl
series.

Currently, the variables PERL and PERL5LIB are available only during
the configure step of host-intltool, but they are also needed when
running host-intltool, in all packages that depend on
host-intltool. Without them, host-intltool cannot work as it doesn't
find the libxml-parser-perl module installed in
$(HOST_DIR)/usr/lib/perl.

This commit therefore makes the PERL and PERL5LIB variables global, so
that all packages can access them.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-23 21:58:28 +02:00

16 lines
477 B
Makefile

################################################################################
#
# intltool
#
################################################################################
INTLTOOL_VERSION = 0.50.2
INTLTOOL_SITE = https://launchpad.net/intltool/trunk/$(INTLTOOL_VERSION)/+download
INTLTOOL_LICENSE = GPLv2+
INTLTOOL_LICENSE_FILES = COPYING
HOST_INTLTOOL_DEPENDENCIES = host-gettext host-libxml-parser-perl
$(eval $(autotools-package))
$(eval $(host-autotools-package))