buildrootschalter/package/faifa/faifa.mk
Thomas De Schampheleire 0518a98ac3 packages: rename FOO_MAKE_OPT into FOO_MAKE_OPTS
While the autotools infrastructure was using FOO_MAKE_OPT, generic packages
were typically using FOO_MAKE_OPTS. This inconsistency becomes a problem
when a new infrastructure is introduced that wants to make use of
FOO_MAKE_OPT(S), and can live alongside either generic-package or
autotools-package. The new infrastructure will have to choose between either
OPT or OPTS, and thus rule out transparent usage by respectively generic
packages or generic packages. An example of such an infrastructure is
kconfig-package, which provides kconfig-related make targets.

The OPTS variant is more logical, as there are typically multiple options.

This patch renames all occurrences of FOO_MAKE_OPT in FOO_MAKE_OPTS.
Sed command used:
    find * -type f | xargs sed -i 's#_MAKE_OPT\>#&S#g'

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-04 15:07:23 +02:00

42 lines
1.0 KiB
Makefile

################################################################################
#
# faifa
#
################################################################################
FAIFA_VERSION = v0.1
FAIFA_SITE = $(call github,ffainelli,faifa,$(FAIFA_VERSION))
FAIFA_INSTALL_STAGING = YES
FAIFA_DEPENDENCIES = libpcap host-autoconf
FAIFA_LICENSE = BSD-3c
FAIFA_LICENSE_FILES = COPYING
FAIFA_MAKE_OPTS += GIT_REV=$(FAIFA_VERSION)
# This package uses autoconf, but not automake, so we need to call
# their special autogen.sh script, and have custom target and staging
# installation commands.
define FAIFA_RUN_AUTOGEN
cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
endef
FAIFA_PRE_CONFIGURE_HOOKS += FAIFA_RUN_AUTOGEN
define FAIFA_INSTALL_TARGET_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
PREFIX=/usr \
STRIP=/bin/true \
DESTDIR=$(TARGET_DIR) \
install
endef
define FAIFA_INSTALL_STAGING_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
PREFIX=/usr \
STRIP=/bin/true \
DESTDIR=$(STAGING_DIR) \
install
endef
$(eval $(autotools-package))