buildrootschalter/package/audiofile/audiofile.mk
Maxime Hadjinlian 05a710e0d5 packages/*.mk: Remove duplicate options
These flags are already defined in pkg-autotools.mk.
There is no need to have them twice.

[Thomas: restore += instead of = in the opus package, as suggested by
Yann E. Morin.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-19 11:42:36 +02:00

26 lines
752 B
Makefile

################################################################################
#
# audiofile
#
################################################################################
AUDIOFILE_VERSION = 0.3.6
AUDIOFILE_SITE = http://audiofile.68k.org
AUDIOFILE_INSTALL_STAGING = YES
AUDIOFILE_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
AUDIOFILE_CONF_OPTS = --disable-examples
AUDIOFILE_DEPENDENCIES = host-pkgconf
# configure is outdated and has old bugs because of it
AUDIOFILE_AUTORECONF = YES
AUDIOFILE_LICENSE = GPLv2+ LGPLv2.1+
AUDIOFILE_LICENSE_FILES = COPYING COPYING.GPL
ifeq ($(BR2_PACKAGE_FLAC),y)
AUDIOFILE_DEPENDENCIES += flac
AUDIOFILE_CONF_OPTS += --enable-flac
else
AUDIOFILE_CONF_OPTS += --disable-flac
endif
$(eval $(autotools-package))