buildrootschalter/package/xfsprogs/xfsprogs.mk
Romain Naour a434dac30d xfsprogs: fix shared-only build
The shared-only build is not supported by xfsprogs because without
--enable-static, the builtin libraries (libxfs, libxcmd ...)  are only
built as shared libraries and xfs tools requires the static ones.

Also, we needs to replace -static with -static-libtool-libs for the
shared-only case, in order to fallback to linking with the shared
version of libuuid library.

Fixes:
http://autobuild.buildroot.net/results/139/139fa30756d35a24209136068c818802074908de/
http://autobuild.buildroot.net/results/e2e/e2eef5dbadec555756a912a24978c78c0013ee70/
http://autobuild.buildroot.net/results/08c/08c4bc5037379a8ca312e3e7574067235da74030/

And many more.

[Thomas: fix misc typos in the patch description and commit title.]

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-12-20 21:44:25 +01:00

23 lines
589 B
Makefile

################################################################################
#
# xfsprogs
#
################################################################################
XFSPROGS_VERSION = 3.1.11
XFSPROGS_SITE = ftp://oss.sgi.com/projects/xfs/cmd_tars
XFSPROGS_DEPENDENCIES = util-linux
XFSPROGS_CONF_ENV = ac_cv_header_aio_h=yes ac_cv_lib_rt_lio_listio=yes
XFSPROGS_CONF_OPTS = \
--enable-lib64=no \
--enable-gettext=no \
INSTALL_USER=root \
INSTALL_GROUP=root \
--enable-static
XFSPROGS_INSTALL_TARGET_OPTS = DIST_ROOT=$(TARGET_DIR) install
$(eval $(autotools-package))