buildrootschalter/package/tor/tor.mk
Bernd Kuhls dbe7e621aa package/tor: limit libseccomp support to archs supported by upstream
See this commit for a list of supported archs:
https://gitweb.torproject.org/tor.git/commit/src/common/sandbox.c?id=b0c1c700114aa8d4dfc180d85870c5bbe15fcacb

Fixes mips64el build error:
http://autobuild.buildroot.net/results/f97/f9792a0b013f6b79774ecc978d859f56bd941586/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-04-26 14:29:30 +02:00

36 lines
889 B
Makefile

################################################################################
#
# tor
#
################################################################################
TOR_VERSION = 0.2.5.12
TOR_SITE = https://dist.torproject.org
TOR_LICENSE = BSD-3c
TOR_LICENSE_FILES = LICENSE
TOR_DEPENDENCIES = libevent openssl zlib
TOR_AUTORECONF = YES
TOR_CONF_OPTS = \
--disable-gcc-hardening \
--with-libevent-dir=$(STAGING_DIR)/usr \
--with-openssl-dir=$(STAGING_DIR)/usr \
--with-zlib-dir=$(STAGING_DIR)/usr
ifeq ($(BR2_STATIC_LIBS),y)
TOR_CONF_OPTS += \
--enable-static-libevent \
--enable-static-openssl \
--enable-static-tor \
--enable-static-zlib
endif
ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
TOR_CONF_OPTS += --enable-seccomp
TOR_DEPENDENCIES += libseccomp
else
TOR_CONF_OPTS += --disable-seccomp
endif
$(eval $(autotools-package))