buildrootschalter/package/libwebsock/libwebsock.mk
Yann E. MORIN 2967f17c52 package/libwebsock: allow building without SSL
libwebsock can optionally use SL, and defaults to using it without
checking for its presence first.

Just disable SSL support if openssl is not enabled, and ensure it is
built before libwebsock if it is enabled.

Add a patch to fix SSL conditional build.

Fixes:
    http://autobuild.buildroot.org/results/2c4/2c49e45667aaf2f2a59ace94885b9d4ed98038d7/
    http://autobuild.buildroot.org/results/517/517bc814732f86dc6dd1a5c91148ce52ec9803f7/
    http://autobuild.buildroot.org/results/951/95109c7e37aa21228bc71c69e9c66a6821f3174a/
    ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gregory Dymarek <gregd72002@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-01-04 21:33:21 +01:00

23 lines
676 B
Makefile

################################################################################
#
# libwebsock
#
################################################################################
LIBWEBSOCK_VERSION = 3c1615eeadb0b582b63851073bfe3e5132f31ebc
LIBWEBSOCK_SITE = $(call github,payden,libwebsock,$(LIBWEBSOCK_VERSION))
LIBWEBSOCK_DEPENDENCIES = libevent host-pkgconf
LIBWEBSOCK_AUTORECONF = YES
LIBWEBSOCK_INSTALL_STAGING = YES
LIBWEBSOCK_LICENSE = LGPLv3
LIBWEBSOCK_LICENSE_FILES = COPYING.lesser
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBWEBSOCK_DEPENDENCIES += openssl
LIBWEBSOCK_CONF_OPTS += --with-ssl
else
LIBWEBSOCK_CONF_OPTS += --without-ssl
endif
$(eval $(autotools-package))