buildrootschalter/package/libtorrent/libtorrent.mk
Thomas De Schampheleire aaffd209fa packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS,
make the same change for FOO_CONF_OPT.

Sed command used:
   find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g'

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-10-04 18:54:16 +02:00

19 lines
613 B
Makefile

################################################################################
#
# libtorrent
#
################################################################################
LIBTORRENT_VERSION = 0.13.3
LIBTORRENT_SITE = http://libtorrent.rakshasa.no/downloads
LIBTORRENT_DEPENDENCIES = host-pkgconf libsigc \
$(if $(BR2_PACKAGE_OPENSSL),openssl)
LIBTORRENT_CONF_OPTS = --enable-aligned \
$(if $(BR2_PACKAGE_OPENSSL),--enable-openssl,--disable-openssl)
LIBTORRENT_INSTALL_STAGING = YES
LIBTORRENT_AUTORECONF = YES
LIBTORRENT_LICENSE = GPLv2
LIBTORRENT_LICENSE_FILES = COPYING
$(eval $(autotools-package))