New package squid 3.0.STABLE21

Closes #513

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Gustavo Zacarias 2009-12-23 09:30:45 -03:00 committed by Peter Korsgaard
parent 0e9aad6c71
commit ffe25f05ef
5 changed files with 79 additions and 1 deletions

View File

@ -5,7 +5,7 @@
X.org updated to 7.5.
New packages: librsync, lmbench
New packages: librsync, lmbench, squid
Updated/fixed packages: busybox, dosfstools, e2fsprogs,
freetype, iperf, libglib2, libpng, mdadm, memstat, mtd-utils,
@ -13,6 +13,7 @@
Issues resolved (http://bugs.uclibc.org):
#513: Add new squid package
#661: lmbench: new package
#800: [PATCH] iperf update to 2.0.4
#805: [PATCH] mdadm - version update

View File

@ -201,6 +201,7 @@ source "package/samba/Config.in"
source "package/ser2net/Config.in"
source "package/socat/Config.in"
source "package/spawn-fcgi/Config.in"
source "package/squid/Config.in"
source "package/stunnel/Config.in"
source "package/tcpdump/Config.in"
source "package/tcpreplay/Config.in"

10
package/squid/Config.in Normal file
View File

@ -0,0 +1,10 @@
comment "Squid requires a toolchain with C++ support enabled"
depends on !BR2_INSTALL_LIBSTDCPP
config BR2_PACKAGE_SQUID
bool "squid"
depends on BR2_INSTALL_LIBSTDCPP
help
Caching proxy for the Web supporting HTTP, HTTPS, FTP, and more.
http://www.squid-cache.org/

View File

@ -0,0 +1,31 @@
diff -Nura squid-3.0.STABLE17/configure.in squid-3.0.STABLE17.cross/configure.in
--- squid-3.0.STABLE17/configure.in 2009-07-26 09:24:48.000000000 -0300
+++ squid-3.0.STABLE17.cross/configure.in 2009-07-30 11:54:28.000000000 -0300
@@ -1895,6 +1895,10 @@
;;
esac
+dnl Define CXX_FOR_BUILD
+CXX_FOR_BUILD="$CXX_FOR_BUILD"
+AC_SUBST(CXX_FOR_BUILD)
+
dnl Check for programs
AC_PROG_CPP
AC_PROG_INSTALL
diff -Nura squid-3.0.STABLE17/src/Makefile.am squid-3.0.STABLE17.cross/src/Makefile.am
--- squid-3.0.STABLE17/src/Makefile.am 2009-07-26 09:24:46.000000000 -0300
+++ squid-3.0.STABLE17.cross/src/Makefile.am 2009-07-30 11:55:08.000000000 -0300
@@ -1034,6 +1034,13 @@
squid.conf.default: cf_parser.h
true
+CXX_FOR_BUILD ?= @CXX_FOR_BUILD@
+
+cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES)
+ $(CXX_FOR_BUILD) -o $@ $(srcdir)/cf_gen.cc \
+ $(top_srcdir)/lib/util.c $(top_srcdir)/lib/assert.c \
+ -DNDEBUG -DBUILD_HOST_TOOL ${INCLUDES}
+
cf_parser.h: cf.data cf_gen$(EXEEXT)
./cf_gen cf.data $(srcdir)/cf.data.depend

35
package/squid/squid.mk Normal file
View File

@ -0,0 +1,35 @@
#############################################################
#
# squid
#
#############################################################
SQUID_VERSION = 3.0.STABLE21
SQUID_SOURCE = squid-$(SQUID_VERSION).tar.bz2
SQUID_SITE = http://www.squid-cache.org/Versions/v3/3.0
SQUID_AUTORECONF = YES
SQUID_LIBTOOL_PATCH = NO
SQUID_CONF_ENV = ac_cv_epoll_works=yes ac_cv_func_setresuid=yes \
ac_cv_func_va_copy=yes ac_cv_func___va_copy=yes \
ac_cv_func_strnstr=no
SQUID_CONF_OPT = --disable-wccp --disable-wccp2 \
--disable-htcp --disable-snmp \
--enable-linux-netfilter \
--enable-storeio=ufs,diskd,aufs,null \
--enable-removal-policies="lru,heap" \
--with-aufs-threads=24 --with-filedescriptors=1024
ifeq ($(BR2_PACKAGE_OPENSSL),y)
SQUID_CONF_OPT += --enable-ssl
SQUID_DEPENDENCIES += openssl
endif
$(eval $(call AUTOTARGETS,package,squid))
$(SQUID_HOOK_POST_INSTALL):
rm -f $(addprefix $(TARGET_DIR)/usr/bin/, \
RunCache RunAccel)
rm -f $(addprefix $(TARGET_DIR)/etc/, \
cachemgr.conf mime.conf.default squid.conf.default)
rm -f $(TARGET_DIR)/usr/libexec/cachemgr.cgi
rm -f $(TARGET_DIR)/usr/share/mib.txt
touch $@