Fix libmad configure order according to issue 0001571, revert old fix

This commit is contained in:
Ulf Samuelsson 2007-11-27 21:40:57 +00:00
parent aef5bbb665
commit fdca6a9270
2 changed files with 40 additions and 45 deletions

View File

@ -139,6 +139,46 @@ index 5a51570..70f550a 100644
unsigned short mad_bit_crc(struct mad_bitptr, unsigned int, unsigned short);
# endif
diff --git a/configure.ac b/configure.ac
index 9b79399..063cb9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,13 +274,14 @@ fi
AC_MSG_CHECKING(for architecture-specific fixed-point math routines)
AC_ARG_ENABLE(fpm, AC_HELP_STRING([--enable-fpm=ARCH],
[use ARCH-specific fixed-point math routines
- (one of: intel, arm, mips, sparc, ppc, 64bit, default)]),
+ (one of: intel, arm, avr32, mips, sparc, ppc, 64bit, default)]),
[
case "$enableval" in
yes) ;;
no|default|approx) FPM="DEFAULT" ;;
intel|i?86) FPM="INTEL" ;;
arm) FPM="ARM" ;;
+ avr32) FPM="AVR32" ;;
mips) FPM="MIPS" ;;
sparc) FPM="SPARC" ;;
ppc|powerpc) FPM="PPC" ;;
@@ -298,6 +299,7 @@ then
case "$host" in
i?86-*) FPM="INTEL" ;;
arm*-*) FPM="ARM" ;;
+ avr32*-*) FPM="AVR32" ;;
mips*-*) FPM="MIPS" ;;
sparc*-*) FPM="SPARC" ;;
powerpc*-*) FPM="PPC" ;;
@@ -343,6 +345,11 @@ then
ASO="$ASO -DASO_IMDCT"
ASO_OBJS="imdct_l_arm.lo"
;;
+ avr32*-*)
+ ASO="$ASO -DASO_INTERLEAVE2"
+ ASO="$ASO -DASO_ZEROCHECK"
+ ASO_OBJS="dct32_avr32.lo synth_avr32.lo imdct_avr32.lo"
+ ;;
mips*-*)
ASO="$ASO -DASO_INTERLEAVE2"
ASO="$ASO -DASO_ZEROCHECK"
diff --git a/configure b/configure
index ee421cc..7a9f0c8 100755
--- a/configure
@ -176,46 +216,6 @@ index ee421cc..7a9f0c8 100755
+ ASO="$ASO -DASO_INTERLEAVE2"
+ ASO="$ASO -DASO_ZEROCHECK"
+ ASO_OBJS="dct32_avr32.lo synth_avr32.lo imdct_avr32.lo"
+ ;;
mips*-*)
ASO="$ASO -DASO_INTERLEAVE2"
ASO="$ASO -DASO_ZEROCHECK"
diff --git a/configure.ac b/configure.ac
index 9b79399..063cb9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,13 +274,14 @@ fi
AC_MSG_CHECKING(for architecture-specific fixed-point math routines)
AC_ARG_ENABLE(fpm, AC_HELP_STRING([--enable-fpm=ARCH],
[use ARCH-specific fixed-point math routines
- (one of: intel, arm, mips, sparc, ppc, 64bit, default)]),
+ (one of: intel, arm, avr32, mips, sparc, ppc, 64bit, default)]),
[
case "$enableval" in
yes) ;;
no|default|approx) FPM="DEFAULT" ;;
intel|i?86) FPM="INTEL" ;;
arm) FPM="ARM" ;;
+ avr32) FPM="AVR32" ;;
mips) FPM="MIPS" ;;
sparc) FPM="SPARC" ;;
ppc|powerpc) FPM="PPC" ;;
@@ -298,6 +299,7 @@ then
case "$host" in
i?86-*) FPM="INTEL" ;;
arm*-*) FPM="ARM" ;;
+ avr32*-*) FPM="AVR32" ;;
mips*-*) FPM="MIPS" ;;
sparc*-*) FPM="SPARC" ;;
powerpc*-*) FPM="PPC" ;;
@@ -343,6 +345,11 @@ then
ASO="$ASO -DASO_IMDCT"
ASO_OBJS="imdct_l_arm.lo"
;;
+ avr32*-*)
+ ASO="$ASO -DASO_INTERLEAVE2"
+ ASO="$ASO -DASO_ZEROCHECK"
+ ASO_OBJS="dct32_avr32.lo synth_avr32.lo imdct_avr32.lo"
+ ;;
mips*-*)
ASO="$ASO -DASO_INTERLEAVE2"

View File

@ -38,13 +38,8 @@ $(LIBMAD_DIR)/.configured: $(LIBMAD_DIR)/.unpacked
)
touch $@
# This rule runs 'libtoolize' since the ltmain.sh which comes in the tarball
# is unsuitable with new libtool versions (causing shared libraries to build
# without the .so extension).
$(LIBMAD_DIR)/libmad.la: $(LIBMAD_DIR)/.configured
rm -f $@
(cd $(LIBMAD_DIR); libtoolize --force)
$(MAKE) -C $(LIBMAD_DIR)
$(STAGING_DIR)/usr/lib/libmad.so.0: $(LIBMAD_DIR)/libmad.la