pppd: fix build without UCLIBC_HAS_BSD_ERR

Replace the BSD specific warn() with a call to syslog.
Patch by Gustavo Zacarias, closes #109.
This commit is contained in:
Peter Korsgaard 2009-02-19 12:08:11 +00:00
parent a83dddf9ff
commit fc8ac0c7e5
2 changed files with 22 additions and 0 deletions

View File

@ -0,0 +1,21 @@
diff -Nura ppp-2.4.4/pppd/plugins/rp-pppoe/discovery.c ppp-2.4.4-nobsd/pppd/plugins/rp-pppoe/discovery.c
--- ppp-2.4.4/pppd/plugins/rp-pppoe/discovery.c 2005-03-22 07:22:32.000000000 -0300
+++ ppp-2.4.4-nobsd/pppd/plugins/rp-pppoe/discovery.c 2009-02-17 09:01:27.000000000 -0200
@@ -598,7 +598,7 @@
do {
padiAttempts++;
if (padiAttempts > MAX_PADI_ATTEMPTS) {
- warn("Timeout waiting for PADO packets");
+ syslog(LOG_WARNING, "Timeout waiting for PADO packets");
close(conn->discoverySocket);
conn->discoverySocket = -1;
return;
@@ -627,7 +627,7 @@
do {
padrAttempts++;
if (padrAttempts > MAX_PADI_ATTEMPTS) {
- warn("Timeout waiting for PADS packets");
+ syslog(LOG_WARNING, "Timeout waiting for PADS packets");
close(conn->discoverySocket);
conn->discoverySocket = -1;
return;

View File

@ -21,6 +21,7 @@ PPPD_OPTIONS_$(BR2_PACKAGE_PPPD_FILTER) += FILTER=y
$(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
$(PPPD_CAT) $(DL_DIR)/$(PPPD_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(PPPD_DIR) package/pppd/ pppd\*.patch
$(SED) 's/ -DIPX_CHANGE -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
$(SED) 's/FILTER=y/#FILTER=y/' $(PPPD_DIR)/pppd/Makefile.linux
$(SED) 's,(INSTALL) -s,(INSTALL),' $(PPPD_DIR)/*/Makefile.linux