New package: fbgrab

FBGrab is a framebuffer screenshot program, capturing the linux
frambuffer and converting it to a png-picture.

[Peter: drop zlib dep, add uninstall]
Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Daniel Nyström 2010-12-09 16:28:29 +01:00 committed by Peter Korsgaard
parent 5a6f6bfe88
commit f6cdaf5982
5 changed files with 51 additions and 1 deletions

View File

@ -8,7 +8,7 @@
m4, openssh, openssl, pango, qt, rsync, sdl_gfx, sdl_sound,
udev, usbutils, xz, zlib
New packages: dhrystone, lsuio, rsh-redone, whetstone
New packages: dhrystone, fbgrab, lsuio, rsh-redone, whetstone
Issues resolved (http://bugs.uclibc.org):

View File

@ -96,6 +96,7 @@ source "package/directfb/Config.in"
source "package/directfb-examples/Config.in"
source "package/divine/Config.in"
source "package/fbdump/Config.in"
source "package/fbgrab/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/fbset/Config.in"
endif

8
package/fbgrab/Config.in Normal file
View File

@ -0,0 +1,8 @@
config BR2_PACKAGE_FBGRAB
bool "fbgrab"
select BR2_PACKAGE_LIBPNG
help
FBGrab is a framebuffer screenshot program, capturing the linux
frambuffer and converting it to a png-picture.
http://hem.bredband.net/gmogmo/fbgrab

View File

@ -0,0 +1,23 @@
[PATCH] fbgrab: A proper Makefile for cross compiling
Respect to the CC, CFLAGS and LDFLAGS is required for cross compiling in
Buildroot. And there's no need to run the source through splint.
Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
--- fbgrab-1.0.orig/Makefile 2010-12-07 22:57:24.000000000 +0100
+++ fbgrab-1.0/Makefile 2010-12-07 22:58:36.000000000 +0100
@@ -3,9 +3,10 @@
### modular. So this is a simple gnu Makefile...
###
-fbgrab: fbgrab.c
- splint +posixlib fbgrab.c
- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
+LDFLAGS += -lpng -lz
+
+fbgrab: fbgrab.o
+ $(CC) $(LDFLAGS) fbgrab.o -o $@
install:
strip fbgrab

18
package/fbgrab/fbgrab.mk Normal file
View File

@ -0,0 +1,18 @@
FBGRAB_VERSION = 1.0
FBGRAB_SOURCE = fbgrab-$(FBGRAB_VERSION).tar.gz
FBGRAB_SITE = http://hem.bredband.net/gmogmo/fbgrab
FBGRAB_DEPENDENCIES = libpng
define FBGRAB_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
define FBGRAB_INSTALL_TARGET_CMDS
$(INSTALL) -m 0755 -D $(@D)/fbgrab $(TARGET_DIR)/usr/bin/fbgrab
endef
define FBGRAB_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/fbgrab
endef
$(eval $(call GENTARGETS,package,fbgrab))