Include a patch for GNU sed that allows building it on Mac OS X and

remove a spurious --prefix from sed.mk.  (Heikki Lindholm)
This commit is contained in:
Bernhard Reutner-Fischer 2007-03-09 08:36:22 +00:00
parent 1506b0cfd5
commit ed5893f398
2 changed files with 33 additions and 10 deletions

View File

@ -0,0 +1,29 @@
diff -Nru sed-4.1.5.orig/configure sed-4.1.5/configure
--- sed-4.1.5.orig/configure 2006-02-03 11:24:40.000000000 +0200
+++ sed-4.1.5/configure 2007-02-23 14:03:55.000000000 +0200
@@ -10147,8 +10147,6 @@
LINGUAS="${LINGUAS-%UNSET%}"
- install_sh="$install_sh"
-
_ACEOF
@@ -11265,14 +11263,10 @@
esac
done ;;
gettext-fix )
- sed -e '/^mkinstalldirs *=/a\' \
- -e "install_sh=$install_sh" \
- -e 's/^mkinstalldirs *=.*/mkinstalldirs=$(MKINSTALLDIRS)/' \
+ sed -e 's/^mkinstalldirs *=.*/mkinstalldirs=$(MKINSTALLDIRS)/' \
intl/Makefile > intl/Makefile.tmp
mv intl/Makefile.tmp intl/Makefile
- sed -e '/^mkinstalldirs *=/a\' \
- -e "install_sh=$install_sh" \
- -e 's/^mkinstalldirs *=.*/mkinstalldirs=$(MKINSTALLDIRS)/' \
+ sed -e 's/^mkinstalldirs *=.*/mkinstalldirs=$(MKINSTALLDIRS)/' \
po/Makefile > po/Makefile.tmp
mv po/Makefile.tmp po/Makefile ;;
esac

View File

@ -18,6 +18,7 @@ endif
HOST_SED_DIR:=$(TOOL_BUILD_DIR)
SED:=$(HOST_SED_DIR)/bin/sed -i -e
HOST_SED_TARGET=$(shell package/sed/sedcheck.sh)
HOST_SED_IF_ANY=$(shell toolchain/dependencies/check-host-sed.sh)
$(DL_DIR)/$(SED_SOURCE):
mkdir -p $(DL_DIR)
@ -35,13 +36,13 @@ $(SED_DIR1)/.unpacked: $(DL_DIR)/$(SED_SOURCE)
mkdir -p $(TOOL_BUILD_DIR)
mkdir -p $(HOST_SED_DIR)/bin;
$(SED_CAT) $(DL_DIR)/$(SED_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(SED_DIR1) package/sed/ configure.patch
touch $(SED_DIR1)/.unpacked
$(SED_DIR1)/.configured: $(SED_DIR1)/.unpacked
(cd $(SED_DIR1); rm -rf config.cache; \
./configure \
--prefix=$(HOST_SED_DIR) \
--prefix=/usr \
);
touch $(SED_DIR1)/.configured
@ -62,17 +63,10 @@ build-sed-host-binary: $(SED_DIR1)/$(SED_BINARY)
$(HOST_SED_DIR)/usr/man $(HOST_SED_DIR)/usr/share/doc; fi
use-sed-host-binary:
@if [ -x /usr/bin/sed ] ; then \
SED="/usr/bin/sed" ; \
else \
if [ -x /bin/sed ] ; then \
SED="/bin/sed" ; \
fi \
fi ; \
if [ ! -e "$(HOST_SED_DIR)/$(SED_TARGET_BINARY)" ] ; then \
@if [ ! -e "$(HOST_SED_DIR)/$(SED_TARGET_BINARY)" ] ; then \
mkdir -p "$(HOST_SED_DIR)/bin"; \
rm -f "$(HOST_SED_DIR)/$(SED_TARGET_BINARY)"; \
ln -sf "$$SED" "$(HOST_SED_DIR)/$(SED_TARGET_BINARY)"; \
ln -sf "$(HOST_SED_IF_ANY)" "$(HOST_SED_DIR)/$(SED_TARGET_BINARY)"; \
fi
host-sed: $(HOST_SED_TARGET)