qjson: new package

[Peter: misc white space fixes]
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Zoltan Gyarmati 2013-04-08 10:35:48 +00:00 committed by Peter Korsgaard
parent 05554f1747
commit ecfee10732
4 changed files with 52 additions and 0 deletions

View File

@ -144,6 +144,7 @@ if BR2_PACKAGE_QT
comment "QT libraries and helper libraries"
source "package/grantlee/Config.in"
source "package/qextserialport/Config.in"
source "package/qjson/Config.in"
source "package/qtuio/Config.in"
source "package/qwt/Config.in"
endif

7
package/qjson/Config.in Normal file
View File

@ -0,0 +1,7 @@
config BR2_PACKAGE_QJSON
bool "qjson"
help
QJson is a Qt-based library that maps JSON data to
QVariant objects and vice versa.
http://qjson.sourceforge.net

View File

@ -0,0 +1,29 @@
From 529e50939316abc3c4190f89a482b17a4d4b3355 Mon Sep 17 00:00:00 2001
From: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Date: Sat, 6 Apr 2013 16:54:25 +0200
Subject: [PATCH] fix Qt4 package error in CMakeLists.txt
Avoid checking for uic executable by cmake as it results configure
time error if QtGui isn't installed.
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13e65f1..447f209 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,7 @@ SET(FRAMEWORK_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/Library/Frameworks"
SET(QT_USE_IMPORTED_TARGETS TRUE)
# Find Qt4
-FIND_PACKAGE( Qt4 REQUIRED )
+find_package(Qt4 COMPONENTS QtCore REQUIRED )
IF (NOT WIN32)
SET( QT_DONT_USE_QTGUI TRUE )
--
1.7.10.4

15
package/qjson/qjson.mk Normal file
View File

@ -0,0 +1,15 @@
#############################################################
#
# qjson
#
#############################################################
QJSON_VERSION = 0.8.1
QJSON_SITE = http://github.com/flavio/qjson/tarball/$(QJSON_VERSION)
QJSON_INSTALL_STAGING = YES
QJSON_DEPENDENCIES = qt
QJSON_LICENSE = LGPLv2.1
QJSON_LICENSE_FILES = COPYING.lib
$(eval $(cmake-package))