xserver_xorg-server: Fix race condition when installing man pages

Reproduced the bug using BR2_JLEVEL=16

Fixes race condition by disabling parallel make in man/

http://autobuild.buildroot.net/results/11e/11ece737078ca8da2fee4249432148675b4e630e/
http://autobuild.buildroot.net/results/a95/a952932b832ee3296d6c225c7a9df408ca3eef9f/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Bernd Kuhls 2014-06-12 10:09:45 +02:00 committed by Thomas Petazzoni
parent 59bde2b4df
commit e244eb12df
2 changed files with 21 additions and 0 deletions

View File

@ -0,0 +1,19 @@
Fix race condition when installing man page
Fixes
http://autobuild.buildroot.net/results/11e/11ece737078ca8da2fee4249432148675b4e630e/
http://autobuild.buildroot.net/results/a95/a952932b832ee3296d6c225c7a9df408ca3eef9f/
Patch sent upstream: https://bugs.freedesktop.org/show_bug.cgi?id=79396
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
diff -uNr xorg-server-1.15.1.org/man/Makefile.am xorg-server-1.15.1/man/Makefile.am
--- xorg-server-1.15.1.org/man/Makefile.am 2014-03-22 06:37:53.000000000 +0100
+++ xorg-server-1.15.1/man/Makefile.am 2014-05-29 09:27:48.808356591 +0200
@@ -4,3 +4,5 @@
include $(top_srcdir)/manpages.am
appman_PRE = Xserver.man
+
+.NOTPARALLEL:

View File

@ -9,6 +9,7 @@ XSERVER_XORG_SERVER_SOURCE = xorg-server-$(XSERVER_XORG_SERVER_VERSION).tar.bz2
XSERVER_XORG_SERVER_SITE = http://xorg.freedesktop.org/releases/individual/xserver
XSERVER_XORG_SERVER_LICENSE = MIT
XSERVER_XORG_SERVER_LICENSE_FILES = COPYING
XSERVER_XORG_SERVER_AUTORECONF = YES
XSERVER_XORG_SERVER_INSTALL_STAGING = YES
XSERVER_XORG_SERVER_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install install-data
XSERVER_XORG_SERVER_DEPENDENCIES = \
@ -53,6 +54,7 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
xkeyboard-config \
pixman \
mcookie \
host-xfont_font-util \
host-pkgconf
XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \