xstroke: remove deprecated package

xstroke has been deprecated since 2013.02 and thus can be removed in
2014.02.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas De Schampheleire 2014-02-05 14:50:53 +01:00 committed by Peter Korsgaard
parent 2852f787d0
commit ddf5424fb5
5 changed files with 7 additions and 63 deletions

View File

@ -119,6 +119,13 @@ config BR2_sh3eb
Due to an inexistent user base and generally poor Linux
support, the support for the SH3eb architecture was removed.
config BR2_PACKAGE_XSTROKE
bool "xstroke has been removed"
select BR2_LEGACY
help
The 'xstroke' package has been removed since it has been
deprecated for more than four buildroot releases.
config BR2_PACKAGE_LZMA
bool "lzma target package has been removed"
select BR2_LEGACY

View File

@ -235,7 +235,6 @@ source "package/torsmo/Config.in"
source "package/wmctrl/Config.in"
source "package/x11vnc/Config.in"
source "package/xscreensaver/Config.in"
source "package/xstroke/Config.in"
source "package/xterm/Config.in"
source "package/xvkbd/Config.in"

View File

@ -1,14 +0,0 @@
config BR2_PACKAGE_XSTROKE
bool "xstroke"
depends on BR2_PACKAGE_XORG7
# dead upstream, probably not many users
depends on BR2_DEPRECATED_SINCE_2013_02
select BR2_PACKAGE_XLIB_LIBXFT
select BR2_PACKAGE_XLIB_LIBXTST
select BR2_PACKAGE_XLIB_LIBXPM
select BR2_PACKAGE_XLIB_LIBXRENDER
select BR2_PACKAGE_XLIB_LIBXEXT
help
Handwriting recognition for X
http://mirror.egtvedt.no/avr32linux.org/twiki/pub/Main/XStroke

View File

@ -1,35 +0,0 @@
Fix link issues by linking against all needed libraries
Since gcc 4.6, all libraries that are directly used must be explicitly
passed on the command line. In the case of xstroke, linking against
Xrender, Xext and dl was missing. For the first two, they are added
through addition PKG_CHECK_MODULES() checks, for the latter, it is
added next to -lm and -lpthread in Makefile.am.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile.am
===================================================================
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@
BUILT_SOURCES = rec_parse.h rec_lex.h rec_lex.c
AM_YFLAGS = -d
-xstroke_LDADD = @XSTROKE_LIBS@ -lm -lpthread $(X_LIBS) -lXpm -lXtst
+xstroke_LDADD = @XSTROKE_LIBS@ -ldl -lm -lpthread $(X_LIBS) -lXpm -lXtst
AM_CFLAGS = @XSTROKE_CFLAGS@ -DXSTROKE_CONF_DIR='"$(sysconfdir)/xstroke"' $(X_CFLAGS)
EXTRA_DIST = xstroke_active.xpm xstroke_inactive.xpm etc/alphabet
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@
AC_CHECK_FUNCS([gettimeofday localtime_r])
AC_PATH_XTRA
-PKG_CHECK_MODULES(XSTROKE, xft)
+PKG_CHECK_MODULES(XSTROKE, [xft xrender xext])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT

View File

@ -1,13 +0,0 @@
################################################################################
#
# xstroke
#
################################################################################
XSTROKE_VERSION = 0.6
XSTROKE_SITE = http://mirror.egtvedt.no/avr32linux.org/twiki/pub/Main/XStroke
XSTROKE_DEPENDENCIES = xlib_libXft xlib_libXtst xlib_libXpm xlib_libXrender xlib_libXext
XSTROKE_AUTORECONF = YES
$(eval $(autotools-package))