zlib: Bump to 1.2.5

Closes #1981

Signed-off-by: Paul Jones <paul@pauljones.id.au>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Paul Jones 2010-06-07 22:33:06 +10:00 committed by Peter Korsgaard
parent a563a66347
commit d47c73ee9b
4 changed files with 3 additions and 127 deletions

View File

@ -36,7 +36,7 @@
setserial, sdl, sdl_mixer, sdl_sound, sdl_ttf, sqlite,
squashfs, swfdec, tftpd, thttpd, tn5250, tremor, usbutils,
webif, webkit, wireless_tools, xkeyboard-config,
xserver_xorg-server, xvkbd
xserver_xorg-server, xvkbd, zlib
Removed packages: libgail, modutils, portage, rxvt
@ -72,6 +72,7 @@
#1951: Bump openssl to 0.9.8o
#1957: Bump sqlite to 3.6.23.1
#1975: Package removal/deprecation
#1981: zlib: bump to 1.2.5
#1987: intltool: Fix spelling mistake
#1993: Bump bash to 4.1.7(1) and migrate to autotargets
#1999: Typo in path checking

View File

@ -1,103 +0,0 @@
--- zlib/configure
+++ zlib/configure
@@ -160,8 +160,8 @@
if test $shared -eq 1; then
echo Checking for shared library support...
# we must test in two steps (cc then ld), required at least on SunOS 4.x
- if test "`($CC -c $SFLAGS $test.c) 2>&1`" = "" &&
- test "`($LDSHARED -o $test$shared_ext $test.o) 2>&1`" = ""; then
+ if ($CC -c $SFLAGS $test.c) 2>>config.log &&
+ ($LDSHARED -o $test$shared_ext $test.o) 2>>config.log; then
CFLAGS="$SFLAGS"
LIBS="$LIBS $SHAREDLIBV"
echo Building shared library $SHAREDLIBV with $CC.
@@ -185,7 +185,7 @@
#include <unistd.h>
int main() { return 0; }
EOF
-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
sed < zconf.in.h "/HAVE_UNISTD_H/s%0%1%" > zconf.h
echo "Checking for unistd.h... Yes."
else
@@ -208,7 +208,7 @@
}
EOF
-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
echo "Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf()"
cat > $test.c <<EOF
@@ -232,7 +232,7 @@
}
EOF
- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
+ if ($CC $CFLAGS -o $test $test.c) 2>>config.log; then
echo "Checking for vsnprintf() in stdio.h... Yes."
cat >$test.c <<EOF
@@ -257,7 +257,7 @@
}
EOF
- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
echo "Checking for return value of vsnprintf()... Yes."
else
CFLAGS="$CFLAGS -DHAS_vsnprintf_void"
@@ -295,7 +295,7 @@
}
EOF
- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
echo "Checking for return value of vsprintf()... Yes."
else
CFLAGS="$CFLAGS -DHAS_vsprintf_void"
@@ -325,7 +325,7 @@
}
EOF
- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
+ if ($CC $CFLAGS -o $test $test.c) 2>>config.log; then
echo "Checking for snprintf() in stdio.h... Yes."
cat >$test.c <<EOF
@@ -344,7 +344,7 @@
}
EOF
- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
echo "Checking for return value of snprintf()... Yes."
else
CFLAGS="$CFLAGS -DHAS_snprintf_void"
@@ -376,7 +376,7 @@
}
EOF
- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
echo "Checking for return value of sprintf()... Yes."
else
CFLAGS="$CFLAGS -DHAS_sprintf_void"
@@ -392,7 +392,7 @@
#include <errno.h>
int main() { return 0; }
EOF
-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
echo "Checking for errno.h... Yes."
else
echo "Checking for errno.h... No."
@@ -407,7 +407,7 @@
return mmap((caddr_t)0, (off_t)0, PROT_READ, MAP_SHARED, 0, (off_t)0);
}
EOF
-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
CFLAGS="$CFLAGS -DUSE_MMAP"
echo Checking for mmap support... Yes.
else

View File

@ -1,21 +0,0 @@
--- zlib-1.2.3/Makefile.in
+++ zlib-1.2.3/Makefile.in
@@ -33,7 +33,8 @@
SHAREDLIBV=libz.so.1.2.3
SHAREDLIBM=libz.so.1
-AR=ar rc
+AR=ar
+ARFLAGS=rc
RANLIB=ranlib
TAR=tar
SHELL=/bin/sh
@@ -68,7 +69,7 @@
fi
libz.a: $(OBJS) $(OBJA)
- $(AR) $@ $(OBJS) $(OBJA)
+ $(AR) $(ARFLAGS) $@ $(OBJS) $(OBJA)
-@ ($(RANLIB) $@ || true) >/dev/null 2>&1
match.o: match.S

View File

@ -3,7 +3,7 @@
# zlib
#
#############################################################
ZLIB_VERSION:=1.2.3
ZLIB_VERSION:=1.2.5
ZLIB_SOURCE:=zlib-$(ZLIB_VERSION).tar.bz2
ZLIB_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libpng
ZLIB_INSTALL_STAGING=YES
@ -24,7 +24,6 @@ define ZLIB_CONFIGURE_CMDS
./configure \
$(ZLIB_SHARED) \
--prefix=/usr \
--exec-prefix=$(STAGING_DIR)/usr/bin \
--libdir=$(STAGING_DIR)/usr/lib \
--includedir=$(STAGING_DIR)/usr/include \
)