flac: unbreak powerpc e500 support

Add patch to avoid the enable/disable-debug options from unsetting -g
from CFLAGS in an incorrect way which breaks -mfloat-gprs=X (translit to
-mfloatprs=X).
It's possible to affect other less common CFLAGS with a '-g' in any
position.

Upstream status: sent different patch (configure.ac) - to avoid
autoreconfiguring.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Gustavo Zacarias 2014-11-27 20:51:50 -03:00 committed by Peter Korsgaard
parent 939e03fa9f
commit d1c6a7a6cd
1 changed files with 27 additions and 0 deletions

View File

@ -0,0 +1,27 @@
The sed expression is wrong, any flags with '-g' in any position gets
zapped, for example:
-mfloat-gprs=double (for powerpc e500) -> -mfloatprs=double.
Which gives build errors and is perfectly valid in real use scenarios to
switch from e500v1 (single precision) code to e500v2 (double precision) code.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura flac-1.3.1.orig/configure flac-1.3.1/configure
--- flac-1.3.1.orig/configure 2014-11-27 20:43:29.921303105 -0300
+++ flac-1.3.1/configure 2014-11-27 20:45:33.460250179 -0300
@@ -19870,11 +19870,10 @@
if test "x$debug" = xtrue; then
CPPFLAGS="-DDEBUG $CPPFLAGS"
- CFLAGS=$(echo "$CFLAGS" | sed 's/-g//')
- CFLAGS="-g $CFLAGS"
+ CFLAGS=$(echo "-g $CFLAGS")
else
CPPFLAGS="-DNDEBUG $CPPFLAGS"
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
CFLAGS="-O3 -funroll-loops $CFLAGS"
fi