lttng-babeltrace: fix build failure on gcc14

The gcc14 machine has a moderately old host gcc, which was causing a
recurrent build failure of host-lttng-babeltrace:

 http://autobuild.buildroot.org/results/492/49216052c161874f41738e41e6e0c89a6dd04000/build-end.log

This commit adds a patch to fix this build failure, related to the
access of the ULLONG_MAX define on compilers that did not default to
the C99 variant of the C language.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Thomas Petazzoni 2013-05-28 08:21:29 +00:00 committed by Peter Korsgaard
parent 9428d10362
commit c95ba8a487
3 changed files with 31 additions and 0 deletions

View File

@ -0,0 +1,27 @@
Support old compilers
Some old compilers do not use C99 as their default C language variant,
for example gcc 4.3.x, which is used on some old machines. When such a
compiler is used, by default, ULLONG_MAX is not visible. Adding
-std=gnu99 is needed to make this definition visible.
In autoconf speak, this translates into the need of using
AC_PROC_CC_STDC instead of AC_PROG_CC. See
http://www.gnu.org/software/autoconf/manual/autoconf-2.65/html_node/C-Compiler.html
for more details.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,7 @@
AC_SYS_LARGEFILE
# Checks for programs.
-AC_PROG_CC
+AC_PROG_CC_STDC
AC_PROG_MAKE_SET
LT_INIT
AC_PROG_YACC

View File

@ -4,5 +4,9 @@ LTTNG_BABELTRACE_SOURCE = babeltrace-$(LTTNG_BABELTRACE_VERSION).tar.bz2
LTTNG_BABELTRACE_DEPENDENCIES = popt util-linux libglib2
# One patch touches configure.ac
LTTNG_BABELTRACE_AUTORECONF = YES
HOST_LTTNG_BABELTRACE_AUTORECONF = YES
$(eval $(autotools-package))
$(eval $(host-autotools-package))