netplug: disable -Werror to fix build failure

netplug uses nested functions, and gcc generates a warning that
is turned into an error:

cc1: warnings being treated as errors
if_info.c: In function 'ifsm_scriptdone':
if_info.c:289: error: generating trampoline in object (requires executable stack)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Thomas Petazzoni 2010-05-10 23:39:50 +02:00 committed by Peter Korsgaard
parent 5b9384337a
commit c554cc2a2e
2 changed files with 27 additions and 4 deletions

View File

@ -3,10 +3,11 @@
Fixes all over the tree.
Updated/fixed packages: busybox, customize, hal, hostapd,
less, libxcb, mplayer, pciutils, xdriver_xf86-video-openchrome,
usb_modeswitch, usbutils, wpa_supplicant, xapp_bdftopcf,
xapp_mkfontdir, xfont_encodings, xlib_libX11, xlib_libXfont,
xlib_xtrans, xproto_fontcacheproto, xproto_fontsproto, xvkbd
less, libxcb, mplayer, netplug, pciutils,
xdriver_xf86-video-openchrome, usb_modeswitch, usbutils,
wpa_supplicant, xapp_bdftopcf, xapp_mkfontdir,
xfont_encodings, xlib_libX11, xlib_libXfont, xlib_xtrans,
xproto_fontcacheproto, xproto_fontsproto, xvkbd
Removed packages: vice

View File

@ -0,0 +1,22 @@
netplug uses nested functions, and gcc generates a warning that
is turned into an error:
cc1: warnings being treated as errors
if_info.c: In function 'ifsm_scriptdone':
if_info.c:289: error: generating trampoline in object (requires executable stack)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: netplug-1.2.9/Makefile
===================================================================
--- netplug-1.2.9.orig/Makefile 2010-05-09 21:07:40.000000000 +0200
+++ netplug-1.2.9/Makefile 2010-05-09 21:09:32.000000000 +0200
@@ -9,7 +9,7 @@
install_opts :=
-CFLAGS += -Wall -Werror -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
+CFLAGS += -Wall -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
-DNP_SCRIPT_DIR='"$(scriptdir)"' -ggdb3 -O3 -DNP_VERSION='"$(version)"'
netplugd: config.o netlink.o lib.o if_info.o main.o