strace: bump version, remove patches now upstream

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Peter Korsgaard 2010-09-13 14:10:09 +02:00
parent 5ba97d900a
commit ba4fd23559
8 changed files with 3 additions and 2248 deletions

View File

@ -10,7 +10,8 @@
Updated/fixed packages: berkeleydb, busybox, dropbear,
iptables, kismet, openvpn, qt, usbutils
Removed packages: dillo, libglib12, libgtk12, microwin, pcmcia
Removed packages: dillo, libglib12, libgtk12, microwin,
pcmcia, strace
2010.08: Released August 31th, 2010:

File diff suppressed because it is too large Load Diff

View File

@ -1,27 +0,0 @@
From f5da8d0c38ea0eb660cb17de7aa62cda6899eb75 Mon Sep 17 00:00:00 2001
From: ldv <ldv>
Date: Thu, 1 Jan 2009 23:20:38 +0000
Subject: [PATCH] 2008-11-13 Kirill A. Shutemov <kirill@shutemov.name>
* linux/arm/syscallent.h: Fix build on ARM EABI which does not
provide syscalls socketcall and ipc.
diff --git a/linux/arm/syscallent.h b/linux/arm/syscallent.h
index 5ccef2f..edc3641 100644
--- a/linux/arm/syscallent.h
+++ b/linux/arm/syscallent.h
@@ -431,6 +431,7 @@
{ 5, 0, printargs, "SYS_398" }, /* 398 */
{ 5, 0, printargs, "SYS_399" }, /* 399 */
+#ifndef __ARM_EABI__
#if SYS_socket_subcall != 400
#error fix me
#endif
@@ -481,3 +482,4 @@
{ 4, TI, sys_shmdt, "shmdt" }, /* 440 */
{ 4, TI, sys_shmget, "shmget" }, /* 441 */
{ 4, TI, sys_shmctl, "shmctl" }, /* 442 */
+#endif
--
1.6.1.3

View File

@ -1,19 +0,0 @@
ARM defines SYS_cacheflush, but doesn't have <asm/cachectl.h>
---
system.c | 2 ++
1 file changed, 2 insertions(+)
--- a/system.c
+++ b/system.c
@@ -70,9 +70,11 @@
#include <linux/capability.h>
#endif
+#ifndef ARM
#ifdef SYS_cacheflush
#include <asm/cachectl.h>
#endif
+#endif
#ifdef HAVE_LINUX_USTNAME_H
#include <linux/utsname.h>

View File

@ -1,139 +0,0 @@
--- a/config.h.in
+++ b/config.h.in
@@ -146,6 +146,9 @@
/* Define if stat64 is available in asm/stat.h. */
#undef HAVE_STAT64
+/* Define if statfs64 is available in sys/statfs.h or sys/vfs.h. */
+#undef HAVE_STATFS64
+
/* Define to 1 if stdbool.h conforms to C99. */
#undef HAVE_STDBOOL_H
--- a/configure
+++ b/configure
@@ -2531,6 +2531,14 @@ cat >>confdefs.h <<\_ACEOF
_ACEOF
;;
+avr32*)
+ arch=avr32
+
+cat >>confdefs.h <<\_ACEOF
+#define AVR32 1
+_ACEOF
+
+ ;;
*)
{ echo "$as_me:$LINENO: result: NO!" >&5
echo "${ECHO_T}NO!" >&6; }
@@ -5994,6 +6002,70 @@ _ACEOF
fi
+{ echo "$as_me:$LINENO: checking for statfs64 in sys/(statfs|vfs).h" >&5
+echo $ECHO_N "checking for statfs64 in sys/(statfs|vfs).h... $ECHO_C" >&6; }
+if test "${ac_cv_type_statfs64+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+#ifdef LINUX
+#include <linux/types.h>
+#include <sys/statfs.h>
+#else
+#include <sys/vfs.h>
+#endif
+int
+main ()
+{
+struct statfs64 st;
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext
+if { (ac_try="$ac_compile"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+ (eval "$ac_compile") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest.$ac_objext; then
+ ac_cv_type_statfs64=yes
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_type_statfs64=no
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+fi
+
+{ echo "$as_me:$LINENO: result: $ac_cv_type_statfs64" >&5
+echo "${ECHO_T}$ac_cv_type_statfs64" >&6; }
+if test "$ac_cv_type_statfs64" = yes
+then
+
+cat >>confdefs.h <<\_ACEOF
+#define HAVE_STATFS64 1
+_ACEOF
+
+fi
+
{ echo "$as_me:$LINENO: checking return type of signal handlers" >&5
echo $ECHO_N "checking return type of signal handlers... $ECHO_C" >&6; }
@@ -10377,22 +10449,21 @@ echo "$as_me: $ac_file is unchanged" >&6
fi
rm -f "$tmp/out12"
# Compute $ac_file's index in $config_headers.
-_am_arg=$ac_file
_am_stamp_count=1
for _am_header in $config_headers :; do
case $_am_header in
- $_am_arg | $_am_arg:* )
+ $ac_file | $ac_file:* )
break ;;
* )
_am_stamp_count=`expr $_am_stamp_count + 1` ;;
esac
done
-echo "timestamp for $_am_arg" >`$as_dirname -- "$_am_arg" ||
-$as_expr X"$_am_arg" : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
- X"$_am_arg" : 'X\(//\)[^/]' \| \
- X"$_am_arg" : 'X\(//\)$' \| \
- X"$_am_arg" : 'X\(/\)' \| . 2>/dev/null ||
-echo X"$_am_arg" |
+echo "timestamp for $ac_file" >`$as_dirname -- $ac_file ||
+$as_expr X$ac_file : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
+ X$ac_file : 'X\(//\)[^/]' \| \
+ X$ac_file : 'X\(//\)$' \| \
+ X$ac_file : 'X\(/\)' \| . 2>/dev/null ||
+echo X$ac_file |
sed '/^X\(.*[^/]\)\/\/*[^/][^/]*\/*$/{
s//\1/
q
@@ -10429,7 +10500,7 @@ echo "$as_me: executing $ac_file command
# each Makefile.in and add a new line on top of each file to say so.
# Grep'ing the whole file is not good either: AIX grep has a line
# limit of 2048, but all sed's we know have understand at least 4000.
- if sed -n 's,^#.*generated by automake.*,X,p' "$mf" | grep X >/dev/null 2>&1; then
+ if sed 10q "$mf" | grep '^#.*generated by automake' > /dev/null 2>&1; then
dirpart=`$as_dirname -- "$mf" ||
$as_expr X"$mf" : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
X"$mf" : 'X\(//\)[^/]' \| \

View File

@ -1,10 +0,0 @@
--- a/process.c
+++ b/process.c
@@ -2726,7 +2726,6 @@ const struct xlat struct_user_offsets[]
{ 4*REG_GBR, "4*REG_GBR" },
{ 4*REG_MACH, "4*REG_MACH" },
{ 4*REG_MACL, "4*REG_MACL" },
- { 4*REG_SYSCALL, "4*REG_SYSCALL" },
{ 4*REG_FPUL, "4*REG_FPUL" },
{ 4*REG_FPREG0, "4*REG_FPREG0" },
{ 4*(REG_FPREG0+1), "4*REG_FPREG1" },

View File

@ -1,50 +0,0 @@
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -210,6 +210,26 @@ then
fi
])
+dnl ### A macro to determine whether statfs64 is defined.
+AC_DEFUN([AC_STATFS64],
+[AC_MSG_CHECKING(for statfs64 in sys/(statfs|vfs).h)
+AC_CACHE_VAL(ac_cv_type_statfs64,
+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef LINUX
+#include <linux/types.h>
+#include <sys/statfs.h>
+#else
+#include <sys/vfs.h>
+#endif]], [[struct statfs64 st;]])],[ac_cv_type_statfs64=yes],[ac_cv_type_statfs64=no])])
+AC_MSG_RESULT($ac_cv_type_statfs64)
+if test "$ac_cv_type_statfs64" = yes
+then
+ AC_DEFINE([HAVE_STATFS64], 1,
+[Define if statfs64 is available in sys/statfs.h or sys/vfs.h.])
+fi
+])
+
+
+
dnl ### A macro to determine if off_t is a long long
AC_DEFUN([AC_OFF_T_IS_LONG_LONG],
[AC_MSG_CHECKING(for long long off_t)
--- a/configure.ac
+++ b/configure.ac
@@ -170,6 +170,7 @@ AC_CHECK_MEMBERS([struct stat.st_blksize
struct stat.st_level,
struct stat.st_rdev])
AC_STAT64
+AC_STATFS64
AC_TYPE_SIGNAL
AC_TYPE_UID_T
--- a/file.c
+++ b/file.c
@@ -1704,7 +1704,7 @@ struct tcb *tcp;
return 0;
}
-#ifdef LINUX
+#ifdef HAVE_STATFS64
static void
printstatfs64(tcp, addr)
struct tcb *tcp;

View File

@ -3,7 +3,7 @@
# strace
#
#############################################################
STRACE_VERSION:=4.5.18
STRACE_VERSION:=4.5.20
STRACE_SOURCE:=strace-$(STRACE_VERSION).tar.bz2
STRACE_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/strace
STRACE_AUTORECONF:=NO