update to linux 2.4.16 and current uClibc.

This commit is contained in:
Eric Andersen 2006-03-25 19:09:09 +00:00
parent 7aa8096f08
commit ba46d4d7ca
39 changed files with 1124 additions and 655 deletions

View File

@ -1,24 +1,46 @@
--- linux-2.4.29/arch/mips/Makefile.orig 2005-03-08 23:24:05.000000000 -0700
+++ linux-2.4.29/arch/mips/Makefile 2005-03-08 23:27:37.000000000 -0700
@@ -17,16 +17,16 @@
--- linux/arch/mips/Makefile.orig 2006-01-02 20:21:10.000000000 -0700
+++ linux/arch/mips/Makefile 2006-03-19 17:25:29.000000000 -0700
@@ -22,15 +22,15 @@
# Select the object file format to substitute into the linker script.
#
ifdef CONFIG_CPU_LITTLE_ENDIAN
-tool-prefix = mipsel-linux-
+#tool-prefix = mipsel-linux-
ld-emul = elf32ltsmip
-32bit-tool-prefix = mipsel-linux-
-64bit-tool-prefix = mips64el-linux-
+#32bit-tool-prefix = mipsel-linux-
+#64bit-tool-prefix = mips64el-linux-
32bit-bfd = elf32-tradlittlemips
64bit-bfd = elf64-tradlittlemips
32bit-emul = elf32ltsmip
64bit-emul = elf64ltsmip
else
-tool-prefix = mips-linux-
+#tool-prefix = mips-linux-
ld-emul = elf32btsmip
-32bit-tool-prefix = mips-linux-
-64bit-tool-prefix = mips64-linux-
+#32bit-tool-prefix = mips-linux-
+#64bit-tool-prefix = mips64-linux-
32bit-bfd = elf32-tradbigmips
64bit-bfd = elf64-tradbigmips
32bit-emul = elf32btsmip
@@ -39,18 +39,18 @@
ifdef CONFIG_32BIT
gcc-abi = 32
-tool-prefix = $(32bit-tool-prefix)
+#tool-prefix = $(32bit-tool-prefix)
UTS_MACHINE := mips
endif
ifdef CONFIG_64BIT
gcc-abi = 64
-tool-prefix = $(64bit-tool-prefix)
+#tool-prefix = $(64bit-tool-prefix)
UTS_MACHINE := mips64
endif
-ifdef CONFIG_CROSSCOMPILE
-CROSS_COMPILE = $(tool-prefix)
-CROSS_COMPILE := $(tool-prefix)
-endif
+#ifdef CONFIG_CROSSCOMPILE
+#CROSS_COMPILE = $(tool-prefix)
+#CROSS_COMPILE := $(tool-prefix)
+#endif
MAKEBOOT = $(MAKE) -C arch/$(ARCH)/boot
CHECKFLAGS-y += -D__linux__ -D__mips__ \
-D_ABIO32=1 \

View File

@ -0,0 +1,11 @@
--- orig/kernel/fork.c 2006-03-21 01:41:50.000000000 -0700
+++ linux-2.6.16/kernel/fork.c 2006-03-21 01:41:50.000000000 -0700
@@ -773,7 +773,7 @@
/* This can race but the race causes us to copy when we don't
need to and drop the copy */
- if(atomic_read(&files->count) == 1)
+ if(atomic_read(&files->count) == 1 || current->pid == 1)
{
atomic_inc(&files->count);
return 0;

View File

@ -0,0 +1,11 @@
--- orig/drivers/ieee1394/nodemgr.c 2006-03-21 01:41:51.000000000 -0700
+++ linux-2.6.16/drivers/ieee1394/nodemgr.c 2006-03-21 01:41:51.000000000 -0700
@@ -1487,7 +1487,7 @@
/* If there is no bus manager then we should set the root node's
* force_root bit to promote bus stability per the 1394
* spec. (8.4.2.6) */
- if (host->busmgr_id == 0xffff && host->node_count > 1)
+ if (host->busmgr_id == 0x3f && host->node_count > 1)
{
u16 root_node = host->node_count - 1;

View File

@ -0,0 +1,27 @@
--- linux-2.6.16-rc6-mm1.orig/lib/kobject_uevent.c 2006-03-14 22:57:23.000000000 +0900
+++ linux-2.6.16-rc6-mm1/lib/kobject_uevent.c 2006-03-15 08:39:33.000000000 +0900
@@ -25,6 +25,11 @@
#define BUFFER_SIZE 2048 /* buffer for the variables */
#define NUM_ENVP 32 /* number of env pointers */
+#ifdef CONFIG_HOTPLUG
+u64 uevent_seqnum;
+char uevent_helper[UEVENT_HELPER_PATH_LEN] = "/sbin/hotplug";
+#endif
+
#if defined(CONFIG_HOTPLUG) && defined(CONFIG_NET)
static DEFINE_SPINLOCK(sequence_lock);
static struct sock *uevent_sock;
--- linux-2.6.16-rc6-mm1.orig/kernel/ksysfs.c 2006-03-14 22:57:31.000000000 +0900
+++ linux-2.6.16-rc6-mm1/kernel/ksysfs.c 2006-03-15 08:41:11.000000000 +0900
@@ -15,9 +15,6 @@
#include <linux/module.h>
#include <linux/init.h>
-u64 uevent_seqnum;
-char uevent_helper[UEVENT_HELPER_PATH_LEN] = "/sbin/hotplug";
-
#define KERNEL_ATTR_RO(_name) \
static struct subsys_attribute _name##_attr = __ATTR_RO(_name)

View File

@ -0,0 +1,13 @@
--- orig/drivers/cdrom/cdrom.c 2004-12-07 22:55:38.000000000 -0700
+++ linux-2.6.10-rc3/drivers/cdrom/cdrom.c 2004-12-07 22:55:38.000000000 -0700
@@ -997,6 +997,10 @@
cdinfo(CD_OPEN, "entering cdrom_open\n");
+ /* If the device is opened O_EXCL but there are other openers, return busy */
+ if ( (fp->f_flags & O_EXCL) && (cdi->use_count>0) )
+ return -EBUSY;
+
/* if this was a O_NONBLOCK open and we should honor the flags,
* do a quick open without drive/disc integrity checks. */
cdi->use_count++;

View File

@ -0,0 +1,109 @@
--- orig/include/linux/cdrom.h 2005-10-28 10:14:52.000000000 -0600
+++ linux-2.6.14/include/linux/cdrom.h 2005-10-28 10:14:52.000000000 -0600
@@ -946,7 +946,8 @@
char name[20]; /* name of the device type */
/* per-device flags */
__u8 sanyo_slot : 2; /* Sanyo 3 CD changer support */
- __u8 reserved : 6; /* not used yet */
+ __u8 use_read10 : 1; /* Use READ10 instead of READCD */
+ __u8 reserved : 5; /* not used yet */
int cdda_method; /* see flags */
__u8 last_sense;
__u8 media_written; /* dirty flag, DVD+RW bookkeeping */
--- orig/drivers/cdrom/cdrom.c 2005-10-28 10:14:52.000000000 -0600
+++ linux-2.6.14/drivers/cdrom/cdrom.c 2005-10-28 10:14:52.000000000 -0600
@@ -1982,6 +1982,8 @@
return 0;
}
+static int cdrom_switch_blocksize(struct cdrom_device_info *cdi, int size);
+
/*
* Specific READ_10 interface
*/
@@ -1990,6 +1992,7 @@
int blocksize, int nblocks)
{
struct cdrom_device_ops *cdo = cdi->ops;
+ int ret = 0;
memset(&cgc->cmd, 0, sizeof(cgc->cmd));
cgc->cmd[0] = GPCMD_READ_10;
@@ -2001,7 +2004,22 @@
cgc->cmd[7] = (nblocks >> 8) & 0xff;
cgc->cmd[8] = nblocks & 0xff;
cgc->buflen = blocksize * nblocks;
- return cdo->generic_packet(cdi, cgc);
+
+ if (blocksize != CD_FRAMESIZE) {
+ ret = cdrom_switch_blocksize(cdi, blocksize);
+ ret |= cdo->generic_packet(cdi, cgc);
+ ret |= cdrom_switch_blocksize(cdi, CD_FRAMESIZE);
+ } else ret = cdo->generic_packet(cdi, cgc);
+
+ /*
+ * Switch cdrom_read_block back to default behaviour
+ * if we get an error.
+ * FIXME: Maybe this should not be done on all errors.
+ */
+ if (ret != 0)
+ cdi->use_read10 = 0;
+
+ return ret;
}
/* very generic interface for reading the various types of blocks */
@@ -2010,8 +2028,15 @@
int lba, int nblocks, int format, int blksize)
{
struct cdrom_device_ops *cdo = cdi->ops;
+ int ret;
+
+ if (cdi->use_read10)
+ return cdrom_read_cd(cdi, cgc, lba, blksize, nblocks);
memset(&cgc->cmd, 0, sizeof(cgc->cmd));
+ /*
+ * SCSI-II devices are not required to support READ_CD.
+ */
cgc->cmd[0] = GPCMD_READ_CD;
/* expected sector size - cdda,mode1,etc. */
cgc->cmd[1] = format << 2;
@@ -2034,7 +2059,15 @@
default : cgc->cmd[9] = 0x10;
}
- return cdo->generic_packet(cdi, cgc);
+ ret = cdo->generic_packet(cdi, cgc);
+ if (ret && cgc->sense && cgc->sense->sense_key==0x05 && cgc->sense->asc==0x20 && cgc->sense->ascq==0x00) {
+ ret = cdrom_read_cd(cdi, cgc, lba, blksize, nblocks);
+ if (ret == 0) {
+ cdi->use_read10 = 1;
+ printk(KERN_INFO "cdrom.c: drive does not like READ_CD for blksize=%d, switching to READ_10.\n", blksize);
+ }
+ }
+ return ret;
}
static int cdrom_read_cdda_old(struct cdrom_device_info *cdi, __u8 __user *ubuf,
@@ -2671,20 +2704,6 @@
cgc.sense = &sense;
cgc.data_direction = CGC_DATA_READ;
ret = cdrom_read_block(cdi, &cgc, lba, 1, format, blocksize);
- if (ret && sense.sense_key==0x05 && sense.asc==0x20 && sense.ascq==0x00) {
- /*
- * SCSI-II devices are not required to support
- * READ_CD, so let's try switching block size
- */
- /* FIXME: switch back again... */
- if ((ret = cdrom_switch_blocksize(cdi, blocksize))) {
- kfree(cgc.buffer);
- return ret;
- }
- cgc.sense = NULL;
- ret = cdrom_read_cd(cdi, &cgc, lba, blocksize, 1);
- ret |= cdrom_switch_blocksize(cdi, blocksize);
- }
if (!ret && copy_to_user((char __user *)arg, cgc.buffer, blocksize))
ret = -EFAULT;
kfree(cgc.buffer);

View File

@ -0,0 +1,11 @@
--- orig/drivers/md/md.c 2006-03-21 01:43:49.000000000 -0700
+++ linux-2.6.16/drivers/md/md.c 2006-03-21 01:43:49.000000000 -0700
@@ -4860,7 +4860,7 @@
if ((code == SYS_DOWN) || (code == SYS_HALT) || (code == SYS_POWER_OFF)) {
- printk(KERN_INFO "md: stopping all md devices.\n");
+ //printk(KERN_INFO "md: stopping all md devices.\n");
ITERATE_MDDEV(mddev,tmp)
if (mddev_trylock(mddev)==0)

View File

@ -0,0 +1,18 @@
--- orig/drivers/scsi/scsi_ioctl.c 2005-12-03 02:10:27.000000000 -0700
+++ linux-2.6.14/drivers/scsi/scsi_ioctl.c 2005-12-03 02:10:27.000000000 -0700
@@ -374,6 +374,7 @@
if (!scsi_block_when_processing_errors(sdev))
return -ENODEV;
+#if 0
/* Check for deprecated ioctls ... all the ioctls which don't
* follow the new unique numbering scheme are deprecated */
switch (cmd) {
@@ -389,6 +390,7 @@
default:
break;
}
+#endif
switch (cmd) {
case SCSI_IOCTL_GET_IDLUN:

View File

@ -0,0 +1,12 @@
--- orig/Makefile 2005-12-03 09:22:07 +0000
+++ linux-2.6.14/Makefile 2005-12-03 09:22:07 +0000
@@ -1,7 +1,7 @@
VERSION = 2
PATCHLEVEL = 6
-SUBLEVEL = 16
-EXTRAVERSION =
+SUBLEVEL = 16
+EXTRAVERSION = -erik
NAME=Sliding Snow Leopard
# *DOCUMENTATION*

File diff suppressed because it is too large Load Diff

View File

@ -22,9 +22,9 @@
ifneq ($(filter $(TARGETS),linux),)
# Base version of Linux kernel that we need to download
DOWNLOAD_LINUX_VERSION=2.4.29
DOWNLOAD_LINUX_VERSION=2.6.16
# Version of Linux kernel AFTER applying all patches
LINUX_VERSION=2.4.29-erik
LINUX_VERSION=2.6.16-erik
# File name for the Linux kernel binary

View File

@ -1,5 +1,6 @@
#
# Automatically generated make config: don't edit
# Sat Mar 18 22:41:24 2006
#
# TARGET_alpha is not set
# TARGET_arm is not set
@ -8,8 +9,10 @@
# TARGET_e1 is not set
# TARGET_frv is not set
# TARGET_h8300 is not set
# TARGET_hppa is not set
# TARGET_i386 is not set
# TARGET_i960 is not set
# TARGET_ia64 is not set
# TARGET_m68k is not set
# TARGET_microblaze is not set
TARGET_mips=y
@ -20,31 +23,32 @@ TARGET_mips=y
# TARGET_sh64 is not set
# TARGET_sparc is not set
# TARGET_v850 is not set
# TARGET_vax is not set
# TARGET_x86_64 is not set
#
# Target Architecture Features and Options
#
HAVE_ELF=y
ARCH_SUPPORTS_LITTLE_ENDIAN=y
TARGET_ARCH="mips"
FORCE_OPTIONS_FOR_ARCH=y
ARCH_CFLAGS="-mno-split-addresses"
ARCH_SUPPORTS_BIG_ENDIAN=y
# CONFIG_MIPS_ISA_1 is not set
# CONFIG_MIPS_ISA_2 is not set
# CONFIG_MIPS_ISA_3 is not set
# CONFIG_MIPS_ISA_4 is not set
CONFIG_MIPS_ISA_MIPS32=y
# CONFIG_MIPS_ISA_MIPS64 is not set
# ARCH_LITTLE_ENDIAN is not set
ARCH_ANY_ENDIAN=y
ARCH_BIG_ENDIAN=y
# ARCH_HAS_NO_MMU is not set
ARCH_WANTS_BIG_ENDIAN=y
# ARCH_WANTS_LITTLE_ENDIAN is not set
ARCH_HAS_MMU=y
ARCH_USE_MMU=y
UCLIBC_HAS_FLOATS=y
HAS_FPU=y
# UCLIBC_HAS_FPU is not set
UCLIBC_HAS_SOFT_FLOAT=y
DO_C99_MATH=y
KERNEL_SOURCE="/usr/src/linux"
C_SYMBOL_PREFIX=""
HAVE_DOT_CONFIG=y
#
@ -53,29 +57,30 @@ HAVE_DOT_CONFIG=y
# HAVE_NO_PIC is not set
DOPIC=y
# HAVE_NO_SHARED is not set
HAVE_SHARED=y
# ARCH_HAS_NO_LDSO is not set
BUILD_UCLIBC_LDSO=y
HAVE_SHARED=y
# FORCE_SHAREABLE_TEXT_SEGMENTS is not set
LDSO_LDD_SUPPORT=y
LDSO_CACHE_SUPPORT=y
# LDSO_PRELOAD_FILE_SUPPORT is not set
LDSO_BASE_FILENAME="ld.so"
LDSO_RUNPATH=y
# DL_FINI_CRT_COMPAT is not set
# UCLIBC_STATIC_LDCONFIG is not set
# LDSO_RUNPATH is not set
UCLIBC_CTOR_DTOR=y
# HAS_NO_THREADS is not set
UCLIBC_HAS_THREADS=y
# UCLIBC_HAS_THREADS_NATIVE is not set
PTHREADS_DEBUG_SUPPORT=y
LINUXTHREADS_OLD=y
UCLIBC_HAS_LFS=y
# UCLIBC_STATIC_LDCONFIG is not set
# MALLOC is not set
# MALLOC_SIMPLE is not set
MALLOC_STANDARD=y
MALLOC_GLIBC_COMPAT=y
UCLIBC_DYNAMIC_ATEXIT=y
# COMPAT_ATEXIT is not set
HAS_SHADOW=y
# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
UCLIBC_HAS___PROGNAME=y
# UNIX98PTY_ONLY is not set
ASSUME_DEVPTS=y
UCLIBC_HAS_TM_EXTENSIONS=y
@ -90,7 +95,8 @@ UCLIBC_TZ_FILE_PATH="/etc/TZ"
UCLIBC_HAS_IPV6=y
UCLIBC_HAS_RPC=y
UCLIBC_HAS_FULL_RPC=y
# UCLIBC_HAS_REENTRANT_RPC is not set
UCLIBC_HAS_REENTRANT_RPC=y
# UCLIBC_USE_NETLINK is not set
#
# String and Stdio Support
@ -131,14 +137,19 @@ UCLIBC_HAS_ERRNO_MESSAGES=y
UCLIBC_HAS_SIGNUM_MESSAGES=y
# UCLIBC_HAS_SYS_SIGLIST is not set
UCLIBC_HAS_GNU_GETOPT=y
UCLIBC_HAS_GNU_GETSUBOPT=y
#
# Big and Tall
#
UCLIBC_HAS_REGEX=y
UCLIBC_HAS_REGEX_OLD=y
UCLIBC_HAS_FNMATCH=y
UCLIBC_HAS_FNMATCH_OLD=y
# UCLIBC_HAS_WORDEXP is not set
UCLIBC_HAS_FTW=y
UCLIBC_HAS_GLOB=y
UCLIBC_HAS_GNU_GLOB=y
#
# Library Installation Options
@ -148,9 +159,15 @@ RUNTIME_PREFIX="/"
DEVEL_PREFIX="/usr/"
#
# uClibc security related options
# Security options
#
# UCLIBC_SECURITY is not set
# UCLIBC_BUILD_PIE is not set
# UCLIBC_HAS_ARC4RANDOM is not set
# HAVE_NO_SSP is not set
# UCLIBC_HAS_SSP is not set
UCLIBC_BUILD_RELRO=y
UCLIBC_BUILD_NOW=y
UCLIBC_BUILD_NOEXECSTACK=y
#
# uClibc development/debugging options
@ -158,8 +175,11 @@ DEVEL_PREFIX="/usr/"
CROSS_COMPILER_PREFIX=""
# DODEBUG is not set
# DODEBUG_PT is not set
NOSTRIP=y
# DOASSERTS is not set
# SUPPORT_LD_DEBUG is not set
# SUPPORT_LD_DEBUG_EARLY is not set
WARNINGS="-Wall"
# EXTRA_WARNINGS is not set
# DOMULTI is not set
# UCLIBC_MJN3_ONLY is not set

View File

@ -1,26 +1,27 @@
#
# Automatically generated make config: don't edit
#
# TARGET_alpha is not set
# TARGET_arm is not set
# TARGET_bfin is not set
# TARGET_cris is not set
# TARGET_e1 is not set
# TARGET_frv is not set
# TARGET_h8300 is not set
# TARGET_i386 is not set
# TARGET_i960 is not set
# TARGET_m68k is not set
# TARGET_microblaze is not set
# TARGET_alpha=y
# TARGET_arm=y
# TARGET_bfin=y
# TARGET_cris=y
# TARGET_e1=y
# TARGET_frv=y
# TARGET_h8300=y
# TARGET_hppa=y
# TARGET_i386=y
# TARGET_i960=y
# TARGET_m68k=y
# TARGET_microblaze=y
TARGET_mips=y
# TARGET_nios is not set
# TARGET_nios2 is not set
# TARGET_powerpc is not set
# TARGET_sh is not set
# TARGET_sh64 is not set
# TARGET_sparc is not set
# TARGET_v850 is not set
# TARGET_x86_64 is not set
# TARGET_nios=y
# TARGET_nios2=y
# TARGET_powerpc=y
# TARGET_sh=y
# TARGET_sh64=y
# TARGET_sparc=y
# TARGET_v850=y
# TARGET_x86_64=y
#
# Target Architecture Features and Options
@ -30,53 +31,52 @@ ARCH_SUPPORTS_LITTLE_ENDIAN=y
TARGET_ARCH="mips"
ARCH_CFLAGS="-mno-split-addresses"
ARCH_SUPPORTS_BIG_ENDIAN=y
# CONFIG_MIPS_ISA_1 is not set
# CONFIG_MIPS_ISA_2 is not set
# CONFIG_MIPS_ISA_3 is not set
# CONFIG_MIPS_ISA_4 is not set
# CONFIG_MIPS_ISA_1=y
# CONFIG_MIPS_ISA_2=y
# CONFIG_MIPS_ISA_3=y
# CONFIG_MIPS_ISA_4=y
CONFIG_MIPS_ISA_MIPS32=y
# CONFIG_MIPS_ISA_MIPS64 is not set
# CONFIG_MIPS_ISA_MIPS64=y
ARCH_LITTLE_ENDIAN=y
# ARCH_BIG_ENDIAN is not set
# ARCH_HAS_NO_MMU is not set
# ARCH_HAS_NO_MMU=y
ARCH_HAS_MMU=y
UCLIBC_HAS_FLOATS=y
HAS_FPU=y
DO_C99_MATH=y
KERNEL_SOURCE="/usr/src/linux"
KERNEL_SOURCE="/home/andersen/SVN/buildroot/toolchain_build_mips/linux"
C_SYMBOL_PREFIX=""
HAVE_DOT_CONFIG=y
#
# General Library Settings
#
# HAVE_NO_PIC is not set
# HAVE_NO_PIC=y
DOPIC=y
# HAVE_NO_SHARED is not set
# HAVE_NO_SHARED=y
# ARCH_HAS_NO_LDSO=y
HAVE_SHARED=y
# ARCH_HAS_NO_LDSO is not set
BUILD_UCLIBC_LDSO=y
# FORCE_SHAREABLE_TEXT_SEGMENTS is not set
# FORCE_SHAREABLE_TEXT_SEGMENTS=y
LDSO_LDD_SUPPORT=y
LDSO_CACHE_SUPPORT=y
# LDSO_PRELOAD_FILE_SUPPORT is not set
# LDSO_PRELOAD_FILE_SUPPORT=y
LDSO_BASE_FILENAME="ld.so"
LDSO_RUNPATH=y
# DL_FINI_CRT_COMPAT is not set
# LDSO_RUNPATH=y
UCLIBC_CTOR_DTOR=y
# HAS_NO_THREADS is not set
# HAS_NO_THREADS=y
UCLIBC_HAS_THREADS=y
# UCLIBC_HAS_THREADS_NATIVE is not set
PTHREADS_DEBUG_SUPPORT=y
LINUXTHREADS_OLD=y
UCLIBC_HAS_LFS=y
# UCLIBC_STATIC_LDCONFIG is not set
# MALLOC is not set
# MALLOC_SIMPLE is not set
# UCLIBC_STATIC_LDCONFIG=y
# MALLOC=y
# MALLOC_SIMPLE=y
MALLOC_STANDARD=y
MALLOC_GLIBC_COMPAT=y
UCLIBC_DYNAMIC_ATEXIT=y
COMPAT_ATEXIT=y
HAS_SHADOW=y
# UNIX98PTY_ONLY is not set
# UNIX98PTY_ONLY=y
ASSUME_DEVPTS=y
UCLIBC_HAS_TM_EXTENSIONS=y
UCLIBC_HAS_TZ_CACHING=y
@ -90,7 +90,7 @@ UCLIBC_TZ_FILE_PATH="/etc/TZ"
UCLIBC_HAS_IPV6=y
UCLIBC_HAS_RPC=y
UCLIBC_HAS_FULL_RPC=y
# UCLIBC_HAS_REENTRANT_RPC is not set
# UCLIBC_HAS_REENTRANT_RPC=y
#
# String and Stdio Support
@ -99,44 +99,45 @@ UCLIBC_HAS_STRING_GENERIC_OPT=y
UCLIBC_HAS_STRING_ARCH_OPT=y
UCLIBC_HAS_CTYPE_TABLES=y
UCLIBC_HAS_CTYPE_SIGNED=y
# UCLIBC_HAS_CTYPE_UNSAFE is not set
# UCLIBC_HAS_CTYPE_UNSAFE=y
UCLIBC_HAS_CTYPE_CHECKED=y
# UCLIBC_HAS_CTYPE_ENFORCED is not set
# UCLIBC_HAS_CTYPE_ENFORCED=y
UCLIBC_HAS_WCHAR=y
# UCLIBC_HAS_LOCALE is not set
# UCLIBC_HAS_LOCALE=y
UCLIBC_HAS_HEXADECIMAL_FLOATS=y
UCLIBC_HAS_GLIBC_CUSTOM_PRINTF=y
UCLIBC_PRINTF_SCANF_POSITIONAL_ARGS=9
UCLIBC_HAS_SCANF_GLIBC_A_FLAG=y
# UCLIBC_HAS_STDIO_BUFSIZ_NONE is not set
# UCLIBC_HAS_STDIO_BUFSIZ_256 is not set
# UCLIBC_HAS_STDIO_BUFSIZ_512 is not set
# UCLIBC_HAS_STDIO_BUFSIZ_1024 is not set
# UCLIBC_HAS_STDIO_BUFSIZ_2048 is not set
# UCLIBC_HAS_STDIO_BUFSIZ_NONE=y
# UCLIBC_HAS_STDIO_BUFSIZ_256=y
# UCLIBC_HAS_STDIO_BUFSIZ_512=y
# UCLIBC_HAS_STDIO_BUFSIZ_1024=y
# UCLIBC_HAS_STDIO_BUFSIZ_2048=y
UCLIBC_HAS_STDIO_BUFSIZ_4096=y
# UCLIBC_HAS_STDIO_BUFSIZ_8192 is not set
# UCLIBC_HAS_STDIO_BUFSIZ_8192=y
UCLIBC_HAS_STDIO_BUILTIN_BUFFER_NONE=y
# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_4 is not set
# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_8 is not set
# UCLIBC_HAS_STDIO_SHUTDOWN_ON_ABORT is not set
# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_4=y
# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_8=y
# UCLIBC_HAS_STDIO_SHUTDOWN_ON_ABORT=y
UCLIBC_HAS_STDIO_GETC_MACRO=y
UCLIBC_HAS_STDIO_PUTC_MACRO=y
UCLIBC_HAS_STDIO_AUTO_RW_TRANSITION=y
# UCLIBC_HAS_FOPEN_LARGEFILE_MODE is not set
# UCLIBC_HAS_FOPEN_LARGEFILE_MODE=y
UCLIBC_HAS_FOPEN_EXCLUSIVE_MODE=y
UCLIBC_HAS_GLIBC_CUSTOM_STREAMS=y
UCLIBC_HAS_PRINTF_M_SPEC=y
UCLIBC_HAS_ERRNO_MESSAGES=y
# UCLIBC_HAS_SYS_ERRLIST is not set
# UCLIBC_HAS_SYS_ERRLIST=y
UCLIBC_HAS_SIGNUM_MESSAGES=y
# UCLIBC_HAS_SYS_SIGLIST is not set
# UCLIBC_HAS_SYS_SIGLIST=y
UCLIBC_HAS_GNU_GETOPT=y
#
# Big and Tall
#
UCLIBC_HAS_REGEX=y
# UCLIBC_HAS_WORDEXP is not set
UCLIBC_HAS_REGEX_OLD=y
# UCLIBC_HAS_WORDEXP=y
UCLIBC_HAS_FTW=y
UCLIBC_HAS_GLOB=y
@ -148,18 +149,24 @@ RUNTIME_PREFIX="/"
DEVEL_PREFIX="/usr/"
#
# uClibc security related options
# Security options
#
# UCLIBC_SECURITY is not set
# UCLIBC_BUILD_PIE=y
# HAVE_NO_SSP=y
# UCLIBC_HAS_SSP=y
UCLIBC_BUILD_RELRO=y
UCLIBC_BUILD_NOW=y
# UCLIBC_BUILD_NOEXECSTACK=y
#
# uClibc development/debugging options
#
CROSS_COMPILER_PREFIX=""
# DODEBUG is not set
# DODEBUG_PT is not set
# DOASSERTS is not set
# SUPPORT_LD_DEBUG is not set
# SUPPORT_LD_DEBUG_EARLY is not set
CROSS_COMPILER_PREFIX="/home/andersen/SVN/buildroot/build_mips/staging_dir/bin/mips-linux-uclibc-"
# DODEBUG=y
# DODEBUG_PT=y
# DOASSERTS=y
# SUPPORT_LD_DEBUG=y
# SUPPORT_LD_DEBUG_EARLY=y
WARNINGS="-Wall"
# UCLIBC_MJN3_ONLY is not set
# DOMULTI=y
# UCLIBC_MJN3_ONLY=y