package/mesa3d: Fix uClibc build with BR2_ENABLE_DEBUG=yes

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Bernd Kuhls 2014-10-19 20:05:22 +02:00 committed by Thomas Petazzoni
parent 34cf104187
commit b90a1ea36d
1 changed files with 47 additions and 0 deletions

View File

@ -0,0 +1,47 @@
Fixes uclibc build as uclibc does not include backtrace functionality
Patch sent upstream:
http://lists.freedesktop.org/archives/mesa-dev/2014-October/069506.html
Bugtracker: https://bugs.freedesktop.org/show_bug.cgi?id=85197
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
diff -uNr Mesa-10.3.1.org/configure.ac Mesa-10.3.1/configure.ac
--- Mesa-10.3.1.org/configure.ac 2014-10-12 22:42:38.000000000 +0200
+++ Mesa-10.3.1/configure.ac 2014-10-19 19:15:11.000000000 +0200
@@ -539,6 +539,9 @@
dnl See if posix_memalign is available
AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
+dnl Check for backtrace support
+AC_CHECK_HEADER([execinfo.h], [DEFINES="$DEFINES -DHAVE_EXECINFO_H"])
+
dnl Check for pthreads
case "$host_os" in
mingw*)
diff -uNr Mesa-10.3.1.org/src/mapi/glapi/gen/gl_gentable.py Mesa-10.3.1/src/mapi/glapi/gen/gl_gentable.py
--- Mesa-10.3.1.org/src/mapi/glapi/gen/gl_gentable.py 2014-10-12 22:42:39.000000000 +0200
+++ Mesa-10.3.1/src/mapi/glapi/gen/gl_gentable.py 2014-10-19 19:21:32.913846414 +0200
@@ -42,7 +42,7 @@
#endif
#if (defined(GLXEXT) && defined(HAVE_BACKTRACE)) \\
- || (!defined(GLXEXT) && defined(DEBUG) && !defined(_WIN32_WCE) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__))
+ || (!defined(GLXEXT) && defined(DEBUG) && defined(HAVE_EXECINFO_H) && !defined(_WIN32_WCE) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__))
#define USE_BACKTRACE
#endif
diff -uNr Mesa-10.3.1.org/src/mesa/drivers/dri/i915/intel_regions.c Mesa-10.3.1/src/mesa/drivers/dri/i915/intel_regions.c
--- Mesa-10.3.1.org/src/mesa/drivers/dri/i915/intel_regions.c 2014-05-06 00:45:23.000000000 +0200
+++ Mesa-10.3.1/src/mesa/drivers/dri/i915/intel_regions.c 2014-10-19 19:23:13.833850693 +0200
@@ -65,7 +65,9 @@
#define _DBG(...) {debug_backtrace(); DBG(__VA_ARGS__);}
/* Backtracing debug support */
+#ifdef HAVE_EXECINFO_H
#include <execinfo.h>
+#endif
static void
debug_backtrace(void)