busybox: support only one version

This commit removes the version selection for the busybox
package. Busybox is very well maintained, and bugs are typically fixed
in a timely fashion. Moreover, regressions are fairly unlikely in this
very stable and well-tested tool.

Therefore, there isn't a very compelling reason to have a version
selection for Busybox since we don't accept such a version selection
for the vast majority of other packages, unless there is a strong
reason to do so.

Consequently, this commit:

 * Removes the 1.19.4, 1.20.2 and 1.21.1 Busybox versions, patches and
   default configuration file.

 * Moves the 1.22.1 patches from package/busybox/1.22.1 to just
   package/busybox/ like all other packages.

 * Renames the default 1.22.1 configuration file to just
   busybox.config.

 * Adapts the busybox.mk makefile to encode the current version to
   use.

 * Adds appropriate options to Config.in.legacy. However, even though
   the BR2_BUSYBOX_VERSION_1_22_X is removed, we don't add a
   Config.in.legacy option for it, since it would cause a legacy
   warning for virtually *all* users as most people are currently
   using 1.22.x.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas Petazzoni 2014-07-01 20:03:09 +02:00 committed by Peter Korsgaard
parent 02d85f6576
commit b18dca0df8
20 changed files with 26 additions and 3600 deletions

View File

@ -184,6 +184,30 @@ config BR2_GDB_VERSION_7_5
The 7.5 version of gdb has been removed. Use a newer version
instead.
config BR2_BUSYBOX_VERSION_1_19_X
bool "busybox version selection has been removed"
select BR2_LEGACY
help
The possibility of selecting the Busybox version has been
removed. Use the latest version provided by the Busybox
package instead.
config BR2_BUSYBOX_VERSION_1_20_X
bool "busybox version selection has been removed"
select BR2_LEGACY
help
The possibility of selecting the Busybox version has been
removed. Use the latest version provided by the Busybox
package instead.
config BR2_BUSYBOX_VERSION_1_21_X
bool "busybox version selection has been removed"
select BR2_LEGACY
help
The possibility of selecting the Busybox version has been
removed. Use the latest version provided by the Busybox
package instead.
config BR2_PACKAGE_LIBV4L_DECODE_TM6000
bool "decode_tm6000"
select BR2_PACKAGE_LIBV4L_UTILS

View File

@ -1,164 +0,0 @@
--- busybox-1.19.4/networking/udhcp/common.c
+++ busybox-1.19.4-udhcp/networking/udhcp/common.c
@@ -29,16 +29,16 @@ const struct dhcp_optflag dhcp_optflags[
// { OPTION_IP | OPTION_LIST , 0x07 }, /* DHCP_LOG_SERVER */
// { OPTION_IP | OPTION_LIST , 0x08 }, /* DHCP_COOKIE_SERVER */
{ OPTION_IP | OPTION_LIST , 0x09 }, /* DHCP_LPR_SERVER */
- { OPTION_STRING | OPTION_REQ, 0x0c }, /* DHCP_HOST_NAME */
+ { OPTION_STRING_HOST | OPTION_REQ, 0x0c }, /* DHCP_HOST_NAME */
{ OPTION_U16 , 0x0d }, /* DHCP_BOOT_SIZE */
- { OPTION_STRING | OPTION_REQ, 0x0f }, /* DHCP_DOMAIN_NAME */
+ { OPTION_STRING_HOST | OPTION_REQ, 0x0f }, /* DHCP_DOMAIN_NAME */
{ OPTION_IP , 0x10 }, /* DHCP_SWAP_SERVER */
{ OPTION_STRING , 0x11 }, /* DHCP_ROOT_PATH */
{ OPTION_U8 , 0x17 }, /* DHCP_IP_TTL */
{ OPTION_U16 , 0x1a }, /* DHCP_MTU */
{ OPTION_IP | OPTION_REQ, 0x1c }, /* DHCP_BROADCAST */
{ OPTION_IP_PAIR | OPTION_LIST , 0x21 }, /* DHCP_ROUTES */
- { OPTION_STRING , 0x28 }, /* DHCP_NIS_DOMAIN */
+ { OPTION_STRING_HOST , 0x28 }, /* DHCP_NIS_DOMAIN */
{ OPTION_IP | OPTION_LIST , 0x29 }, /* DHCP_NIS_SERVER */
{ OPTION_IP | OPTION_LIST | OPTION_REQ, 0x2a }, /* DHCP_NTP_SERVER */
{ OPTION_IP | OPTION_LIST , 0x2c }, /* DHCP_WINS_SERVER */
@@ -46,7 +46,7 @@ const struct dhcp_optflag dhcp_optflags[
{ OPTION_IP , 0x36 }, /* DHCP_SERVER_ID */
{ OPTION_STRING , 0x38 }, /* DHCP_ERR_MESSAGE */
//TODO: must be combined with 'sname' and 'file' handling:
- { OPTION_STRING , 0x42 }, /* DHCP_TFTP_SERVER_NAME */
+ { OPTION_STRING_HOST , 0x42 }, /* DHCP_TFTP_SERVER_NAME */
{ OPTION_STRING , 0x43 }, /* DHCP_BOOT_FILE */
//TODO: not a string, but a set of LASCII strings:
// { OPTION_STRING , 0x4D }, /* DHCP_USER_CLASS */
@@ -143,6 +143,7 @@ const uint8_t dhcp_option_lengths[] ALIG
[OPTION_IP_PAIR] = 8,
// [OPTION_BOOLEAN] = 1,
[OPTION_STRING] = 1, /* ignored by udhcp_str2optset */
+ [OPTION_STRING_HOST] = 1, /* ignored by udhcp_str2optset */
#if ENABLE_FEATURE_UDHCP_RFC3397
[OPTION_DNS_STRING] = 1, /* ignored by both udhcp_str2optset and xmalloc_optname_optval */
[OPTION_SIP_SERVERS] = 1,
@@ -411,7 +412,9 @@ static NOINLINE void attach_option(
/* actually 255 is ok too, but adding a space can overlow it */
existing->data = xrealloc(existing->data, OPT_DATA + 1 + old_len + length);
- if ((optflag->flags & OPTION_TYPE_MASK) == OPTION_STRING) {
+ if ((optflag->flags & OPTION_TYPE_MASK) == OPTION_STRING
+ || (optflag->flags & OPTION_TYPE_MASK) == OPTION_STRING_HOST
+ ) {
/* add space separator between STRING options in a list */
existing->data[OPT_DATA + old_len] = ' ';
old_len++;
@@ -475,6 +478,7 @@ int FAST_FUNC udhcp_str2optset(const cha
retval = udhcp_str2nip(val, buffer + 4);
break;
case OPTION_STRING:
+ case OPTION_STRING_HOST:
#if ENABLE_FEATURE_UDHCP_RFC3397
case OPTION_DNS_STRING:
#endif
--- busybox-1.19.4/networking/udhcp/common.h
+++ busybox-1.19.4-udhcp/networking/udhcp/common.h
@@ -80,6 +80,9 @@ enum {
OPTION_IP = 1,
OPTION_IP_PAIR,
OPTION_STRING,
+ /* Opts of STRING_HOST type will be sanitized before they are passed
+ * to udhcpc script's environment: */
+ OPTION_STRING_HOST,
// OPTION_BOOLEAN,
OPTION_U8,
OPTION_U16,
--- busybox-1.19.4/networking/udhcp/dhcpc.c
+++ busybox-1.19.4-udhcp/networking/udhcp/dhcpc.c
@@ -101,6 +101,7 @@ static const uint8_t len_of_option_as_st
[OPTION_IP_PAIR ] = sizeof("255.255.255.255 ") * 2,
[OPTION_STATIC_ROUTES ] = sizeof("255.255.255.255/32 255.255.255.255 "),
[OPTION_STRING ] = 1,
+ [OPTION_STRING_HOST ] = 1,
#if ENABLE_FEATURE_UDHCP_RFC3397
[OPTION_DNS_STRING ] = 1, /* unused */
/* Hmmm, this severely overestimates size if SIP_SERVERS option
@@ -135,6 +136,63 @@ static int mton(uint32_t mask)
return i;
}
+/* Check if a given label represents a valid DNS label
+ * Return pointer to the first character after the label upon success,
+ * NULL otherwise.
+ * See RFC1035, 2.3.1
+ */
+/* We don't need to be particularly anal. For example, allowing _, hyphen
+ * at the end, or leading and trailing dots would be ok, since it
+ * can't be used for attacks. (Leading hyphen can be, if someone uses
+ * cmd "$hostname"
+ * in the script: then hostname may be treated as an option)
+ */
+static const char *valid_domain_label(const char *label)
+{
+ unsigned char ch;
+ unsigned pos = 0;
+
+ for (;;) {
+ ch = *label;
+ if ((ch|0x20) < 'a' || (ch|0x20) > 'z') {
+ if (pos == 0) {
+ /* label must begin with letter */
+ return NULL;
+ }
+ if (ch < '0' || ch > '9') {
+ if (ch == '\0' || ch == '.')
+ return label;
+ /* DNS allows only '-', but we are more permissive */
+ if (ch != '-' && ch != '_')
+ return NULL;
+ }
+ }
+ label++;
+ pos++;
+ //Do we want this?
+ //if (pos > 63) /* NS_MAXLABEL; labels must be 63 chars or less */
+ // return NULL;
+ }
+}
+
+/* Check if a given name represents a valid DNS name */
+/* See RFC1035, 2.3.1 */
+static int good_hostname(const char *name)
+{
+ //const char *start = name;
+
+ for (;;) {
+ name = valid_domain_label(name);
+ if (!name)
+ return 0;
+ if (!name[0])
+ return 1;
+ //Do we want this?
+ //return ((name - start) < 1025); /* NS_MAXDNAME */
+ name++;
+ }
+}
+
/* Create "opt_name=opt_value" string */
static NOINLINE char *xmalloc_optname_optval(uint8_t *option, const struct dhcp_optflag *optflag, const char *opt_name)
{
@@ -185,8 +243,11 @@ static NOINLINE char *xmalloc_optname_op
break;
}
case OPTION_STRING:
+ case OPTION_STRING_HOST:
memcpy(dest, option, len);
dest[len] = '\0';
+ if (type == OPTION_STRING_HOST && !good_hostname(dest))
+ safe_strncpy(dest, "bad", len);
return ret; /* Short circuit this case */
case OPTION_STATIC_ROUTES: {
/* Option binary format:
@@ -314,6 +375,7 @@ static char **fill_envp(struct dhcp_pack
/* +1 element for each option, +2 for subnet option: */
if (packet) {
/* note: do not search for "pad" (0) and "end" (255) options */
+//TODO: change logic to scan packet _once_
for (i = 1; i < 255; i++) {
temp = udhcp_get_option(packet, i);
if (temp) {

View File

@ -1,25 +0,0 @@
--- busybox-1.20.2/libbb/kernel_version.c
+++ busybox-1.20.2-kernel_ver/libbb/kernel_version.c
@@ -20,18 +20,15 @@
int FAST_FUNC get_linux_version_code(void)
{
struct utsname name;
- char *s;
+ char *s, *t;
int i, r;
- if (uname(&name) == -1) {
- bb_perror_msg("can't get system information");
- return 0;
- }
-
+ uname(&name); /* never fails */
s = name.release;
r = 0;
for (i = 0; i < 3; i++) {
- r = r * 256 + atoi(strtok(s, "."));
+ t = strtok(s, ".");
+ r = r * 256 + (t ? atoi(t) : 0);
s = NULL;
}
return r;

View File

@ -1,11 +0,0 @@
--- busybox-1.20.2/networking/ntpd.c
+++ busybox-1.20.2-ntpd/networking/ntpd.c
@@ -1840,7 +1840,7 @@ recv_and_process_client_pkt(void /*int f
/* Build a reply packet */
memset(&msg, 0, sizeof(msg));
- msg.m_status = G.stratum < MAXSTRAT ? G.ntp_status : LI_ALARM;
+ msg.m_status = G.stratum < MAXSTRAT ? (G.ntp_status & LI_MASK) : LI_ALARM;
msg.m_status |= (query_status & VERSION_MASK);
msg.m_status |= ((query_status & MODE_MASK) == MODE_CLIENT) ?
MODE_SERVER : MODE_SYM_PAS;

View File

@ -1,67 +0,0 @@
From b1cec5003b73080a8aa7ea277621bf1c71c3e8d6 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Sat, 20 Oct 2012 15:01:26 -0400
Subject: [PATCH] build system: use pkg-config to look up selinux libs
Newer versions of libselinux has started linking against more libs.
Rather than continuing hardcoding things, switch to using pkg-config
to query for its dependencies.
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
Makefile | 1 +
Makefile.flags | 12 +++++++++++-
2 files changed, 12 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index fccde4a..3a0a5e1 100644
--- a/Makefile
+++ b/Makefile
@@ -297,6 +297,7 @@ NM = $(CROSS_COMPILE)nm
STRIP = $(CROSS_COMPILE)strip
OBJCOPY = $(CROSS_COMPILE)objcopy
OBJDUMP = $(CROSS_COMPILE)objdump
+PKG_CONFIG ?= $(CROSS_COMPILE)pkg-config
AWK = awk
GENKSYMS = scripts/genksyms/genksyms
DEPMOD = /sbin/depmod
diff --git a/Makefile.flags b/Makefile.flags
index c43c8dc..15dcc1f 100644
--- a/Makefile.flags
+++ b/Makefile.flags
@@ -74,6 +74,12 @@ ARCH_FPIC ?= -fpic
ARCH_FPIE ?= -fpie
ARCH_PIE ?= -pie
+# Usage: $(eval $(call pkg_check_modules,VARIABLE-PREFIX,MODULES))
+define pkg_check_modules
+$(1)_CFLAGS := $(shell $(PKG_CONFIG) $(PKG_CONFIG_FLAGS) --cflags $(2))
+$(1)_LIBS := $(shell $(PKG_CONFIG) $(PKG_CONFIG_FLAGS) --libs $(2))
+endef
+
ifeq ($(CONFIG_BUILD_LIBBUSYBOX),y)
# on i386: 14% smaller libbusybox.so
# (code itself is 9% bigger, we save on relocs/PLT/GOT)
@@ -85,6 +91,7 @@ endif
ifeq ($(CONFIG_STATIC),y)
CFLAGS_busybox += -static
+PKG_CONFIG_FLAGS += --static
endif
ifeq ($(CONFIG_PIE),y)
@@ -127,7 +134,10 @@ LDLIBS += pam pam_misc pthread
endif
ifeq ($(CONFIG_SELINUX),y)
-LDLIBS += selinux sepol
+SELINUX_PC_MODULES = libselinux libsepol
+$(eval $(call pkg_check_modules,SELINUX,$(SELINUX_PC_MODULES)))
+CPPFLAGS += $(SELINUX_CFLAGS)
+LDLIBS += $(if $(SELINUX_LIBS),$(SELINUX_LIBS:-l%=%),$(SELINUX_PC_MODULES:lib%=%))
endif
ifeq ($(CONFIG_EFENCE),y)
--
1.7.12

View File

@ -1,123 +0,0 @@
From 5a5dfcad6ba96d12d68bd7b39279215a8fee70d3 Mon Sep 17 00:00:00 2001
From: Tias Guns <tias@ulyssis.org>
Date: Sun, 10 Jun 2012 14:19:01 +0200
Subject: [PATCH] inetd: fix build failure in Android
Signed-off-by: Tias Guns <tias@ulyssis.org>
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
(cherry picked from commit 64f763b42a43cbf36e401690ff6767c25575e520)
---
networking/inetd.c | 1 +
1 file changed, 1 insertion(+)
--
1.7.12
From 246ea72843d5b7e9d4cd902dc5e9d71359196303 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 5 Jul 2012 23:19:09 -0400
Subject: [PATCH] include sys/resource.h where needed
We use functions from sys/resource.h in misc applets, but don't include
the header. This breaks building with newer glibc versions, so add the
include where needed.
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
(cherry picked from commit c5fe9f7b723f949457263ef8e22ab807d5b549ce)
---
loginutils/passwd.c | 1 +
miscutils/time.c | 1 +
networking/inetd.c | 1 +
networking/ntpd.c | 1 +
networking/ntpd_simple.c | 1 +
runit/chpst.c | 1 +
shell/shell_common.c | 1 +
7 files changed, 7 insertions(+)
diff --git a/loginutils/passwd.c b/loginutils/passwd.c
index b83db00..a7006f0 100644
--- a/loginutils/passwd.c
+++ b/loginutils/passwd.c
@@ -15,6 +15,7 @@
#include "libbb.h"
#include <syslog.h>
+#include <sys/resource.h> /* setrlimit */
static void nuke_str(char *str)
{
diff --git a/miscutils/time.c b/miscutils/time.c
index 945f15f..ffed386 100644
--- a/miscutils/time.c
+++ b/miscutils/time.c
@@ -16,6 +16,7 @@
//usage: "\n -v Verbose"
#include "libbb.h"
+#include <sys/resource.h> /* getrusage */
/* Information on the resources used by a child process. */
typedef struct {
diff --git a/networking/inetd.c b/networking/inetd.c
index 1308d74..00baf69 100644
--- a/networking/inetd.c
+++ b/networking/inetd.c
@@ -165,6 +165,8 @@
//usage: "\n (default: 0 - disabled)"
#include <syslog.h>
+#include <sys/resource.h> /* setrlimit */
+#include <sys/socket.h> /* un.h may need this */
#include <sys/un.h>
#include "libbb.h"
diff --git a/networking/ntpd.c b/networking/ntpd.c
index 603801e..b885215 100644
--- a/networking/ntpd.c
+++ b/networking/ntpd.c
@@ -46,6 +46,7 @@
#include "libbb.h"
#include <math.h>
#include <netinet/ip.h> /* For IPTOS_LOWDELAY definition */
+#include <sys/resource.h> /* setpriority */
#include <sys/timex.h>
#ifndef IPTOS_LOWDELAY
# define IPTOS_LOWDELAY 0x10
diff --git a/networking/ntpd_simple.c b/networking/ntpd_simple.c
index 4ad44e4..1b7c66b 100644
--- a/networking/ntpd_simple.c
+++ b/networking/ntpd_simple.c
@@ -7,6 +7,7 @@
*/
#include "libbb.h"
#include <netinet/ip.h> /* For IPTOS_LOWDELAY definition */
+#include <sys/resource.h> /* setpriority */
#ifndef IPTOS_LOWDELAY
# define IPTOS_LOWDELAY 0x10
#endif
diff --git a/runit/chpst.c b/runit/chpst.c
index ac296ba..ed72c8b 100644
--- a/runit/chpst.c
+++ b/runit/chpst.c
@@ -91,6 +91,7 @@ ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
//usage: "\n a SIGXCPU after N seconds"
#include "libbb.h"
+#include <sys/resource.h> /* getrlimit */
/*
Five applets here: chpst, envdir, envuidgid, setuidgid, softlimit.
diff --git a/shell/shell_common.c b/shell/shell_common.c
index 51c92d6..780e27e 100644
--- a/shell/shell_common.c
+++ b/shell/shell_common.c
@@ -18,6 +18,7 @@
*/
#include "libbb.h"
#include "shell_common.h"
+#include <sys/resource.h> /* getrlimit */
const char defifsvar[] ALIGN1 = "IFS= \t\n";
--
1.7.12

View File

@ -1,32 +0,0 @@
From 676452a92d1fc4f85e8d89930d7729197c031026 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sat, 5 Oct 2013 15:51:56 +0200
Subject: [PATCH 1/3] libbb: use <poll.h> instead of <sys/poll.h>
As the pol() manpage recommends, include the <poll.h> header instead
of <sys/poll.h>. This allows to get rid of gazillions of warnings when
building BusyBox against the musl C library, which prints a warning
when the internal header <sys/poll.h> is included directly instead of
the <poll.h> header.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
include/libbb.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/libbb.h b/include/libbb.h
index e520060..f03f454 100644
--- a/include/libbb.h
+++ b/include/libbb.h
@@ -37,7 +37,7 @@
#include <libgen.h> /* dirname,basename */
#undef basename
#define basename dont_use_basename
-#include <sys/poll.h>
+#include <poll.h>
#include <sys/ioctl.h>
#include <sys/mman.h>
#include <sys/socket.h>
--
1.8.1.2

View File

@ -1,33 +0,0 @@
From 5eae213031a3ef88fe8d9d0a387f44264ea635cc Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sat, 5 Oct 2013 15:53:16 +0200
Subject: [PATCH 2/3] network/ifconfig: include <linux/if_slip.h> instead of
<net/if_slip.h>
The musl C library doesn't provide the <net/if_slip.h> since userspace
applications can just as well use the <linux/if_slip.h> kernel header.
This commit fixes the build of the ifconfig applet with the musl C
library.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
networking/ifconfig.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/networking/ifconfig.c b/networking/ifconfig.c
index 782374b..c90ed6b 100644
--- a/networking/ifconfig.c
+++ b/networking/ifconfig.c
@@ -56,7 +56,7 @@
#endif
#if ENABLE_FEATURE_IFCONFIG_SLIP
-# include <net/if_slip.h>
+# include <linux/if_slip.h>
#endif
/* I don't know if this is needed for busybox or not. Anyone? */
--
1.8.1.2

View File

@ -1,36 +0,0 @@
From d4fec31889ad660a58dab633c511221feb66e817 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sat, 5 Oct 2013 15:55:06 +0200
Subject: [PATCH 3/3] networking/libiproute: use <linux/if_packet.h> instead of
<net/if_packet.h>
The musl C library doesn't provide the <net/if_packet.h> since the
corresponding kernel headers <linux/if_packet.h> already provides the
necessary definitions. Replacing <net/if_packet.h> by
<linux/if_packet.h> also removes the need to include
<netpacket/packet.h>
This commit fixes the build of iplink with the musl C library.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
networking/libiproute/iplink.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/networking/libiproute/iplink.c b/networking/libiproute/iplink.c
index bad2017..32ccb1c 100644
--- a/networking/libiproute/iplink.c
+++ b/networking/libiproute/iplink.c
@@ -5,8 +5,7 @@
* Licensed under GPLv2 or later, see file LICENSE in this source tree.
*/
#include <net/if.h>
-#include <net/if_packet.h>
-#include <netpacket/packet.h>
+#include <linux/if_packet.h>
#include <netinet/if_ether.h>
#include "ip_common.h" /* #include "libbb.h" is inside */
--
1.8.1.2

View File

@ -11,44 +11,9 @@ config BR2_PACKAGE_BUSYBOX
if BR2_PACKAGE_BUSYBOX
choice
prompt "BusyBox Version"
default BR2_BUSYBOX_VERSION_1_22_X
help
Select the version of BusyBox you wish to use.
config BR2_BUSYBOX_VERSION_1_19_X
bool "BusyBox 1.19.x"
depends on BR2_DEPRECATED_SINCE_2014_02
config BR2_BUSYBOX_VERSION_1_20_X
bool "BusyBox 1.20.x"
config BR2_BUSYBOX_VERSION_1_21_X
bool "BusyBox 1.21.x"
config BR2_BUSYBOX_VERSION_1_22_X
bool "BusyBox 1.22.x"
config BR2_PACKAGE_BUSYBOX_SNAPSHOT
bool "daily snapshot"
endchoice
config BR2_BUSYBOX_VERSION
string
default "1.19.4" if BR2_BUSYBOX_VERSION_1_19_X
default "1.20.2" if BR2_BUSYBOX_VERSION_1_20_X
default "1.21.1" if BR2_BUSYBOX_VERSION_1_21_X
default "1.22.1" if BR2_BUSYBOX_VERSION_1_22_X
config BR2_PACKAGE_BUSYBOX_CONFIG
string "BusyBox configuration file to use?"
default "package/busybox/busybox-1.21.x.config" if BR2_PACKAGE_BUSYBOX_SNAPSHOT
default "package/busybox/busybox-1.19.x.config" if BR2_BUSYBOX_VERSION_1_19_X
default "package/busybox/busybox-1.20.x.config" if BR2_BUSYBOX_VERSION_1_20_X
default "package/busybox/busybox-1.21.x.config" if BR2_BUSYBOX_VERSION_1_21_X
default "package/busybox/busybox-1.22.x.config" if BR2_BUSYBOX_VERSION_1_22_X
default "package/busybox/busybox.config"
help
Some people may wish to use their own modified BusyBox configuration
file, and will specify their config file location with this option.

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -4,13 +4,8 @@
#
################################################################################
ifeq ($(BR2_PACKAGE_BUSYBOX_SNAPSHOT),y)
BUSYBOX_VERSION = snapshot
BUSYBOX_SITE = http://www.busybox.net/downloads/snapshots
else
BUSYBOX_VERSION = $(call qstrip,$(BR2_BUSYBOX_VERSION))
BUSYBOX_VERSION = 1.22.1
BUSYBOX_SITE = http://www.busybox.net/downloads
endif
BUSYBOX_SOURCE = busybox-$(BUSYBOX_VERSION).tar.bz2
BUSYBOX_LICENSE = GPLv2
BUSYBOX_LICENSE_FILES = LICENSE