libiqrf: Bump to v0.1.2 + update build system.

v0.1.2 update build system from autotools to cmake.

[Thomas: add patch to ensure the CMake build system only checks for a
C compiler and not a C++ compiler]

Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Marek Belisko 2013-07-03 22:51:20 +02:00 committed by Thomas Petazzoni
parent 88418bd2de
commit aef9be3eb3
2 changed files with 31 additions and 2 deletions

View File

@ -0,0 +1,29 @@
Use only the C language
libirqf is written completely in C, but by default, CMake assumes that
both C and C++ are used, and therefore verifies that a C++ compiler is
installed. This may not necessarily be the case for a C-only package
in Buildroot.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/src/CMakeLists.txt
===================================================================
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,3 @@
-project(iqrf)
-
set (iqrf_version_major 0)
set (iqrf_version_minor 1)
set (iqrf_version_patch 2)
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,5 @@
+project(iqrf C)
+
cmake_minimum_required(VERSION 2.8.1)
enable_testing()

View File

@ -4,11 +4,11 @@
#
################################################################################
LIBIQRF_VERSION = v0.1.0
LIBIQRF_VERSION = v0.1.2
LIBIQRF_SITE = http://github.com/nandra/libiqrf/tarball/$(LIBIQRF_VERSION)
LIBIQRF_INSTALL_STAGING = YES
LIBIQRF_DEPENDENCIES = libusb
$(eval $(autotools-package))
$(eval $(cmake-package))