open2300: fix build failure

This patch fixes the open2300's build-system, which is a handwritten
Makefile, by removing the hard-coded include and library locations and
making them pointing to the systroot.

Fixes:
  http://autobuild.buildroot.org/results/072/0724ffa1355f5564b1fcd9d6e3c9ff2162d20f44/build-end.log

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Samuel Martin 2014-02-06 21:49:36 +01:00 committed by Peter Korsgaard
parent 7bb2997280
commit a8b1d7c8cc
2 changed files with 59 additions and 1 deletions

View File

@ -0,0 +1,52 @@
From b0a1f12349bee43040a889c7e74873cfb253b9d8 Mon Sep 17 00:00:00 2001
From: Samuel Martin <s.martin49@gmail.com>
Date: Thu, 6 Feb 2014 21:42:50 +0100
Subject: [PATCH] fix makefile
- allow to extend CFLAGS and CC_LDFLAGS
- remove hard-coded include dirs. and lib. dirs. (which pointed to some
location in the host system)
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
Makefile | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/Makefile b/Makefile
index 92a2cc0..1b54175 100755
--- a/Makefile
+++ b/Makefile
@@ -37,9 +37,9 @@ MYSQLHISTLOGOBJ = mysqlhistlog2300.o rw2300.o linux2300.o win2300.o
VERSION = 1.11
-CFLAGS = -Wall -O3 -DVERSION=\"$(VERSION)\"
-CC_LDFLAGS = -lm
-CC_WINFLAG =
+override CFLAGS += -Wall -O3 -DVERSION=\"$(VERSION)\"
+override CC_LDFLAGS += -lm
+CC_WINFLAG =
# For Windows - comment the two line above and un-comment the two lines below.
#CC_LDFLAGS = -lm -lwsock32
#CC_WINFLAG = -mwindows
@@ -80,7 +80,7 @@ xml2300 : $(XMLOBJ)
$(CC) $(CFLAGS) -o $@ $(XMLOBJ) $(CC_LDFLAGS) $(CC_WINFLAG)
mysql2300:
- $(CC) $(CFLAGS) -o mysql2300 mysql2300.c rw2300.c linux2300.c $(CC_LDFLAGS) $(CC_WINFLAG) -I/usr/include/mysql -L/usr/lib/mysql -lmysqlclient
+ $(CC) $(CFLAGS) -o mysql2300 mysql2300.c rw2300.c linux2300.c $(CC_LDFLAGS) $(CC_WINFLAG)
pgsql2300: $(PGSQLOBJ)
$(CC) $(CFLAGS) -o $@ $(PGSQLOBJ) $(CC_LDFLAGS) $(CC_WINFLAG) -I/usr/include/pgsql -L/usr/lib/pgsql -lpq
@@ -95,7 +95,7 @@ minmax2300: $(MINMAXOBJ)
$(CC) $(CFLAGS) -o $@ $(MINMAXOBJ) $(CC_LDFLAGS) $(CC_WINFLAG)
mysqlhistlog2300 :
- $(CC) $(CFLAGS) -o mysqlhistlog2300 mysqlhistlog2300.c rw2300.c linux2300.c $(CC_LDFLAGS) $(CC_WINFLAG) -I/usr/include/mysql -L/usr/lib/mysql -lmysqlclient
+ $(CC) $(CFLAGS) -o mysqlhistlog2300 mysqlhistlog2300.c rw2300.c linux2300.c $(CC_LDFLAGS) $(CC_WINFLAG)
install:
--
1.8.5.3

View File

@ -10,14 +10,20 @@ OPEN2300_VERSION = 12
OPEN2300_BINS = open2300 dump2300 log2300 fetch2300 wu2300 cw2300 history2300 \
histlog2300 bin2300 xml2300 light2300 interval2300 minmax2300
OPEN2300_CFLAGS = $(TARGET_CFLAGS)
OPEN2300_LDFLAGS = $(TARGET_LDFLAGS)
ifeq ($(BR2_PACKAGE_MYSQL),y)
OPEN2300_DEPENDENCIES += mysql
OPEN2300_BINS += mysql2300 mysqlhistlog2300
OPEN2300_CFLAGS += -I$(STAGING_DIR)/usr/include/mysql
OPEN2300_LDFLAGS += -L$(STAGING_DIR)/usr/lib/mysql -lmysqlclient
endif
define OPEN2300_BUILD_CMDS
$(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D) $(OPEN2300_BINS)
$(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" \
CFLAGS="$(OPEN2300_CFLAGS)" CC_LDFLAGS="$(OPEN2300_LDFLAGS)" \
-C $(@D) $(OPEN2300_BINS)
endef
define OPEN2300_INSTALL_TARGET_CMDS