Merge branch 'next'

Kickoff 2013.02 cycle
This commit is contained in:
Peter Korsgaard 2012-12-02 17:19:40 -08:00
commit 8cdabd7695
31 changed files with 679 additions and 168 deletions

View File

@ -0,0 +1,45 @@
From 3d1a9b44b9dcd2c0f5d54c09596c96c0524d8340 Mon Sep 17 00:00:00 2001
From: Gregory Hermant <gregory.hermant@calao-systems.com>
Date: Tue, 13 Nov 2012 11:47:41 +0100
Subject: [PATCH] trace-debug[stm]: Fix for BT/WLAN instability
Pins under mop500_ske_pins array are used for different
functionalities in snowball. Ex: GPIO161 pin configured
for keypad here must stay configured as GPIO alternate
function for operating PMU_EN pin of BT/WLAN chip in snowball.
So forbid configuring these pins, for snowball
Signed-off-by: Rajanikanth H.V <rajanikanth.hv@stericsson.com>
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com>
---
arch/arm/mach-ux500/board-mop500-stm.c | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/arch/arm/mach-ux500/board-mop500-stm.c b/arch/arm/mach-ux500/board-mop500-stm.c
index 1bef2a0..532fb9e 100644
--- a/arch/arm/mach-ux500/board-mop500-stm.c
+++ b/arch/arm/mach-ux500/board-mop500-stm.c
@@ -121,7 +121,9 @@ static int stm_ste_disable_ape_on_mipi60(void)
if (retval)
STM_ERR("Failed to disable MIPI60\n");
else {
- retval = nmk_config_pins(ARRAY_AND_SIZE(mop500_ske_pins));
+ if (!machine_is_snowball())
+ retval = nmk_config_pins(
+ ARRAY_AND_SIZE(mop500_ske_pins));
if (retval)
STM_ERR("Failed to enable SKE gpio\n");
}
@@ -314,7 +316,8 @@ static int stm_ste_connection(enum stm_connection_type con_type)
/* Enable altC3 on GPIO70-74 (STMMOD) and GPIO75-76 (UARTMOD) */
prcmu_enable_stm_mod_uart();
/* Enable APE on MIPI60 */
- retval = nmk_config_pins_sleep(ARRAY_AND_SIZE(mop500_ske_pins));
+ if (!machine_is_snowball())
+ retval = nmk_config_pins_sleep(ARRAY_AND_SIZE(mop500_ske_pins));
if (retval)
STM_ERR("Failed to disable SKE GPIO\n");
else {
--
1.7.9.5

View File

@ -0,0 +1,24 @@
BR2_arm=y
BR2_cortex_a9=y
BR2_GCC_VERSION_4_7_X=y
# BR2_SOFT_FLOAT is not set
BR2_TOOLCHAIN_BUILDROOT_WCHAR=y
BR2_TOOLCHAIN_BUILDROOT_CXX=y
BR2_VFP_FLOAT=y
BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV=y
BR2_TARGET_GENERIC_GETTY_PORT="ttyAMA2"
BR2_PACKAGE_BUSYBOX_SHOW_OTHERS=y
BR2_PACKAGE_SNOWBALL_HDMISERVICE=y
BR2_PACKAGE_LIBNL=y
BR2_PACKAGE_SNOWBALL_INIT=y
BR2_PACKAGE_WPA_SUPPLICANT=y
BR2_TARGET_ROOTFS_TAR_GZIP=y
BR2_TARGET_UBOOT=y
BR2_TARGET_UBOOT_BOARDNAME="snowball"
BR2_LINUX_KERNEL=y
BR2_LINUX_KERNEL_CUSTOM_GIT=y
BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL="git://igloocommunity.org/git/kernel/igloo-kernel.git"
BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION="stable-linux-ux500-3.4"
BR2_LINUX_KERNEL_PATCH="board/calao/snowball/"
BR2_LINUX_KERNEL_DEFCONFIG="u8500"
BR2_LINUX_KERNEL_INSTALL_TARGET=y

View File

@ -250,6 +250,7 @@ source "package/sane-backends/Config.in"
source "package/sdparm/Config.in"
source "package/setserial/Config.in"
source "package/smartmontools/Config.in"
source "package/snowball-hdmiservice/Config.in"
source "package/sredird/Config.in"
source "package/statserial/Config.in"
source "package/sysstat/Config.in"
@ -260,6 +261,7 @@ source "package/usb_modeswitch/Config.in"
source "package/usb_modeswitch_data/Config.in"
source "package/usbmount/Config.in"
source "package/usbutils/Config.in"
source "package/ux500-firmware/Config.in"
source "package/wipe/Config.in"
endmenu
@ -376,6 +378,7 @@ source "package/cairo/Config.in"
source "package/fltk/Config.in"
source "package/fontconfig/Config.in"
source "package/freetype/Config.in"
source "package/gd/Config.in"
source "package/giblib/Config.in"
source "package/gtk2-engines/Config.in"
source "package/gtk2-themes/Config.in"
@ -434,6 +437,8 @@ endmenu
menu "Multimedia"
source "package/libdvdread/Config.in"
source "package/libdvdnav/Config.in"
source "package/libebml/Config.in"
source "package/libmatroska/Config.in"
source "package/libmms/Config.in"
source "package/libmpeg2/Config.in"
source "package/libogg/Config.in"
@ -549,6 +554,7 @@ source "package/empty/Config.in"
source "package/googlefontdirectory/Config.in"
source "package/mobile-broadband-provider-info/Config.in"
source "package/shared-mime-info/Config.in"
source "package/snowball-init/Config.in"
source "package/sound-theme-borealis/Config.in"
source "package/sound-theme-freedesktop/Config.in"
endmenu

View File

@ -0,0 +1,106 @@
From ac7992081abba87627c9e91735b3309584b48585 Mon Sep 17 00:00:00 2001
From: Gregory Hermant <gregory.hermant@calao-systems.com>
Date: Wed, 14 Nov 2012 14:27:02 +0100
Subject: [PATCH] add support for the ST-Ericsson CG2900 GPS FM Bluetooth
combo controller
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com>
---
tools/hciattach.c | 22 +++++++++++++++-------
tools/hciattach.h | 1 +
2 files changed, 16 insertions(+), 7 deletions(-)
diff --git a/tools/hciattach.c b/tools/hciattach.c
index e4d5aa1..7f08243 100644
--- a/tools/hciattach.c
+++ b/tools/hciattach.c
@@ -1066,6 +1066,11 @@ struct uart_t uart[] = {
{ "texasalt", 0x0000, 0x0000, HCI_UART_LL, 115200, 115200,
FLOW_CTL, DISABLE_PM, NULL, texasalt, NULL },
+ /* ST-Ericsson CG2900 GPS FM Bluetooth combo controller */
+ { "cg2900", 0x0000, 0x0000, HCI_UART_STE, 115200, 115200,
+ FLOW_CTL, DISABLE_PM, NULL, NULL },
+
+
/* ST Microelectronics minikits based on STLC2410/STLC2415 */
{ "st", 0x0000, 0x0000, HCI_UART_H4, 57600, 115200,
FLOW_CTL, DISABLE_PM, NULL, st },
@@ -1157,10 +1162,10 @@ static struct uart_t * get_by_type(char *type)
}
/* Initialize UART driver */
-static int init_uart(char *dev, struct uart_t *u, int send_break, int raw)
+static int init_uart(char *dev, struct uart_t *u, int send_break, int raw, int line_disc)
{
struct termios ti;
- int fd, i;
+ int fd;
unsigned long flags = 0;
if (raw)
@@ -1217,8 +1222,7 @@ static int init_uart(char *dev, struct uart_t *u, int send_break, int raw)
}
/* Set TTY to N_HCI line discipline */
- i = N_HCI;
- if (ioctl(fd, TIOCSETD, &i) < 0) {
+ if (ioctl(fd, TIOCSETD, &line_disc) < 0) {
perror("Can't set line discipline");
return -1;
}
@@ -1243,7 +1247,7 @@ static void usage(void)
{
printf("hciattach - HCI UART driver initialization utility\n");
printf("Usage:\n");
- printf("\thciattach [-n] [-p] [-b] [-r] [-t timeout] [-s initial_speed] <tty> <type | id> [speed] [flow|noflow] [bdaddr]\n");
+ printf("\thciattach [-n] [-p] [-a line_disc_nr] [-b] [-r] [-t timeout] [-s initial_speed] <tty> <type | id> [speed] [flow|noflow] [bdaddr]\n");
printf("\thciattach -l\n");
}
@@ -1252,6 +1256,7 @@ int main(int argc, char *argv[])
struct uart_t *u = NULL;
int detach, printpid, raw, opt, i, n, ld, err;
int to = 10;
+ int line_disc = N_HCI;
int init_speed = 0;
int send_break = 0;
pid_t pid;
@@ -1264,8 +1269,11 @@ int main(int argc, char *argv[])
printpid = 0;
raw = 0;
- while ((opt=getopt(argc, argv, "bnpt:s:lr")) != EOF) {
+ while ((opt=getopt(argc, argv, "bnpt:s:lra:")) != EOF) {
switch(opt) {
+ case 'a':
+ line_disc = atoi(optarg);
+ break;
case 'b':
send_break = 1;
break;
@@ -1381,7 +1389,7 @@ int main(int argc, char *argv[])
alarm(to);
bcsp_max_retries = to;
- n = init_uart(dev, u, send_break, raw);
+ n = init_uart(dev, u, send_break, raw, line_disc);
if (n < 0) {
perror("Can't initialize device");
exit(1);
diff --git a/tools/hciattach.h b/tools/hciattach.h
index fed0d11..09b534d 100644
--- a/tools/hciattach.h
+++ b/tools/hciattach.h
@@ -39,6 +39,7 @@
#define HCI_UART_H4DS 3
#define HCI_UART_LL 4
#define HCI_UART_ATH3K 5
+#define HCI_UART_STE 6
#define HCI_UART_RAW_DEVICE 0
--
1.7.9.5

View File

@ -4,7 +4,7 @@
#
#############################################################
CCACHE_VERSION = 3.1.7
CCACHE_VERSION = 3.1.8
CCACHE_SITE = http://samba.org/ftp/ccache
CCACHE_SOURCE = ccache-$(CCACHE_VERSION).tar.bz2

View File

@ -7,12 +7,12 @@
CPANMINUS_VERSION = 1.5018
CPANMINUS_SOURCE = miyagawa-cpanminus-$(CPANMINUS_VERSION)-0-gee6cd30.tar.gz
CPANMINUS_SITE = https://github.com/miyagawa/cpanminus/tarball/$(CPANMINUS_VERSION)
CPANMINUS_DEPENDENCIES = perl $(call qstrip,$(BR2_PACKAGE_CPANMINUS_NATIVE_DEPENDENCIES))
CPANMINUS_DEPENDENCIES = host-qemu perl $(call qstrip,$(BR2_PACKAGE_CPANMINUS_NATIVE_DEPENDENCIES))
CPANMINUS_RUN_PERL = $(QEMU_USER) $(STAGING_DIR)/usr/bin/perl
CPANMINUS_ARCHNAME = $(shell $(CPANMINUS_RUN_PERL) -MConfig -e "print Config->{archname}")
CPANMINUS_PERL_LIB = $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)
CPANMINUS_PERL_SITELIB = $(TARGET_DIR)/usr/lib/perl5/site_perl/$(PERL_VERSION)
CPANMINUS_PERL_LIB = $(STAGING_DIR)/usr/lib/perl
CPANMINUS_PERL_SITELIB = $(TARGET_DIR)/usr/lib/perl
CPANMINUS_PERL_ARCHLIB = $(CPANMINUS_PERL_LIB)/$(CPANMINUS_ARCHNAME)
CPANMINUS_PERL_SITEARCH = $(CPANMINUS_PERL_SITELIB)/$(CPANMINUS_ARCHNAME)
CPANMINUS_PERL5LIB = $(CPANMINUS_PERL_SITEARCH):$(CPANMINUS_PERL_SITELIB):$(CPANMINUS_PERL_ARCHLIB):$(CPANMINUS_PERL_LIB)
@ -27,8 +27,8 @@ define CPANMINUS_INSTALL_TARGET_CMDS
echo "PERL5LIB=$(CPANMINUS_PERL5LIB) $(CPANMINUS_RUN_PERL) \"\$$@\"" >>$(@D)/run_perl
chmod +x $(@D)/run_perl
PERL5LIB=$(CPANMINUS_PERL5LIB) \
PERL_MM_OPT="DESTDIR=$(TARGET_DIR) PERL=$(@D)/run_perl PERL_LIB=$(CPANMINUS_PERL_LIB) PERL_ARCHLIB=$(CPANMINUS_PERL_ARCHLIB)" \
PERL_MB_OPT="--destdir $(TARGET_DIR)" \
PERL_MM_OPT="DESTDIR=$(CPANMINUS_PERL_SITELIB) PERL=$(@D)/run_perl PERL_LIB=$(CPANMINUS_PERL_LIB) PERL_ARCHLIB=$(CPANMINUS_PERL_ARCHLIB)" \
PERL_MB_OPT="--destdir $(CPANMINUS_PERL_SITELIB)" \
RUN_PERL="$(@D)/run_perl" \
$(CPANMINUS_RUN_PERL) $(@D)/cpanm \
--perl=$(@D)/run_perl \
@ -36,7 +36,7 @@ define CPANMINUS_INSTALL_TARGET_CMDS
--no-man-pages \
$(CPANMINUS_MIRROR) \
$(call qstrip,$(BR2_PACKAGE_CPANMINUS_MODULES))
find $(CPANMINUS_PERL_SITEARCH) -type f -name *.bs -exec rm -f {} \;
-find $(CPANMINUS_PERL_SITEARCH) -type f -name *.bs -exec rm -f {} \;
endef
else
define CPANMINUS_INSTALL_TARGET_CMDS

62
package/gd/Config.in Normal file
View File

@ -0,0 +1,62 @@
config BR2_PACKAGE_GD
bool "gd"
help
GD is a graphics library. It allows your code to quickly
draw images complete with lines, arcs, text, multiple
colours, cut and paste from other images, flood fills, and
write out the result as a PNG file. This is particularly
useful in World Wide Web applications, where PNG is one of
the formats accepted for inline images by most browsers.
http://www.boutell.com/gd/
if BR2_PACKAGE_GD
menu "gd tools"
config BR2_PACKAGE_GD_ANNOTATE
bool "annotate"
config BR2_PACKAGE_GD_BDFTOGD
bool "bdftogd"
depends on BR2_PACKAGE_PERL
config BR2_PACKAGE_GD_GD2COPYPAL
bool "gd2copypal"
config BR2_PACKAGE_GD_GD2TOGIF
bool "gd2togif"
config BR2_PACKAGE_GD_GD2TOPNG
bool "gd2topng"
select BR2_PACKAGE_LIBPNG
config BR2_PACKAGE_GD_GDCMPGIF
bool "gdcmpgif"
config BR2_PACKAGE_GD_GDPARTTOPNG
bool "gdparttopng"
select BR2_PACKAGE_LIBPNG
config BR2_PACKAGE_GD_GDTOPNG
bool "gdtopng"
select BR2_PACKAGE_LIBPNG
config BR2_PACKAGE_GD_GIFTOGD2
bool "giftogd2"
config BR2_PACKAGE_GD_PNGTOGD
bool "pngtogd"
select BR2_PACKAGE_LIBPNG
config BR2_PACKAGE_GD_PNGTOGD2
bool "pngtogd2"
select BR2_PACKAGE_LIBPNG
config BR2_PACKAGE_GD_WEBPNG
bool "webpng"
select BR2_PACKAGE_LIBPNG
endmenu
endif

View File

@ -0,0 +1,28 @@
Patch from Gentoo:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/gd/files/gd-2.0.35-fontconfig.patch?view=log
fix from upstream
http://bugs.gentoo.org/363367
# HG changeset patch
# User tabe
# Date 1239812355 0
# Node ID 3ea283efcdafcb2acc1dd0ace1d3d48da6d8cec8
# Parent 4f29a877875f63cee5a64e7bea406a61882a565e
fixed FS#199
199, Fixed useFontConfig() to work as documented (Ethan Merritt)
diff -r 4f29a877875f -r 3ea283efcdaf gdft.c
--- a/gdft.c Sat Apr 04 12:00:37 2009 +0000
+++ b/gdft.c Wed Apr 15 16:19:15 2009 +0000
@@ -1659,7 +1659,7 @@
BGD_DECLARE(int) gdFTUseFontConfig(int flag)
{
#ifdef HAVE_LIBFONTCONFIG
- fontConfigFlag = 1;
+ fontConfigFlag = flag;
return 1;
#else
return 0;

View File

@ -0,0 +1,20 @@
Patch from Gentoo:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/gd/files/gd-2.0.35-maxcolors.patch?view=log
http://bugs.gentoo.org/292130
fix in usptream repo already
--- gd-2.0.35/gd_gd.c
+++ gd-2.0.35/gd_gd.c
@@ -44,6 +44,10 @@
{
goto fail1;
}
+ if (im->colorsTotal > gdMaxColors)
+ {
+ goto fail1;
+ }
}
/* Int to accommodate truecolor single-color transparency */
if (!gdGetInt (&im->transparent, in))

View File

@ -0,0 +1,51 @@
[PATCH] gd_gd2: provide dummy implementations for all public symbols when !zlib
gd_gd2.c only provides dummy implementations for some of it's public symbols
when zlib isn't found, causing build failures in several of the tools.
Fix it by providing dummy implementations for all of them.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
gd_gd2.c | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Index: gd-2.0.35/gd_gd2.c
===================================================================
--- gd-2.0.35.orig/gd_gd2.c
+++ gd-2.0.35/gd_gd2.c
@@ -1068,4 +1068,34 @@
fprintf (stderr, "GD2 support is not available - no libz\n");
return NULL;
}
+
+BGD_DECLARE(gdImagePtr) gdImageCreateFromGd2Part (FILE * inFile, int srcx, int srcy, int w, int h)
+{
+ fprintf (stderr, "GD2 support is not available - no libz\n");
+ return NULL;
+}
+
+BGD_DECLARE(gdImagePtr) gdImageCreateFromGd2PartPtr (int size, void *data, int srcx, int srcy, int w,
+ int h)
+{
+ fprintf (stderr, "GD2 support is not available - no libz\n");
+ return NULL;
+}
+
+BGD_DECLARE(gdImagePtr) gdImageCreateFromGd2PartCtx (gdIOCtx * in, int srcx, int srcy, int w, int h)
+{
+ fprintf (stderr, "GD2 support is not available - no libz\n");
+ return NULL;
+}
+
+BGD_DECLARE(void) gdImageGd2 (gdImagePtr im, FILE * outFile, int cs, int fmt)
+{
+ fprintf (stderr, "GD2 support is not available - no libz\n");
+}
+
+BGD_DECLARE(void *) gdImageGd2Ptr (gdImagePtr im, int cs, int fmt, int *size)
+{
+ fprintf (stderr, "GD2 support is not available - no libz\n");
+ return NULL;
+}
#endif /* HAVE_LIBZ */

87
package/gd/gd.mk Normal file
View File

@ -0,0 +1,87 @@
################################################################################
#
# gd
#
################################################################################
GD_VERSION = 2.0.35
GD_SOURCE = gd-$(GD_VERSION).tar.bz2
GD_SITE = http://distfiles.gentoo.org/distfiles
# needed because of configure.ac timestamp
GD_AUTORECONF = YES
GD_INSTALL_STAGING = YES
GD_LICENSE = GD license
GD_LICENSE_FILES = COPYING
GD_CONF_OPT = --without-x --disable-rpath
ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
GD_DEPENDENCIES += fontconfig
GD_CONF_OPT += --with-fontconfig
GD_CONF_ENV += ac_cv_path_FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
endif
ifeq ($(BR2_PACKAGE_JPEG),y)
GD_DEPENDENCIES += jpeg
GD_CONF_OPT += --with-jpeg
endif
ifeq ($(BR2_PACKAGE_LIBPNG),y)
GD_DEPENDENCIES += libpng
GD_CONF_OPT += --with-png
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXPM),y)
GD_DEPENDENCIES += xlib_libXpm
GD_CONF_OPT += --with-xpm
endif
ifeq ($(BR2_PACKAGE_ZLIB),y)
GD_DEPENDENCIES += zlib
endif
ifeq ($(BR2_PACKAGE_GETTEXT),y)
GD_DEPENDENCIES += gettext
else
# configure.ac has newer timestamp than aclocal.m4 / configure, so we need
# to autoreconf to regenerate them (or set configure.ac timestamp to older
# than them) to make the Makefile happy.
# configure.ac refers to AM_ICONV which we only have if gettext is enabled,
# so add a dummy definition elsewise
define GD_FIXUP_ICONV
echo 'm4_ifndef([AM_ICONV],[m4_define([AM_ICONV],[:])])' \
>> $(@D)/acinclude.m4
endef
GD_PRE_CONFIGURE_HOOKS += GD_FIXUP_ICONV
endif
define GD_FIXUP_GDLIB_CONFIG
$(SED) 's%prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
-e 's%exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
$(STAGING_DIR)/usr/bin/gdlib-config
endef
GD_POST_INSTALL_STAGING_HOOKS += GD_FIXUP_GDLIB_CONFIG
GD_TOOLS_ += gdlib-config
GD_TOOLS_$(BR2_PACKAGE_GD_ANNOTATE) += annotate
GD_TOOLS_$(BR2_PACKAGE_GD_BDFTOGD) += bdftogd
GD_TOOLS_$(BR2_PACKAGE_GD_GD2COPYPAL) += gd2copypal
GD_TOOLS_$(BR2_PACKAGE_GD_GD2TOGIF) += gd2togif
GD_TOOLS_$(BR2_PACKAGE_GD_GD2TOPNG) += gd2topng
GD_TOOLS_$(BR2_PACKAGE_GD_GDCMPGIF) += gdcmpgif
GD_TOOLS_$(BR2_PACKAGE_GD_GDPARTTOPNG) += gdparttopng
GD_TOOLS_$(BR2_PACKAGE_GD_GDTOPNG) += gdtopng
GD_TOOLS_$(BR2_PACKAGE_GD_GIFTOGD2) += giftogd2
GD_TOOLS_$(BR2_PACKAGE_GD_PNGTOGD) += pngtogd
GD_TOOLS_$(BR2_PACKAGE_GD_PNGTOGD2) += pngtogd2
GD_TOOLS_$(BR2_PACKAGE_GD_WEBPNG) += webpng
define GD_REMOVE_TOOLS
rm -f $(addprefix $(TARGET_DIR)/usr/bin/,$(GD_TOOLS_))
endef
GD_POST_INSTALL_TARGET_HOOKS += GD_REMOVE_TOOLS
$(eval $(autotools-package))

11
package/libebml/Config.in Normal file
View File

@ -0,0 +1,11 @@
config BR2_PACKAGE_LIBEBML
bool "libebml"
depends on BR2_INSTALL_LIBSTDCPP
help
Access library for the EBML (Extensible Binary Meta
Language, a binary derivative of XML) format.
http://matroska.org
comment "libebml requires a toolchain with C++ support"
depends on !BR2_INSTALL_LIBSTDCPP

View File

@ -0,0 +1,26 @@
#############################################################
#
# libebml
#
#############################################################
LIBEBML_VERSION = 1.2.2
LIBEBML_SOURCE = libebml-$(LIBEBML_VERSION).tar.bz2
LIBEBML_SITE = http://dl.matroska.org/downloads/libebml/
LIBEBML_INSTALL_STAGING = YES
LIBEBML_LICENSE = LGPLv2.1+
LIBEBML_LICENSE_FILES = LICENSE.LGPL
define LIBEBML_BUILD_CMDS
$(MAKE) -C $(@D)/make/linux CROSS="$(CCACHE) $(TARGET_CROSS)"
endef
define LIBEBML_INSTALL_STAGING_CMDS
$(MAKE) -C $(@D)/make/linux prefix=$(STAGING_DIR)/usr install
endef
define LIBEBML_INSTALL_TARGET_CMDS
$(MAKE) -C $(@D)/make/linux prefix=$(TARGET_DIR)/usr install
endef
$(eval $(generic-package))

View File

@ -0,0 +1,12 @@
config BR2_PACKAGE_LIBMATROSKA
bool "libmatroska"
select BR2_PACKAGE_LIBEBML
depends on BR2_INSTALL_LIBSTDCPP
help
Extensible open standard audio/video container format access
library.
http://matroska.org
comment "libmatroska requires a toolchain with C++ support"
depends on !BR2_INSTALL_LIBSTDCPP

View File

@ -0,0 +1,27 @@
#############################################################
#
# libmatroska
#
#############################################################
LIBMATROSKA_VERSION = 1.3.0
LIBMATROSKA_SOURCE = libmatroska-$(LIBMATROSKA_VERSION).tar.bz2
LIBMATROSKA_SITE = http://dl.matroska.org/downloads/libmatroska/
LIBMATROSKA_INSTALL_STAGING = YES
LIBMATROSKA_LICENSE = LGPLv2.1+
LIBMATROSKA_LICENSE_FILES = LICENSE.LGPL
LIBMATROSKA_DEPENDENCIES = libebml
define LIBMATROSKA_BUILD_CMDS
$(MAKE) -C $(@D)/make/linux CROSS="$(CCACHE) $(TARGET_CROSS)"
endef
define LIBMATROSKA_INSTALL_STAGING_CMDS
$(MAKE) -C $(@D)/make/linux prefix=$(STAGING_DIR)/usr install
endef
define LIBMATROSKA_INSTALL_TARGET_CMDS
$(MAKE) -C $(@D)/make/linux prefix=$(TARGET_DIR)/usr install
endef
$(eval $(generic-package))

View File

@ -7,10 +7,10 @@ Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: libroxml-2.1.0/Makefile
Index: a/Makefile
===================================================================
--- libroxml-2.1.0.orig/Makefile
+++ libroxml-2.1.0/Makefile
--- a/Makefile
+++ b/Makefile
@@ -41,7 +41,7 @@
# options

View File

@ -2,7 +2,7 @@
# libroxml
#
LIBROXML_VERSION = 2.2.0
LIBROXML_VERSION = 2.2.1
LIBROXML_SITE = http://libroxml.googlecode.com/files
LIBROXML_INSTALL_STAGING = YES

View File

@ -12,9 +12,17 @@ config BR2_PACKAGE_GSTREAMER_GST_DEBUG
default y
depends on BR2_PACKAGE_GSTREAMER
help
Enable support for the gst-debug tracing functionality
in gstreamer. This has limited CPU overhead, but does
increase the rootfs size somewhat.
Enable support for the gst-debug tracing functionality in gstreamer.
This has limited CPU overhead, but does increase the rootfs size
somewhat.
config BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY
bool "enable plugin registry"
default y
depends on BR2_PACKAGE_GSTREAMER
help
Enable support for the GStreamer plugin registry. This may increase
the launch-time for a GStreamer application.
comment "gstreamer requires a toolchain with WCHAR support"
depends on !BR2_USE_WCHAR

View File

@ -21,7 +21,8 @@ GSTREAMER_CONF_OPT = \
--disable-tests \
--disable-failing-tests \
--disable-loadsave \
$(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug)
$(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug) \
$(if $(BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY),,--disable-registry)
GSTREAMER_DEPENDENCIES = libglib2 host-pkgconf

View File

@ -1,53 +0,0 @@
Add qemu support
see https://rt.perl.org/rt3//Public/Bug/Display.html?id=114798
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Index: b/Configure
===================================================================
--- a/Configure
+++ b/Configure
@@ -2837,6 +2837,9 @@
;;
*) echo "Using usrinc $usrinc." >&4 ;;
esac
+ case "$targetrun" in
+ *qemu*) targethost=dummy ;;
+ esac
case "$targethost" in
'') echo "Targethost not defined." >&4; croak=y ;;
*) echo "Using targethost $targethost." >&4
@@ -2868,7 +2871,7 @@
case "$targetfrom" in
'') targetfrom=scp ;;
esac
- run=$run-$targetrun
+ run=$run-`basename $targetrun`
to=$to-$targetto
from=$from-$targetfrom
case "$targetdir" in
@@ -2908,6 +2911,14 @@
$targetrun -l $targetuser $targethost "cd \$cwd && ./\$exe \$@"
EOF
;;
+ *qemu*)
+ to=:
+ from=:
+ cat >$run <<EOF
+#!/bin/sh
+$targetrun -L $qemulib "\$@"
+EOF
+ ;;
*) echo "Unknown targetrun '$targetrun'" >&4
exit 1
;;
@@ -5048,7 +5059,7 @@
echo " ";
echo "Checking if your compiler accepts $flag" 2>&1;
echo "int main(void) { return 0; }" > gcctest.c;
-if $cc -O2 $flag -o gcctest gcctest.c 2>gcctest.out && ./gcctest; then
+if $cc -O2 $flag -o gcctest gcctest.c 2>gcctest.out && $run ./gcctest; then
echo "Yes, it does." 2>&1;
if $test -s gcctest.out ; then
echo "But your platform does not like it:";

View File

@ -1,24 +0,0 @@
Don't use RUN with make (only for perl)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Index: b/make_ext.pl
===================================================================
--- a/make_ext.pl
+++ b/make_ext.pl
@@ -458,11 +458,13 @@
# Give makefile an opportunity to rewrite itself.
# reassure users that life goes on...
my @args = ('config', @$pass_through);
- system(@run, @make, @args) and print "@run @make @args failed, continuing anyway...\n";
+# system(@run, @make, @args) and print "@run @make @args failed, continuing anyway...\n";
+ system(@make, @args) and print "@make @args failed, continuing anyway...\n";
}
my @targ = ($target, @$pass_through);
print "Making $target in $ext_dir\n@run @make @targ\n";
- my $code = system(@run, @make, @targ);
+# my $code = system(@run, @make, @targ);
+ my $code = system(@make, @targ);
die "Unsuccessful make($ext_dir): code=$code" if $code != 0;
chdir $return_dir || die "Cannot cd to $return_dir: $!";

View File

@ -1,37 +0,0 @@
Add RUN
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Index: b/mkppport
===================================================================
--- a/mkppport
+++ b/mkppport
@@ -1,6 +1,7 @@
use strict;
use warnings;
+use Config;
use Getopt::Long;
use File::Spec;
use File::Compare qw( compare );
@@ -136,14 +137,18 @@
#----------------------------------------------
sub run
{
+ my @run = $Config{run};
+ @run = () if not defined $run[0] or $run[0] eq '';
my @args = ("-I" . File::Spec->catdir((File::Spec->updir) x 2, 'lib'), @_);
my $run = $perl =~ m/\s/ ? qq("$perl") : $perl;
for (@args) {
$_ = qq("$_") if $^O eq 'VMS' && /^[^"]/;
$run .= " $_";
}
- print "running $run\n";
- system $run and die "$run failed: $?\n";
+# print "running $run\n";
+# system $run and die "$run failed: $?\n";
+ print "running ", join(' ', @run, $run), "\n";
+ system join(' ', @run, $run) and die "@run $run failed: $?\n";
}
__END__

View File

@ -13,8 +13,11 @@ PERL_LICENSE_FILES = Artistic
PERL_INSTALL_STAGING = YES
PERL_CROSS_VERSION = 0.7
PERL_CROSS_BASE_VERSION = 5.$(PERL_VERSION_MAJOR).0
PERL_CROSS_SITE = http://download.berlios.de/perlcross
PERL_CROSS_SOURCE = perl-5.$(PERL_VERSION_MAJOR).0-cross-$(PERL_CROSS_VERSION).tar.gz
PERL_CROSS_SOURCE = perl-$(PERL_CROSS_BASE_VERSION)-cross-$(PERL_CROSS_VERSION).tar.gz
PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_CROSS_BASE_VERSION))delta.pod
PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
# We use the perlcross hack to cross-compile perl. It should
# be extracted over the perl sources, so we don't define that
@ -32,6 +35,11 @@ define PERL_CROSS_EXTRACT
endef
PERL_POST_EXTRACT_HOOKS += PERL_CROSS_EXTRACT
define PERL_CROSS_SET_POD
$(SED) s/$(PERL_CROSS_OLD_POD)/$(PERL_CROSS_NEW_POD)/g $(@D)/Makefile
endef
PERL_POST_PATCH_HOOKS += PERL_CROSS_SET_POD
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
PERL_DEPENDENCIES += berkeleydb
endif
@ -39,31 +47,22 @@ ifeq ($(BR2_PACKAGE_GDBM),y)
PERL_DEPENDENCIES += gdbm
endif
# Normally, --mode=cross should automatically do the two steps
# below, but it doesn't work for some reason.
PERL_HOST_CONF_OPT = \
--mode=buildmini \
--target=$(GNU_TARGET_NAME) \
--target-arch=$(GNU_TARGET_NAME) \
--set-target-name=$(GNU_TARGET_NAME)
# We have to override LD, because an external multilib toolchain ld is not
# wrapped to provide the required sysroot options. We also can't use ccache
# because the configure script doesn't support it.
PERL_CONF_OPT = \
--mode=target \
--target=$(GNU_TARGET_NAME) \
--target-tools-prefix=$(TARGET_CROSS) \
--prefix=/usr \
-Dld="$(TARGET_CC_NOCCACHE)" \
-A ccflags="$(TARGET_CFLAGS)" \
-A ldflags="$(TARGET_LDFLAGS) -lm" \
-A mydomain="" \
-A myhostname="$(BR2_TARGET_GENERIC_HOSTNAME)" \
-A myuname="Buildroot $(BR2_VERSION_FULL)" \
-A osname=linux \
-A osvers=$(LINUX_VERSION) \
-A perlamdin=root
-Dccflags="$(TARGET_CFLAGS)" \
-Dldflags="$(TARGET_LDFLAGS) -lm" \
-A define:mydomain="" \
-A define:myhostname="$(BR2_TARGET_GENERIC_HOSTNAME)" \
-A define:myuname="Buildroot $(BR2_VERSION_FULL)" \
-A define:osname=linux \
-A define:osvers=$(LINUX_VERSION) \
-A define:perladmin=root
ifeq ($(shell expr $(PERL_VERSION_MAJOR) % 2), 1)
PERL_CONF_OPT += -Dusedevel
@ -79,8 +78,7 @@ PERL_CONF_OPT += --only-mod=$(subst $(space),$(comma),$(PERL_MODULES))
endif
define PERL_CONFIGURE_CMDS
(cd $(@D); HOSTCC='$(HOSTCC_NOCACHE)' ./configure $(PERL_HOST_CONF_OPT))
(cd $(@D); ./configure $(PERL_CONF_OPT))
(cd $(@D); HOSTCC='$(HOSTCC_NOCACHE)' ./configure $(PERL_CONF_OPT))
$(SED) 's/UNKNOWN-/Buildroot $(BR2_VERSION_FULL) /' $(@D)/patchlevel.h
endef

View File

@ -0,0 +1,10 @@
config BR2_PACKAGE_SNOWBALL_HDMISERVICE
bool "snowball-hdmiservice"
depends on BR2_TOOLCHAIN_HAS_THREADS
help
HDMI userspace control daemon
This package contains the HDMI userspace control daemon for the
snowball board
http://www.igloocommunity.org

View File

@ -0,0 +1,41 @@
#############################################################
#
# snowball-hdmiservice
#
#############################################################
SNOWBALL_HDMISERVICE_VERSION = f75c99d1c52707240a78b4ba78e41d20d3aa3b08
SNOWBALL_HDMISERVICE_SITE = git://igloocommunity.org/git/bsp/hdmiservice.git
SNOWBALL_HDMISERVICE_LICENSE = MIT
SNOWBALL_HDMISERVICE_LICENSE_FILES = debian/copyright
SNOWBALL_HDMISERVICE_INSTALL_STAGING = YES
define SNOWBALL_HDMISERVICE_BUILD_CMDS
$(MAKE) -C $(@D) CC="$(TARGET_CC) $(TARGET_CFLAGS)"
endef
define SNOWBALL_HDMISERVICE_INSTALL_STAGING_CMDS
$(MAKE) -C $(@D) CC="$(TARGET_CC) $(TARGET_CFLAGS)" DESTDIR=$(STAGING_DIR) install
endef
define SNOWBALL_HDMISERVICE_INSTALL_TARGET_CMDS
$(MAKE) -C $(@D) CC="$(TARGET_CC) $(TARGET_CFLAGS)" DESTDIR=$(TARGET_DIR) install
endef
define SNOWBALL_HDMISERVICE_UNINSTALL_STAGING_CMDS
rm -f $(STAGING_DIR)/usr/lib/hdmiservice.so
rm -f $(STAGING_DIR)/usr/bin/hdmistart
rm -f $(STAGING_DIR)/usr/include/hdmi_service_api.h
rm -f $(STAGING_DIR)/usr/include/hdmi_service_local.h
endef
define SNOWBALL_HDMISERVICE_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/lib/hdmiservice.so
rm -f $(TARGET_DIR)/usr/bin/hdmistart
endef
define SNOWBALL_HDMISERVICE_CLEAN_CMDS
$(MAKE) -C $(@D) clean
endef
$(eval $(generic-package))

View File

@ -0,0 +1,14 @@
config BR2_PACKAGE_SNOWBALL_INIT
bool "snowball-init"
# Runtime dependency, needed by snowball startup script
select BR2_PACKAGE_BLUEZ_UTILS
depends on !BR2_avr32
depends on BR2_USE_WCHAR # libglib2
depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, alsa-lib
depends on BR2_USE_MMU # dbus
select BR2_PACKAGE_UX500_FIRMWARE
help
Snowball init scripts
http://www.igloocommunity.org

View File

@ -0,0 +1,15 @@
#############################################################
#
# snowball-init
#
#############################################################
SNOWBALL_INIT_VERSION = b064be21de25729039e5e54037bbdd2e25cfd5b7
SNOWBALL_INIT_SITE = git://igloocommunity.org/git/bsp/snowball-init.git
SNOWBALL_INIT_LICENSE = BSD-4c
SNOWBALL_INIT_LICENSE_FILES = debian/copyright
define SNOWBALL_INIT_INSTALL_TARGET_CMDS
$(INSTALL) -D -m 0755 $(@D)/snowball $(TARGET_DIR)/etc/init.d/S50snowball
endef
$(eval $(generic-package))

View File

@ -0,0 +1,7 @@
config BR2_PACKAGE_UX500_FIRMWARE
bool "ux500-firmware"
help
This package provides various binary firmware files (closed binary blobs)
for the Azurewave AW-NH580 combo module (wifi, bt, gps).
https://launchpad.net/~igloocommunity-maintainers/+archive/snowball/+files/

View File

@ -0,0 +1,22 @@
#############################################################
#
# ux500-firmware
#
#############################################################
UX500_FIRMWARE_VERSION = 1.1.3-6
UX500_FIRMWARE_SOURCE = ux500-firmware_$(UX500_FIRMWARE_VERSION)linaro1.tar.gz
UX500_FIRMWARE_SITE = https://launchpad.net/~igloocommunity-maintainers/+archive/snowball/+files/
UX500_FIRMWARE_LICENSE = Snowball click-wrap license
UX500_FIRMWARE_LICENSE_FILES = license.txt
UX500_FIRMWARE_REDISTRIBUTE = NO
# The CG2900 linux driver has to load firmware named CG29XX_* but the firmware
# filenames contained in this package are CG2900_* hence the code below
define UX500_FIRMWARE_INSTALL_TARGET_CMDS
$(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
for f in $(TARGET_DIR)/lib/firmware/CG2900* ; do \
mv $$f $${f/CG2900/CG29XX}; \
done
endef
$(eval $(generic-package))

View File

@ -3,6 +3,23 @@ if BR2_TOOLCHAIN_EXTERNAL
choice
prompt "Toolchain"
config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
bool "Linaro 2012.11"
depends on BR2_arm
depends on BR2_cortex_a8 || BR2_cortex_a9
select BR2_TOOLCHAIN_EXTERNAL_GLIBC
select BR2_TOOLCHAIN_HAS_NATIVE_RPC
select BR2_INSTALL_LIBSTDCPP
help
Linaro toolchain for the ARM architecture. It uses Linaro
GCC 2012.11 (based on gcc 4.7), Linaro GDB 2012.10 (based on
GDB 7.5), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
calling convention, and uses the VFPv3-D16 FPU instructions.
To use this toolchain, you must disable soft float usage.
config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
bool "Linaro 2012.10"
depends on BR2_arm
@ -37,22 +54,9 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
To use this toolchain, you must disable soft float usage.
config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
bool "Linaro 2012.08"
comment "Linaro toolchains available for Cortex-A{8,9}"
depends on BR2_arm
depends on BR2_cortex_a8 || BR2_cortex_a9
select BR2_TOOLCHAIN_EXTERNAL_GLIBC
select BR2_TOOLCHAIN_HAS_NATIVE_RPC
select BR2_INSTALL_LIBSTDCPP
help
Linaro toolchain for the ARM architecture. It uses Linaro
GCC 2012.08 (based on gcc 4.7), Linaro GDB 2012.06 (based on
GDB 7.4), eglibc 2.15. It generates code that runs on all
Cortex-A profile devices, but tuned for the Cortex-A9. The
code generated is Thumb 2, with the hard floating point
calling convention, and uses the VFPv3-D16 FPU instructions.
To use this toolchain, you must disable soft float usage.
depends on !BR2_cortex_a8 && !BR2_cortex_a9
config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
bool "Sourcery CodeBench ARM 2012.03"
@ -624,9 +628,9 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
config BR2_TOOLCHAIN_EXTERNAL_PREFIX
string
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203

View File

@ -184,15 +184,15 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gn
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.08/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.08-20120827_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.09/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.09-20120921_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.10/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.11/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.11-20121123_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2