Add support for the new nconf configuration tool

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2010-08-21 17:21:40 +02:00
parent 52a142a631
commit 8b6585a9d3
3 changed files with 25 additions and 7 deletions

View File

@ -28,7 +28,7 @@ CONFIG_CONFIG_IN=Config.in
CONFIG=package/config
DATE:=$(shell date +%Y%m%d)
noconfig_targets:=menuconfig gconfig xconfig config oldconfig randconfig \
noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig allyesconfig allnoconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
source-check help
@ -490,6 +490,14 @@ menuconfig: $(BUILD_DIR)/buildroot-config/mconf
test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
fi
nconfig: $(BUILD_DIR)/buildroot-config/nconf
@mkdir -p $(BUILD_DIR)/buildroot-config
@if ! KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(BUILD_DIR)/buildroot-config/autoconf.h \
BUILDROOT_CONFIG=$(CONFIG_DIR)/.config $< $(CONFIG_CONFIG_IN); then \
test -f $(CONFIG_DIR)/.config.cmd || rm -f $(CONFIG_DIR)/.config; \
fi
config: $(BUILD_DIR)/buildroot-config/conf
@mkdir -p $(BUILD_DIR)/buildroot-config
@KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \

View File

@ -177,6 +177,9 @@ hostprogs-y := conf qconf gconf kxgettext
ifeq ($(MAKECMDGOALS),nconfig)
hostprogs-y += nconf
endif
ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
hostprogs-y += nconf
endif
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf

View File

@ -1,12 +1,19 @@
---
Makefile | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
Makefile | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
Index: config.new/Makefile
Index: config/Makefile
===================================================================
--- config.new.orig/Makefile
+++ config.new/Makefile
@@ -181,14 +181,23 @@
--- config.orig/Makefile
+++ config/Makefile
@@ -177,18 +177,30 @@
ifeq ($(MAKECMDGOALS),nconfig)
hostprogs-y += nconf
endif
+ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
+ hostprogs-y += nconf
+endif
ifeq ($(MAKECMDGOALS),menuconfig)
hostprogs-y += mconf
endif