fbgrab: bump to version 1.1

[Peter: also update URL in Config.in]
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
gilles.talis@gmail.com 2013-07-03 17:34:35 -07:00 committed by Peter Korsgaard
parent 7f5177d3fd
commit 8916f9d80e
4 changed files with 42 additions and 26 deletions

View File

@ -5,4 +5,4 @@ config BR2_PACKAGE_FBGRAB
FBGrab is a framebuffer screenshot program, capturing the linux
frambuffer and converting it to a png-picture.
http://hem.bredband.net/gmogmo/fbgrab
http://fbgrab.monells.se/

View File

@ -0,0 +1,39 @@
From 2283817b9aed0b6228d0255d5aba7968379c9854 Mon Sep 17 00:00:00 2001
From: Gilles Talis <gilles.talis@gmail.com>
Date: Wed, 3 Jul 2013 11:40:36 -0700
Subject: [PATCH] fbgrab: A proper Makefile for cross compiling
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Respect to the CC, CFLAGS and LDFLAGS is required for cross compiling in
Buildroot. And there's no need to run the source through splint.
Reworked original patch from: Daniel Nyström <daniel.nystrom@timeterminal.se>
Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
Makefile | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index aae16e6..2d6b6fc 100644
--- a/Makefile
+++ b/Makefile
@@ -3,8 +3,10 @@
### modular. So this is a simple gnu Makefile...
###
-fbgrab: fbgrab.c
- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
+LDFLAGS += -lpng -lz
+
+fbgrab: fbgrab.o
+ $(CC) $(LDFLAGS) fbgrab.o -o $@
install:
install fbgrab /usr/bin/fbgrab
--
1.7.4.1

View File

@ -1,23 +0,0 @@
[PATCH] fbgrab: A proper Makefile for cross compiling
Respect to the CC, CFLAGS and LDFLAGS is required for cross compiling in
Buildroot. And there's no need to run the source through splint.
Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
--- fbgrab-1.0.orig/Makefile 2010-12-07 22:57:24.000000000 +0100
+++ fbgrab-1.0/Makefile 2010-12-07 22:58:36.000000000 +0100
@@ -3,9 +3,10 @@
### modular. So this is a simple gnu Makefile...
###
-fbgrab: fbgrab.c
- splint +posixlib fbgrab.c
- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
+LDFLAGS += -lpng -lz
+
+fbgrab: fbgrab.o
+ $(CC) $(LDFLAGS) fbgrab.o -o $@
install:
strip fbgrab

View File

@ -4,9 +4,9 @@
#
################################################################################
FBGRAB_VERSION = 1.0
FBGRAB_VERSION = 1.1
FBGRAB_SOURCE = fbgrab-$(FBGRAB_VERSION).tar.gz
FBGRAB_SITE = http://hem.bredband.net/gmogmo/fbgrab
FBGRAB_SITE = http://fbgrab.monells.se
FBGRAB_DEPENDENCIES = libpng
FBGRAB_LICENSE = GPLv2
FBGRAB_LICENSE_FILES = COPYING