httping: fix math library linking

Add the math library directive '-lm' to linker options at the end.
The order of the math library directive '-lm' matters.

Fixes:

  http://autobuild.buildroot.net/results/843/84382290696e72c23995f5ed020ad5c157817012/

Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yuvaraj Patil 2014-07-23 17:17:22 +05:30 committed by Thomas Petazzoni
parent ffc9e4680c
commit 8793ddcd6f
1 changed files with 25 additions and 0 deletions

View File

@ -0,0 +1,25 @@
Move LDFLAGS+=-lm option to the end.
The order of the math library directive '-lm' matters.
Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com>
---
diff -Nurp httping-2.3.4_orig/Makefile httping-2.3.4/Makefile
--- httping-2.3.4_orig/Makefile 2014-07-23 16:16:36.495546288 +0530
+++ httping-2.3.4/Makefile 2014-07-23 16:18:42.547541002 +0530
@@ -37,7 +37,6 @@ DEBUG=yes
WFLAGS=-Wall -W
OFLAGS=
CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\" -DLOCALEDIR=\"$(LOCALEDIR)\"
-LDFLAGS+=-lm
PACKAGE=$(TARGET)-$(VERSION)
PREFIX?=/usr
@@ -97,6 +96,8 @@ ifeq ($(ARM),yes)
CC=arm-linux-gcc
endif
+LDFLAGS+=-lm
+
all: $(TARGET) $(TRANSLATIONS)
$(TARGET): $(OBJS)