package: add 'pv' (Pipe-Viewer)

Signed-off-by: Roeland Van Praet <roelvp@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Roeland Van Praet 2011-10-07 09:04:26 +02:00 committed by Peter Korsgaard
parent 811fab1b26
commit 7f7cff5239
4 changed files with 41 additions and 0 deletions

View File

@ -31,6 +31,7 @@ source "package/oprofile/Config.in"
source "package/strace/Config.in"
source "package/whetstone/Config.in"
source "package/valgrind/Config.in"
source "package/pv/Config.in"
endmenu
menu "Development tools"

8
package/pv/Config.in Normal file
View File

@ -0,0 +1,8 @@
config BR2_PACKAGE_PV
bool "pv"
help
Pipe Viewer - is a terminal-based tool for
monitoring the progress of data through a
pipeline.
http://www.ivarch.com/programs/pv.shtml

View File

@ -0,0 +1,21 @@
[PATCH] fix linker variable
The linker variable LD was always set to 'ld' instead of the value from
the environment. This breaks any linking, especially when dealing with
a cross-compiler toolchain.
The fix takes the CC variable and changes the 'gcc' extension to 'ld'.
Signed-off-by: Roeland Van Praet <roelvp@mind.be>
---
diff -ruN a/autoconf/make/vars.mk b/autoconf/make/vars.mk
--- a/autoconf/make/vars.mk 2010-03-11 00:43:19.000000000 +0100
+++ b/autoconf/make/vars.mk 2011-10-06 15:47:18.000000000 +0200
@@ -30,7 +30,7 @@
@SET_MAKE@
SHELL = /bin/sh
CC = @CC@
-LD = ld
+LD = $(CC:gcc=ld)
DO_GZIP = @DO_GZIP@
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@

11
package/pv/pv.mk Normal file
View File

@ -0,0 +1,11 @@
#######################
#
# pv - Pipe Viewer
#
#######################
PV_VERSION = 1.2.0
PV_SOURCE = pv-$(PV_VERSION).tar.bz2
PV_SITE = http://pipeviewer.googlecode.com/files
$(eval $(call AUTOTARGETS))