unionfs: add patch to disable search for the C++ compiler

Fixes

  http://autobuild.buildroot.org/results/9c4a9897dda1b99cc7a57af605301b53ed32b95d/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Thomas Petazzoni 2012-10-13 23:21:43 +00:00 committed by Peter Korsgaard
parent 4006b76570
commit 7b0e4f21d3

View File

@ -0,0 +1,19 @@
By default, CMake assumes a project uses the C and C++ languages, so
it checks for both the C and the C++ compiler to exist.
However, unionfs-fuse is written purely in C, so checking for a C++
compiler is useless, and even prevents unionfs-fuse from building
properly on targets for which no C++ compiler is available.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-project(unionfs-fuse)
+project(unionfs-fuse C)
cmake_minimum_required(VERSION 2.0)
INCLUDE (CheckIncludeFiles)