gnutls: add crywrap clock_gettime patch

Fixes:
http://autobuild.buildroot.net/results/1bd/1bd67b616e996d684dd584576569517f4653addd/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gustavo Zacarias 2013-12-26 13:13:56 -03:00 committed by Thomas Petazzoni
parent bbc598c5bd
commit 77ab76b2e9
2 changed files with 27 additions and 0 deletions

View File

@ -0,0 +1,25 @@
From b9dee5a0afec0f78343863048d6564021416e65a Mon Sep 17 00:00:00 2001
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
Date: Thu, 26 Dec 2013 13:09:34 -0300
Subject: [PATCH] Add LIB_CLOCK_GETTIME to crywrap
It's used indirectly thus causing build breakage on versions of glibc
where it's defined in librt rather than libc directly.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
src/crywrap/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/crywrap/Makefile.am b/src/crywrap/Makefile.am
index ca41259..d86ca55 100644
--- a/src/crywrap/Makefile.am
+++ b/src/crywrap/Makefile.am
@@ -29,3 +29,4 @@ bin_PROGRAMS = crywrap
crywrap_SOURCES = crywrap.c primes.h crywrap.h
crywrap_LDADD = ../../lib/libgnutls.la $(LIBIDN_LIBS) #../../gl/libgnu.la
+crywrap_LDADD += $(LIB_CLOCK_GETTIME)
--
1.8.3.2

View File

@ -8,6 +8,8 @@ GNUTLS_VERSION_MAJOR = 3.2
GNUTLS_VERSION = $(GNUTLS_VERSION_MAJOR).8
GNUTLS_SOURCE = gnutls-$(GNUTLS_VERSION).tar.xz
GNUTLS_SITE = ftp://ftp.gnutls.org/gcrypt/gnutls/v$(GNUTLS_VERSION_MAJOR)
# gettime patch
GNUTLS_AUTORECONF = YES
GNUTLS_LICENSE = GPLv3+ LGPLv2.1+
GNUTLS_LICENSE_FILES = COPYING COPYING.LESSER
GNUTLS_DEPENDENCIES = host-pkgconf nettle pcre \