added fltk

This commit is contained in:
John Voltz 2008-03-06 18:09:12 +00:00
parent d2230d77ca
commit 703d58a4f5
3 changed files with 43 additions and 0 deletions

11
package/fltk/Config.in Normal file
View File

@ -0,0 +1,11 @@
config BR2_PACKAGE_FLTK
bool "fltk"
default n
depends on BR2_PACKAGE_XORG||BR2_PACKAGE_XORG7
help
a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X.
http://www.fltk.org/
comment "fltk - disabled (requires Xorg(7))"
depends !(BR2_PACKAGE_XORG || BR2_PACKAGE_XORG7)

View File

@ -0,0 +1,11 @@
--- a/test/Makefile 2006-01-15 13:36:16.000000000 -0500
+++ b/test/Makefile 2008-02-12 13:34:25.000000000 -0500
@@ -230,7 +230,7 @@ uninstall-osx:
# FLUID file rules
.fl.cxx .fl.h: ../fluid/fluid$(EXEEXT)
echo Generating $<...
- ../fluid/fluid$(EXEEXT) -c $<
+ /usr/bin/fluid$(EXEEXT) -c $<
# All demos depend on the FLTK library...
$(ALL): ../lib/$(LIBNAME)

21
package/fltk/fltk.mk Normal file
View File

@ -0,0 +1,21 @@
#############################################################
#
# fltk
#
#############################################################
FLTK_VERSION = 1.1.7
FLTK_SOURCE = fltk-$(FLTK_VERSION)-source.tar.bz2
FLTK_SITE = http://ftp.easysw.com/pub/fltk/1.1.7/
FLTK_AUTORECONF = NO
FLTK_INSTALL_STAGING = YES
FLTK_INSTALL_TARGET = YES
FLTK_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
FLTK_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) --prefix=/usr \
--sysconfdir=/etc
FLTK_DEPENDENCIES = uclibc $(XSERVER)
$(eval $(call AUTOTARGETS,package,fltk))