squashfs: fix 3.4 build after be8a104c3c (pass CFLAGS/LDFLAGS and add host-zlib dependency)

Commit be8a104c3c (pass CFLAGS/LDFLAGS and add host-zlib dependency)
changed the way make was invocated for squashfs and added a patch for 4.0,
but forgot to add an equivalent patch for 3.4.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Peter Korsgaard 2010-03-02 17:42:23 +01:00
parent 291fedce66
commit 58794482a9
2 changed files with 32 additions and 0 deletions

View File

@ -1,3 +1,7 @@
2010.05, Not yet released
Updated/fixed packages: squashfs
2010.02, Release February 26th, 2010:
Fixes all over the tree.

View File

@ -0,0 +1,28 @@
[PATCH]: squashfs-tools: Handle user supplied CFLAGS/LDFLAGS
Properly handle make CFLAGS=.. LDFLAGS=..
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
squashfs-tools/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Index: squashfs3.4/squashfs-tools/Makefile
===================================================================
--- squashfs3.4.orig/squashfs-tools/Makefile
+++ squashfs3.4/squashfs-tools/Makefile
@@ -2,12 +2,12 @@ INSTALL_DIR = /usr/local/bin
INCLUDEDIR = .
-CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
+override CFLAGS += -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
all: mksquashfs unsquashfs
mksquashfs: mksquashfs.o read_fs.o sort.o
- $(CC) mksquashfs.o read_fs.o sort.o -lz -lpthread -lm -o $@
+ $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o -lz -lpthread -lm -o $@
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h