package/mysql: do not force a static build for internal programs

mysql wants to statically link some of the programs it uses internally,
like conf_to_src (whatever it is used for) which links against -lz.

This does not work for a shared-only build, as we would be missing
libz.a in that case.

Fix that by not forcing static builds for internal programs.

Fixes a slew of autobuild failures:
    http://autobuild.buildroot.net/results/018/018a579f37c9c8eca5a36fc76e93508dcf9bba35/
    http://autobuild.buildroot.net/results/2cc/2cc481b0ae43713a6fc50a1ca720f91384892af7/
    http://autobuild.buildroot.net/results/d98/d985c5824f9012374d64e6085d6c8ec9b3cd932b/
    ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yann E. MORIN 2014-12-22 01:00:06 +01:00 committed by Thomas Petazzoni
parent c705bacd3f
commit 574f2f2bb8

View File

@ -0,0 +1,18 @@
configure: do not force a static link for non-installed programs
Otherwise, it tries to link against a static libz, which may not exist
in a shared-only system.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff -durN mysql-5.1.73.orig/configure.in mysql-5.1.73/configure.in
--- mysql-5.1.73.orig/configure.in 2014-12-22 00:04:46.550508208 +0100
+++ mysql-5.1.73/configure.in 2014-12-22 00:05:56.415307480 +0100
@@ -562,7 +562,6 @@
AC_MSG_ERROR([MySQL requires an ANSI C compiler (and a C++ compiler). Try gcc. See the Installation chapter in the Reference Manual.])
fi
-NOINST_LDFLAGS="-static"
static_nss=""
STATIC_NSS_FLAGS=""