libunwind: new package

[Thomas: added patch to disable build of tests that fail on uClibc,
added dependencies for architectures that are supported.]

Signed-off-by: Andy Kennedy <andy.kennedy@adtran.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
ANDY KENNEDY 2013-06-25 21:41:44 +00:00 committed by Thomas Petazzoni
parent e748156012
commit 56a5e5a148
4 changed files with 54 additions and 0 deletions

View File

@ -629,6 +629,7 @@ source "package/libsigsegv/Config.in"
source "package/libtasn1/Config.in"
source "package/libtpl/Config.in"
source "package/libseccomp/Config.in"
source "package/libunwind/Config.in"
source "package/liburcu/Config.in"
source "package/linux-pam/Config.in"
source "package/log4cxx/Config.in"

View File

@ -0,0 +1,8 @@
config BR2_PACKAGE_LIBUNWIND
bool "libunwind"
depends on BR2_arm || BR2_armeb || BR2_mips || BR2_mipsel || BR2_mips64 || \
BR2_mips64el || BR2_powerpc || BR2_sh || BR2_sh64 || BR2_i386 || BR2_x86_64
help
C API to determine the call-chain of a program.
http://www.nongnu.org/libunwind/index.html

View File

@ -0,0 +1,32 @@
Disable building of tests
libunwind tests do not build with uClibc, so we disable them.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile.am
===================================================================
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,7 @@
nodist_include_HEADERS = include/libunwind-common.h
-SUBDIRS = src tests doc
+SUBDIRS = src doc
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
include/compiler.h include/libunwind_i.h include/mempool.h \
Index: b/Makefile.in
===================================================================
--- a/Makefile.in
+++ b/Makefile.in
@@ -313,7 +313,7 @@
$(am__append_7) $(am__append_8) $(am__append_9) \
$(am__append_10)
nodist_include_HEADERS = include/libunwind-common.h
-SUBDIRS = src tests doc
+SUBDIRS = src doc
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
include/compiler.h include/libunwind_i.h include/mempool.h \
include/remote.h \

View File

@ -0,0 +1,13 @@
################################################################################
#
# libunwind
#
################################################################################
LIBUNWIND_VERSION = 1.1
LIBUNWIND_SITE = http://download.savannah.gnu.org/releases/libunwind
LIBUNWIND_INSTALL_STAGING = YES
LIBUNWIND_LICENSE_FILES = COPYING
LIBUNWIND_LICENSE = MIT
$(eval $(autotools-package))