squid: bump to version 3.4.3

And exclude for avr32 since the toolchain is too old, fixes:
http://autobuild.buildroot.net/results/c6a/c6a686885a6c845b527c58c3f2075f82bcf120e2/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Gustavo Zacarias 2014-02-04 06:38:25 -03:00 committed by Peter Korsgaard
parent 136ede6f19
commit 50f0f9d63c
4 changed files with 3 additions and 18 deletions

View File

@ -1,5 +1,6 @@
comment "squid needs a toolchain w/ C++, IPv6"
depends on BR2_USE_MMU
depends on !BR2_avr32 # toolchain too old
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_INET_IPV6
config BR2_PACKAGE_SQUID

View File

@ -1,17 +0,0 @@
AC_RUN_IFELSE is bad for cross compiling, switch to AC_COMPILE_IFELSE
since it's enough for this test.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura squid-3.3.9.orig/configure.ac squid-3.3.9/configure.ac
--- squid-3.3.9.orig/configure.ac 2013-09-13 09:15:32.473365627 -0300
+++ squid-3.3.9/configure.ac 2013-09-13 13:27:06.829711487 -0300
@@ -392,7 +392,7 @@
dnl Check for atomic operations support in the compiler
dnl
AC_MSG_CHECKING([for GNU atomic operations support])
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
int n = 0;
]],[[
__sync_add_and_fetch(&n, 10); // n becomes 10

View File

@ -5,11 +5,12 @@
################################################################################
SQUID_VERSION_MAJOR = 3.4
SQUID_VERSION = $(SQUID_VERSION_MAJOR).2
SQUID_VERSION = $(SQUID_VERSION_MAJOR).3
SQUID_SOURCE = squid-$(SQUID_VERSION).tar.xz
SQUID_SITE = http://www.squid-cache.org/Versions/v3/$(SQUID_VERSION_MAJOR)
SQUID_LICENSE = GPLv2+
SQUID_LICENSE_FILES = COPYING
# For squid-01-assume-get-certificate-ok.patch
SQUID_AUTORECONF = YES
SQUID_DEPENDENCIES = libcap host-libcap host-pkgconf \
$(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)