libdvd{nav, read}: add patches to fix build on NIOS II

Fixes:

  http://autobuild.buildroot.org/results/628/62839c4b2e687b940b97ad61bceb41cd5eb6e17a/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas Petazzoni 2014-05-17 10:28:08 +02:00 committed by Peter Korsgaard
parent ae1df831c0
commit 503f76ae3d
2 changed files with 63 additions and 0 deletions

View File

@ -0,0 +1,32 @@
configure: fix build on NIOS II platform
NIOS II is a CPU architecture from Altera, which uses 'nios2' as the
architecture part of the tuple. Unfortunately, 'nios2' matches the
current '*os2*' test done by libdvdnav's configure script to detect
the OS/2 operating system. This leads to build issues as the build
process of libdvdnav then tries to use OS/2 specific compiler
options, that do not exist in the gcc used for Linux/NIOS2.
To fix this, this patch makes the test for OS/2 a little bit more
specific: in the case of the OS/2 operating system, the OS part of the
tuple contains just 'os2' (confirmed by looking at config.guess and
config.sub in the gnuconfig project). So using '*-os2-*' will properly
match the OS/2 operating system but not the NIOS II architecture.
Upstream-status: not needed, newer upstream versions no longer have
this test
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -166,7 +166,7 @@
*cygwin*)
LDFLAGS="-no-undefined $LDFLAGS"
;;
- *os2*)
+ *-os2-*)
LDFLAGS="-no-undefined -Zbin-files $LDFLAGS"
;;
*)

View File

@ -0,0 +1,31 @@
configure: fix build on NIOS II platform
NIOS II is a CPU architecture from Altera, which uses 'nios2' as the
architecture part of the tuple. Unfortunately, 'nios2' matches the
current '*os2*' test done by libdvdread's configure script to detect
the OS/2 operating system. This leads to build issues as the build
process of libdvdread then tries to use OS/2 specific compiler
options, that do not exist in the gcc used for Linux/NIOS2.
To fix this, this patch makes the test for OS/2 a little bit more
specific: in the case of the OS/2 operating system, the OS part of the
tuple contains just 'os2' (confirmed by looking at config.guess and
config.sub in the gnuconfig project). So using '*-os2-*' will properly
match the OS/2 operating system but not the NIOS II architecture.
Upstream-status: submitted
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -146,7 +146,7 @@
*cygwin*)
LDFLAGS="-no-undefined $LDFLAGS"
;;
- *os2*)
+ *-os2-*)
LDFLAGS="-no-undefined -Zbin-files $LDFLAGS"
;;
*)