libndp: new package

[Thomas: add patch to add stdarg.h include needed on uClibc, add
missing upstream URL in Config.in, fix license to be LGPLv2.1+ instead
of LGPLv2.1]

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yegor Yefremov 2014-03-17 11:57:07 +01:00 committed by Thomas Petazzoni
parent af156db881
commit 2d07ad8026
4 changed files with 44 additions and 0 deletions

View File

@ -714,6 +714,7 @@ source "package/libmbus/Config.in"
source "package/libmicrohttpd/Config.in"
source "package/libmnl/Config.in"
source "package/libmodbus/Config.in"
source "package/libndp/Config.in"
source "package/libnetfilter_acct/Config.in"
source "package/libnetfilter_conntrack/Config.in"
source "package/libnetfilter_cthelper/Config.in"

12
package/libndp/Config.in Normal file
View File

@ -0,0 +1,12 @@
config BR2_PACKAGE_LIBNDP
bool "libndp"
depends on BR2_INET_IPV6
help
This package contains a library which provides a wrapper
for IPv6 Neighbor Discovery Protocol. It also provides a tool
named ndptool for sending and receiving NDP messages.
https://github.com/jpirko/libndp
comment "libndp needs a toolchain w/ IPv6"
depends on !BR2_INET_IPV6

View File

@ -0,0 +1,16 @@
Add missing <stdarg.h> include for va_list
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/include/ndp.h
===================================================================
--- a/include/ndp.h
+++ b/include/ndp.h
@@ -20,6 +20,7 @@
#ifndef _NDP_H_
#define _NDP_H_
+#include <stdarg.h>
#include <stdbool.h>
#include <netinet/in.h>

15
package/libndp/libndp.mk Normal file
View File

@ -0,0 +1,15 @@
################################################################################
#
# libndp
#
################################################################################
LIBNDP_VERSION = v1.2
LIBNDP_SITE = $(call github,jpirko,libndp,$(LIBNDP_VERSION))
LIBNDP_LICENSE = LGPLv2.1+
LIBNDP_LICENSE_FILES = COPYING
LIBNDP_AUTORECONF = YES
LIBNDP_INSTALL_STAGING = YES
LIBNDP_CONF_OPT = --disable-debug
$(eval $(autotools-package))