iw: bump to 3.2

version 3.2 provides support for libnl 3.x, so remove the relevant patch

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Yegor Yefremov 2011-11-09 15:57:52 +01:00 committed by Peter Korsgaard
parent 3e974ba2d2
commit 2c10350977
2 changed files with 1 additions and 48 deletions

View File

@ -1,47 +0,0 @@
---
Makefile | 10 ++++++++++
1 file changed, 10 insertions(+)
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,7 @@
NL1FOUND := $(shell $(PKG_CONFIG) --atleast-version=1 libnl-1 && echo Y)
NL2FOUND := $(shell $(PKG_CONFIG) --atleast-version=2 libnl-2.0 && echo Y)
+NL3FOUND := $(shell $(PKG_CONFIG) --atleast-version=3 libnl-3.0 && echo Y)
ifeq ($(NL1FOUND),Y)
NLLIBNAME = libnl-1
@@ -35,6 +36,12 @@
NLLIBNAME = libnl-2.0
endif
+ifeq ($(NL3FOUND),Y)
+CFLAGS += -DCONFIG_LIBNL20
+LIBS += -lnl-genl
+NLLIBNAME = libnl-3.0
+endif
+
ifeq ($(NLLIBNAME),)
$(error Cannot find development files for any supported version of libnl)
endif
@@ -53,6 +60,8 @@
all: version_check $(ALL)
version_check:
+ifeq ($(NL3FOUND),Y)
+else
ifeq ($(NL2FOUND),Y)
else
ifeq ($(NL1FOUND),Y)
@@ -60,6 +69,7 @@
$(error No libnl found)
endif
endif
+endif
VERSION_OBJS := $(filter-out version.o, $(OBJS))

View File

@ -4,7 +4,7 @@
#
#############################################################
IW_VERSION = 3.1
IW_VERSION = 3.2
IW_SOURCE = iw-$(IW_VERSION).tar.bz2
IW_SITE = http://wireless.kernel.org/download/iw
IW_DEPENDENCIES = host-pkg-config libnl