ltrace: bump to version 0.7.3

Now with proper mips support!

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Gustavo Zacarias 2013-09-17 14:39:34 -03:00 committed by Peter Korsgaard
parent 46baba78ff
commit 238d13ab47
4 changed files with 4 additions and 32 deletions

View File

@ -1,6 +1,6 @@
config BR2_PACKAGE_LTRACE
bool "ltrace"
depends on !(BR2_avr32 || BR2_mips || BR2_sh || BR2_sh64 || BR2_xtensa || BR2_aarch64 || BR2_arc)
depends on !(BR2_avr32 || BR2_sh || BR2_sh64 || BR2_xtensa || BR2_aarch64 || BR2_arc)
select BR2_PACKAGE_LIBELF
help
Debugging program which runs a specified command until it exits.
@ -8,4 +8,4 @@ config BR2_PACKAGE_LTRACE
the dynamic library calls which are called by the executed
process and the signals received by that process.
http://packages.debian.org/unstable/utils/ltrace.html
http://ltrace.org

View File

@ -1,20 +0,0 @@
[PATCH] configure.ac: Recognize linux-uclibc as well
Ltrace works on uClibc as well as on glibc, so accept it.
[Gustavo: update for ltrace 0.7.1]
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura ltrace-0.7.1.orig/configure.ac ltrace-0.7.1/configure.ac
--- ltrace-0.7.1.orig/configure.ac 2012-12-03 09:02:32.995352741 -0300
+++ ltrace-0.7.1/configure.ac 2012-12-03 09:02:56.579096389 -0300
@@ -32,7 +32,7 @@
AC_CANONICAL_HOST
case "${host_os}" in
- linux-gnu*) HOST_OS="linux-gnu" ;;
+ linux-gnu* | linux-uclibc*) HOST_OS="linux-gnu" ;;
*) AC_MSG_ERROR([unkown host-os ${host_os}]) ;;
esac
AC_SUBST(HOST_OS)

View File

@ -4,22 +4,14 @@
#
################################################################################
LTRACE_VERSION = 0.7.2
LTRACE_SITE = http://alioth.debian.org/frs/download.php/file/3848
LTRACE_VERSION = 0.7.3
LTRACE_SITE = http://alioth.debian.org/frs/download.php/file/3947
LTRACE_SOURCE = ltrace-$(LTRACE_VERSION).tar.bz2
LTRACE_DEPENDENCIES = libelf
LTRACE_AUTORECONF = YES
LTRACE_CONF_OPT = --disable-werror
LTRACE_LICENSE = GPLv2
LTRACE_LICENSE_FILES = COPYING
# symlink missing from tarball
define LTRACE_MIPS_SYMLINK
cd $(@D)/sysdeps/linux-gnu; ln -sf mipsel mips
endef
LTRACE_POST_EXTRACT_HOOKS += LTRACE_MIPS_SYMLINK
# ltrace can use libunwind only if libc has backtrace() support
# We don't normally do so for uClibc and we can't know if it's external
ifeq ($(BR2_PACKAGE_LIBUNWIND),y)