package: remove disabled/broken irda-utils package

No updates since it got marked as broken back in January, so lets get
rid of it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Peter Korsgaard 2009-11-24 17:32:25 +01:00
parent 2d04d56ec7
commit 1330cf5b19
4 changed files with 0 additions and 115 deletions

View File

@ -139,7 +139,6 @@ source "package/ethtool/Config.in"
source "package/haserl/Config.in"
source "package/hostap/Config.in"
source "package/ifplugd/Config.in"
#source "package/irda-utils/Config.in"
source "package/iperf/Config.in"
source "package/iproute2/Config.in"
source "package/ipsec-tools/Config.in"

View File

@ -1,45 +0,0 @@
menuconfig BR2_PACKAGE_IRDA_UTILS
bool "irda_utils"
depends on BROKEN
help
Tools for accessing the irda-Subsystem of the Linux-Kernel
The makefile is totally broken.
if BR2_PACKAGE_IRDA_UTILS
config IRDA_IRATTACH
bool "irattach"
default y
help
To start the Irda-Subsystem in SIR-Mode you may need this
config IRDA_IRDAPING
bool "irdaping"
help
what ping is for networks is irdaping for Irda
config IRDA_IRNETD
bool "irnetd"
help
Needed for Networking over Irda
config IRDA_IRDADUMP
bool "irdadump"
help
Like tcpdump, but for infrared connections
config IRDA_FINDCHIP
bool "findchip"
config IRDA_PSION
bool "support psion-dongle"
config IRDA_TEKRAM
bool "support tekram-dongle"
config IRDA_SMCINIT
bool "support toshiba-laptops"
help
Some Toshiba Laptops have buggy BIOSes which didn't initialize
Irda. This may help those.
endif

View File

@ -1,12 +0,0 @@
diff -Naur irda-utils-0.9.18.orig/irnetd/Makefile irda-utils-0.9.18/irnetd/Makefile
--- irda-utils-0.9.18.orig/irnetd/Makefile 2006-07-11 08:16:06.000000000 +0200
+++ irda-utils-0.9.18/irnetd/Makefile 2007-06-08 20:39:25.000000000 +0200
@@ -55,7 +55,7 @@
install: irnetd
$(prn_install)
- $(ECMD) install irnetd /usr/sbin/
+ $(ECMD) install irnetd $(ROOT)/usr/sbin/
clean:

View File

@ -1,57 +0,0 @@
#############################################################
#
# irda-utils
#
#############################################################
IRDA_UTILS_VERSION:=0.9.18
IRDA_UTILS_SOURCE:=irda-utils-$(IRDA_UTILS_VERSION).tar.gz
IRDA_UTILS_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/irda/$(IRDA_UTILS_SOURCE)
IRDA_UTILS_DIR:=$(BUILD_DIR)/irda-utils-$(IRDA_UTILS_VERSION)
ifeq ($(IRDA_IRATTACH),y)
IRDA_DIRS += irattach
endif
ifeq ($(IRDA_IRDAPING),y)
IRDA_DIRS += irdaping
endif
ifeq ($(IRDA_IRNETD),y)
IRDA_DIRS += irnetd
endif
ifeq ($(IRDA_PSION),y)
IRDA_DIRS += psion
endif
ifeq ($(IRDA_TEKRAM),y)
IRDA_DIRS += tekram
endif
ifeq ($(IRDA_FINDCHIP),y)
IRDA_DIRS += findchip
endif
ifeq ($(IRDA_IRDADUMP),y)
IRDA_DIRS += irdadump
endif
ifeq ($(IRDA_SMCINIT),y)
IRDA_DIRS += smcinit
endif
IRDA_UTILS_MAKE_OPT:=-e "DIRS=$(IRDA_DIRS)"
IRDA_UTILS_MAKE_ENV:=CC=$(TARGET_CC) LD=$(TARGET_LD) AR=$(TARGET_AR) RANLIB=$(TARGET_RANLIB) ROOT=$(TARGET_DIR) PREFIX=$(TARGET_DIR)
# Since there is no configure-script
$(IRDA_UTILS_DIR)/.configured: $(IRDA_UTILS_DIR)/.patched
touch $@
irda-utils: uclibc $(DL_DIR)/$(IRDA_UTILS_SOURCE) $(IRDA_UTILS_DIR)/.installed
irda-utils-clean: $(IRDA_UTILS_DIR)/.clean
irda-utils-dirclean: $(IRDA_UTILS_DIR)/.dirclean
#############################################################
#
# Toplevel Makefile options
#
#############################################################
ifeq ($(BR2_PACKAGE_IRDA_UTILS),y)
TARGETS+=irda-utils
endif