dmraid: misc cleanup

Fix install into staging (YES instead of yes), fix uninstall target,
use default target-install handling, install headers/lib/man pages into
target if requested.

A small patch is needed for 'make remove' to work.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Peter Korsgaard 2010-09-16 15:26:25 +02:00
parent 78e7c0b642
commit 0a5ec78866
2 changed files with 32 additions and 5 deletions

View File

@ -0,0 +1,22 @@
[PATCH]: dmraid: fix make remove for header files
prefix/include/dmraid is not empty, so we need rm -rf
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
1.0.0.rc15/include/Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: dmraid/1.0.0.rc15/include/Makefile.in
===================================================================
--- dmraid.orig/1.0.0.rc15/include/Makefile.in
+++ dmraid/1.0.0.rc15/include/Makefile.in
@@ -24,7 +24,7 @@ install: install_dmraid_headers
remove_dmraid_headers:
@echo "Removing $(HEADERS) from $(includedir)/dmraid"
- rm -f $(includedir)/dmraid
+ rm -rf $(includedir)/dmraid
remove: remove_dmraid_headers

View File

@ -9,16 +9,21 @@ DMRAID_SITE:=http://people.redhat.com/~heinzm/sw/dmraid/src
DMRAID_SUBDIR:=$(DMRAID_VERSION)
# lib and tools race with parallel make
DMRAID_MAKE = $(MAKE1)
DMRAID_DEPENDENCIES:=lvm2
DMRAID_INSTALL_STAGING:=yes
DMRAID_INSTALL_STAGING = YES
DMRAID_UNINSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) remove
DMRAID_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
define DMRAID_INSTALL_TARGET_CMDS
$(INSTALL) -m 0755 $(@D)/$(DMRAID_SUBDIR)/tools/dmraid $(TARGET_DIR)/usr/sbin
DMRAID_DEPENDENCIES = lvm2
define DMRAID_INSTALL_INITSCRIPT
$(INSTALL) -m 0755 package/dmraid/dmraid.init $(TARGET_DIR)/etc/init.d/S20dmraid
endef
DMRAID_POST_INSTALL_TARGET_HOOKS += DMRAID_INSTALL_INITSCRIPT
define DMRAID_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/dmraid $(TARGET_DIR)/etc/init.d/S20dmraid
$(MAKE) DESTDIR=$(TARGET_DIR) remove -C $(@D)/$(DMRAID_SUBDIR)
rm -f $(TARGET_DIR)/etc/init.d/S20dmraid
endef
$(eval $(call AUTOTARGETS,package,dmraid))