Browse Source

treewide: remove unused variables (#63177)

* treewide: remove unused variables

* making ofborg happy
pleroma
volth 3 years ago
committed by Alyssa Ross
parent
commit
f3282c8d1e
  1. 2
      lib/systems/parse.nix
  2. 2
      nixos/modules/hardware/video/nvidia.nix
  3. 2
      nixos/modules/installer/cd-dvd/installation-cd-graphical-base.nix
  4. 2
      nixos/modules/installer/cd-dvd/installation-cd-graphical-gnome.nix
  5. 1
      nixos/modules/misc/nixops-autoluks.nix
  6. 2
      nixos/modules/misc/version.nix
  7. 1
      nixos/modules/services/audio/snapserver.nix
  8. 7
      nixos/modules/services/cluster/kubernetes/default.nix
  9. 7
      nixos/modules/services/cluster/kubernetes/kubelet.nix
  10. 1
      nixos/modules/services/cluster/kubernetes/pki.nix
  11. 2
      nixos/modules/services/hardware/triggerhappy.nix
  12. 1
      nixos/modules/services/mail/rspamd.nix
  13. 2
      nixos/modules/services/monitoring/alerta.nix
  14. 2
      nixos/modules/services/monitoring/grafana-reporter.nix
  15. 2
      nixos/modules/services/monitoring/kapacitor.nix
  16. 2
      nixos/modules/services/networking/bitcoind.nix
  17. 2
      nixos/modules/services/system/kerberos/default.nix
  18. 2
      nixos/modules/services/system/kerberos/heimdal.nix
  19. 2
      nixos/modules/services/system/kerberos/mit.nix
  20. 2
      nixos/modules/services/web-apps/limesurvey.nix
  21. 2
      nixos/modules/services/web-apps/nextcloud.nix
  22. 1
      nixos/modules/services/web-apps/tt-rss.nix
  23. 11
      nixos/modules/services/web-servers/nginx/default.nix
  24. 2
      nixos/modules/services/x11/xserver.nix
  25. 1
      nixos/modules/system/boot/kernel_config.nix
  26. 7
      nixos/modules/virtualisation/anbox.nix
  27. 2
      nixos/modules/virtualisation/cloudstack-config.nix
  28. 2
      nixos/modules/virtualisation/docker-containers.nix
  29. 1
      nixos/modules/virtualisation/google-compute-config.nix
  30. 2
      pkgs/applications/altcoins/btc1.nix
  31. 2
      pkgs/applications/altcoins/default.nix
  32. 2
      pkgs/applications/altcoins/exodus/default.nix
  33. 2
      pkgs/applications/audio/ams-lv2/default.nix
  34. 4
      pkgs/applications/audio/bitwig-studio/bitwig-studio2.nix
  35. 2
      pkgs/applications/audio/cadence/default.nix
  36. 2
      pkgs/applications/audio/calf/default.nix
  37. 2
      pkgs/applications/audio/cantata/default.nix
  38. 4
      pkgs/applications/audio/carla/default.nix
  39. 1
      pkgs/applications/audio/chuck/default.nix
  40. 2
      pkgs/applications/audio/cozy-audiobooks/default.nix
  41. 2
      pkgs/applications/audio/gnome-podcasts/default.nix
  42. 2
      pkgs/applications/audio/mixxx/default.nix
  43. 2
      pkgs/applications/audio/parlatype/default.nix
  44. 1
      pkgs/applications/audio/pulseaudio-dlna/zeroconf.nix
  45. 2
      pkgs/applications/audio/reaper/default.nix
  46. 1
      pkgs/applications/audio/vocal/default.nix
  47. 2
      pkgs/applications/editors/android-studio/default.nix
  48. 2
      pkgs/applications/editors/atom/default.nix
  49. 2
      pkgs/applications/editors/emacs-modes/elpa-packages.nix
  50. 4
      pkgs/applications/editors/emacs/default.nix
  51. 2
      pkgs/applications/editors/featherpad/default.nix
  52. 2
      pkgs/applications/editors/gobby/default.nix
  53. 2
      pkgs/applications/editors/quilter/default.nix
  54. 2
      pkgs/applications/editors/retext/default.nix
  55. 2
      pkgs/applications/editors/texmacs/default.nix
  56. 2
      pkgs/applications/editors/vim/configurable.nix
  57. 2
      pkgs/applications/editors/vscode/generic.nix
  58. 2
      pkgs/applications/editors/vscode/vscode.nix
  59. 2
      pkgs/applications/editors/vscode/vscodium.nix
  60. 2
      pkgs/applications/editors/vscode/with-extensions.nix
  61. 2
      pkgs/applications/editors/xmlcopyeditor/default.nix
  62. 2
      pkgs/applications/gis/qgis/default.nix
  63. 2
      pkgs/applications/graphics/animbar/default.nix
  64. 4
      pkgs/applications/graphics/freecad/default.nix
  65. 2
      pkgs/applications/graphics/gcolor3/default.nix
  66. 2
      pkgs/applications/graphics/gscan2pdf/default.nix
  67. 2
      pkgs/applications/graphics/image_optim/default.nix
  68. 2
      pkgs/applications/graphics/jpeg-archive/default.nix
  69. 1
      pkgs/applications/graphics/krita/default.nix
  70. 1
      pkgs/applications/graphics/shotwell/default.nix
  71. 2
      pkgs/applications/graphics/tesseract/tesseract3.nix
  72. 2
      pkgs/applications/kde/knotes.nix
  73. 2
      pkgs/applications/misc/buku/default.nix
  74. 2
      pkgs/applications/misc/cardpeek/default.nix
  75. 2
      pkgs/applications/misc/curaengine/default.nix
  76. 2
      pkgs/applications/misc/ddgr/default.nix
  77. 1
      pkgs/applications/misc/digitalbitbox/default.nix
  78. 6
      pkgs/applications/misc/electron-cash/default.nix
  79. 2
      pkgs/applications/misc/font-manager/default.nix
  80. 4
      pkgs/applications/misc/gImageReader/default.nix
  81. 2
      pkgs/applications/misc/ganttproject-bin/default.nix
  82. 2
      pkgs/applications/misc/gremlin-console/default.nix
  83. 2
      pkgs/applications/misc/k2pdfopt/default.nix
  84. 2
      pkgs/applications/misc/kitty/default.nix
  85. 4
      pkgs/applications/misc/lutris/default.nix
  86. 2
      pkgs/applications/misc/taskell/default.nix
  87. 2
      pkgs/applications/misc/termite/wrapper.nix
  88. 3
      pkgs/applications/misc/ulauncher/default.nix
  89. 2
      pkgs/applications/misc/xcruiser/default.nix
  90. 6
      pkgs/applications/misc/yubioath-desktop/default.nix
  91. 2
      pkgs/applications/misc/zathura/pdf-mupdf/default.nix
  92. 2
      pkgs/applications/networking/browsers/chromium/common.nix
  93. 2
      pkgs/applications/networking/browsers/chromium/default.nix
  94. 3
      pkgs/applications/networking/browsers/firefox-bin/update.nix
  95. 2
      pkgs/applications/networking/browsers/firefox/packages.nix
  96. 1
      pkgs/applications/networking/browsers/firefox/update.nix
  97. 2
      pkgs/applications/networking/browsers/midori/default.nix
  98. 2
      pkgs/applications/networking/browsers/tor-browser-bundle/default.nix
  99. 3
      pkgs/applications/networking/charles/default.nix
  100. 2
      pkgs/applications/networking/cluster/docker-machine/kvm2.nix

2
lib/systems/parse.nix

@ -428,7 +428,7 @@ rec {
mkSystemFromString = s: mkSystemFromSkeleton (mkSkeletonFromList (lib.splitString "-" s));
doubleFromSystem = { cpu, vendor, kernel, abi, ... }:
doubleFromSystem = { cpu, kernel, abi, ... }:
/**/ if abi == abis.cygnus then "${cpu.name}-cygwin"
else if kernel.families ? darwin then "${cpu.name}-darwin"
else "${cpu.name}-${kernel.name}";

2
nixos/modules/hardware/video/nvidia.nix

@ -1,6 +1,6 @@
# This module provides the proprietary NVIDIA X11 / OpenGL drivers.
{ stdenv, config, lib, pkgs, ... }:
{ config, lib, pkgs, ... }:
with lib;

2
nixos/modules/installer/cd-dvd/installation-cd-graphical-base.nix

@ -1,7 +1,7 @@
# This module contains the basic configuration for building a graphical NixOS
# installation CD.
{ config, lib, pkgs, ... }:
{ lib, pkgs, ... }:
with lib;

2
nixos/modules/installer/cd-dvd/installation-cd-graphical-gnome.nix

@ -1,7 +1,7 @@
# This module defines a NixOS installation CD that contains X11 and
# GNOME 3.
{ config, lib, pkgs, ... }:
{ lib, ... }:
with lib;

1
nixos/modules/misc/nixops-autoluks.nix

@ -1,7 +1,6 @@
{ config, options, lib, ... }:
let
path = [ "deployment" "autoLuks" ];
hasAutoLuksOption = lib.hasAttrByPath path options;
hasAutoLuksConfig = lib.hasAttrByPath path config && (lib.attrByPath path {} config) != {};
inherit (config.nixops) enableDeprecatedAutoLuks;

2
nixos/modules/misc/version.nix

@ -1,4 +1,4 @@
{ options, config, lib, pkgs, ... }:
{ config, lib, pkgs, ... }:
with lib;

1
nixos/modules/services/audio/snapserver.nix

@ -4,7 +4,6 @@ with lib;
let
package = "snapcast";
name = "snapserver";
cfg = config.services.snapserver;

7
nixos/modules/services/cluster/kubernetes/default.nix

@ -72,13 +72,6 @@ let
default = null;
};
};
kubeConfigDefaults = {
server = mkDefault cfg.kubeconfig.server;
caFile = mkDefault cfg.kubeconfig.caFile;
certFile = mkDefault cfg.kubeconfig.certFile;
keyFile = mkDefault cfg.kubeconfig.keyFile;
};
in {
###### interface

7
nixos/modules/services/cluster/kubernetes/kubelet.nix

@ -28,13 +28,6 @@ let
kubeconfig = top.lib.mkKubeConfig "kubelet" cfg.kubeconfig;
manifests = pkgs.buildEnv {
name = "kubernetes-manifests";
paths = mapAttrsToList (name: manifest:
pkgs.writeTextDir "${name}.json" (builtins.toJSON manifest)
) cfg.manifests;
};
manifestPath = "kubernetes/manifests";
taintOptions = with lib.types; { name, ... }: {

1
nixos/modules/services/cluster/kubernetes/pki.nix

@ -118,7 +118,6 @@ in
cfsslCertPathPrefix = "${config.services.cfssl.dataDir}/cfssl";
cfsslCert = "${cfsslCertPathPrefix}.pem";
cfsslKey = "${cfsslCertPathPrefix}-key.pem";
cfsslPort = toString config.services.cfssl.port;
certmgrPaths = [
top.caFile

2
nixos/modules/services/hardware/triggerhappy.nix

@ -17,7 +17,7 @@ let
${cfg.extraConfig}
'';
bindingCfg = { config, ... }: {
bindingCfg = { ... }: {
options = {
keys = mkOption {

1
nixos/modules/services/mail/rspamd.nix

@ -5,7 +5,6 @@ with lib;
let
cfg = config.services.rspamd;
opts = options.services.rspamd;
postfixCfg = config.services.postfix;
bindSocketOpts = {options, config, ... }: {

2
nixos/modules/services/monitoring/alerta.nix

@ -1,4 +1,4 @@
{ options, config, lib, pkgs, ... }:
{ config, lib, pkgs, ... }:
with lib;

2
nixos/modules/services/monitoring/grafana-reporter.nix

@ -1,4 +1,4 @@
{ options, config, lib, pkgs, ... }:
{ config, lib, pkgs, ... }:
with lib;

2
nixos/modules/services/monitoring/kapacitor.nix

@ -1,4 +1,4 @@
{ options, config, lib, pkgs, ... }:
{ config, lib, pkgs, ... }:
with lib;

2
nixos/modules/services/networking/bitcoind.nix

@ -28,7 +28,7 @@ let
"-datadir=${cfg.dataDir}"
"-pid=${pidFile}"
];
hexStr = types.strMatching "[0-9a-f]+";
rpcUserOpts = { name, ... }: {
options = {
name = mkOption {

2
nixos/modules/services/system/kerberos/default.nix

@ -1,4 +1,4 @@
{pkgs, config, lib, ...}:
{config, lib, ...}:
let
inherit (lib) mkOption mkIf types length attrNames;

2
nixos/modules/services/system/kerberos/heimdal.nix

@ -2,7 +2,7 @@
let
inherit (lib) mkIf concatStringsSep concatMapStrings toList mapAttrs
mapAttrsToList attrValues;
mapAttrsToList;
cfg = config.services.kerberos_server;
kerberos = config.krb5.kerberos;
stateDir = "/var/heimdal";

2
nixos/modules/services/system/kerberos/mit.nix

@ -2,7 +2,7 @@
let
inherit (lib) mkIf concatStrings concatStringsSep concatMapStrings toList
mapAttrs mapAttrsToList attrValues;
mapAttrs mapAttrsToList;
cfg = config.services.kerberos_server;
kerberos = config.krb5.kerberos;
stateDir = "/var/lib/krb5kdc";

2
nixos/modules/services/web-apps/limesurvey.nix

@ -2,7 +2,7 @@
let
inherit (lib) mkDefault mkEnableOption mkForce mkIf mkMerge mkOption;
inherit (lib) mkDefault mkEnableOption mkForce mkIf mkOption;
inherit (lib) mapAttrs optional optionalString types;
cfg = config.services.limesurvey;

2
nixos/modules/services/web-apps/nextcloud.nix

@ -1,4 +1,4 @@
{ config, lib, pkgs, ... }@args:
{ config, lib, pkgs, ... }:
with lib;

1
nixos/modules/services/web-apps/tt-rss.nix

@ -15,7 +15,6 @@ let
else cfg.database.port;
poolName = "tt-rss";
phpfpmSocketName = "/run/phpfpm/${poolName}.sock";
tt-rss-config = pkgs.writeText "config.php" ''
<?php

11
nixos/modules/services/web-servers/nginx/default.nix

@ -269,17 +269,6 @@ let
${optionalString (config.proxyPass != null && cfg.recommendedProxySettings) "include ${recommendedProxyConfig};"}
}
'') (sortProperties (mapAttrsToList (k: v: v // { location = k; }) locations)));
mkBasicAuth = vhostName: authDef: let
htpasswdFile = pkgs.writeText "${vhostName}.htpasswd" (
concatStringsSep "\n" (mapAttrsToList (user: password: ''
${user}:{PLAIN}${password}
'') authDef)
);
in ''
auth_basic secured;
auth_basic_user_file ${htpasswdFile};
'';
mkHtpasswd = vhostName: authDef: pkgs.writeText "${vhostName}.htpasswd" (
concatStringsSep "\n" (mapAttrsToList (user: password: ''
${user}:{PLAIN}${password}

2
nixos/modules/services/x11/xserver.nix

@ -4,8 +4,6 @@ with lib;
let
kernelPackages = config.boot.kernelPackages;
# Abbreviations.
cfg = config.services.xserver;
xorg = pkgs.xorg;

1
nixos/modules/system/boot/kernel_config.nix

@ -9,7 +9,6 @@ let
mergeAnswer = winners: locs: defs:
let
values = map (x: x.value) defs;
freeformAnswer = intersectLists values winners;
inter = intersectLists values winners;
winner = head winners;
in

7
nixos/modules/virtualisation/anbox.nix

@ -100,12 +100,7 @@ in
wantedBy = [ "multi-user.target" ];
after = [ "systemd-udev-settle.service" ];
preStart = let
initsh = let
ip = cfg.ipv4.container.address;
gw = cfg.ipv4.gateway.address;
dns = cfg.ipv4.dns;
in
pkgs.writeText "nixos-init" (''
initsh = pkgs.writeText "nixos-init" (''
#!/system/bin/sh
setprop nixos.version ${config.system.nixos.version}

2
nixos/modules/virtualisation/cloudstack-config.nix

@ -1,4 +1,4 @@
{ config, lib, pkgs, ... }:
{ lib, pkgs, ... }:
with lib;

2
nixos/modules/virtualisation/docker-containers.nix

@ -5,7 +5,7 @@ let
cfg = config.docker-containers;
dockerContainer =
{ name, config, ... }: {
{ ... }: {
options = {

1
nixos/modules/virtualisation/google-compute-config.nix

@ -2,7 +2,6 @@
with lib;
let
gce = pkgs.google-compute-engine;
cfg = config.virtualisation.googleComputeImage;
in
{
imports = [

2
pkgs/applications/altcoins/btc1.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pkgconfig, autoreconfHook, hexdump, openssl, db48
, boost, zlib, miniupnpc, qt4, utillinux, protobuf, qrencode, libevent
, boost, zlib, miniupnpc, qt4, protobuf, qrencode, libevent
, AppKit
, withGui ? !stdenv.isDarwin
}:

2
pkgs/applications/altcoins/default.nix

@ -1,4 +1,4 @@
{ callPackage, boost155, boost165, openssl_1_1, haskellPackages, darwin, libsForQt5, libsForQt59, miniupnpc_2, python3, buildGo110Package }:
{ callPackage, boost155, boost165, openssl_1_1, darwin, libsForQt5, libsForQt59, miniupnpc_2, python3, buildGo110Package }:
rec {

2
pkgs/applications/altcoins/exodus/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, makeWrapper, fetchurl, unzip, glib, systemd, nss, nspr, gtk3-x11, gnome2,
{ stdenv, lib, fetchurl, unzip, glib, systemd, nss, nspr, gtk3-x11, gnome2,
atk, cairo, gdk_pixbuf, xorg, xorg_sys_opengl, utillinux, alsaLib, dbus, at-spi2-atk,
cups, vivaldi-ffmpeg-codecs, libpulseaudio }:

2
pkgs/applications/audio/ams-lv2/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, cairo, fftw, gtkmm2, lv2, lvtk, pkgconfig, python3
{ stdenv, fetchFromGitHub, cairo, fftw, gtkmm2, lv2, lvtk, pkgconfig
, wafHook }:
stdenv.mkDerivation rec {

4
pkgs/applications/audio/bitwig-studio/bitwig-studio2.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, bitwig-studio1,
xdg_utils, zenity, ffmpeg, pulseaudio }:
{ fetchurl, bitwig-studio1,
pulseaudio }:
bitwig-studio1.overrideAttrs (oldAttrs: rec {
name = "bitwig-studio-${version}";

2
pkgs/applications/audio/cadence/default.nix

@ -3,9 +3,7 @@
, pkgconfig
, qtbase
, makeWrapper
, jack2Full
, python3Packages
, a2jmidid
}:
stdenv.mkDerivation rec {

2
pkgs/applications/audio/calf/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchpatch, cairo, expat, fftwSinglePrec, fluidsynth, glib
{ stdenv, fetchurl, cairo, expat, fftwSinglePrec, fluidsynth, glib
, gtk2, libjack2, ladspaH , libglade, lv2, pkgconfig }:
stdenv.mkDerivation rec {

2
pkgs/applications/audio/cantata/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, fetchpatch, cmake, pkgconfig, vlc
{ stdenv, fetchFromGitHub, cmake, pkgconfig, vlc
, qtbase, qtmultimedia, qtsvg, qttools
# Cantata doesn't build with cdparanoia enabled so we disable that

4
pkgs/applications/audio/carla/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, alsaLib, file, fluidsynth, ffmpeg, fftw, jack2,
liblo, libpulseaudio, libsndfile, makeWrapper, pkgconfig, python3Packages,
{ stdenv, fetchFromGitHub, alsaLib, file, fluidsynth, ffmpeg, jack2,
liblo, libpulseaudio, libsndfile, pkgconfig, python3Packages,
which, withFrontend ? true,
withQt ? true, qtbase ? null,
withGtk2 ? true, gtk2 ? null,

1
pkgs/applications/audio/chuck/default.nix

@ -1,6 +1,5 @@
{ stdenv, lib, fetchurl, alsaLib, bison, flex, libsndfile, which
, AppKit, Carbon, CoreAudio, CoreMIDI, CoreServices, Kernel
, xcbuild
}:
stdenv.mkDerivation rec {

2
pkgs/applications/audio/cozy-audiobooks/default.nix

@ -1,6 +1,5 @@
{ stdenv, fetchFromGitHub
, ninja
, boost
, meson
, pkgconfig
, wrapGAppsHook
@ -12,7 +11,6 @@
, python3Packages
, file
, cairo
, sqlite
, gettext
, gnome3
}:

2
pkgs/applications/audio/gnome-podcasts/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchpatch, fetchFromGitLab, meson, ninja, gettext, cargo, rustc, python3, rustPlatform, pkgconfig, gnome3
{ stdenv, fetchurl, fetchpatch, meson, ninja, gettext, cargo, rustc, python3, pkgconfig, gnome3
, glib, libhandy, gtk3, dbus, openssl, sqlite, gst_all_1, wrapGAppsHook }:
# TODO: build from git for easier updates

2
pkgs/applications/audio/mixxx/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, makeWrapper, chromaprint, fetchpatch
{ stdenv, fetchFromGitHub, makeWrapper, chromaprint
, fftw, flac, faad2, glibcLocales, mp4v2
, libid3tag, libmad, libopus, libshout, libsndfile, libusb1, libvorbis
, libGLU, libxcb, lilv, lv2, opusfile

2
pkgs/applications/audio/parlatype/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, pkgconfig, meson, gtk3, at-spi2-core, dbus, gst_all_1, sphinxbase, pocketsphinx, ninja, gettext, appstream-glib, python3, glib, gobject-introspection, gsettings-desktop-schemas, itstool, wrapGAppsHook, makeWrapper, hicolor-icon-theme }:
{ stdenv, fetchFromGitHub, pkgconfig, meson, gtk3, at-spi2-core, dbus, gst_all_1, sphinxbase, pocketsphinx, ninja, gettext, appstream-glib, python3, glib, gobject-introspection, gsettings-desktop-schemas, itstool, wrapGAppsHook, hicolor-icon-theme }:
stdenv.mkDerivation rec {
pname = "parlatype";

1
pkgs/applications/audio/pulseaudio-dlna/zeroconf.nix

@ -3,7 +3,6 @@
, fetchPypi
, ifaddr
, typing
, isPy27
, pythonOlder
, netifaces
, six

2
pkgs/applications/audio/reaper/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, autoPatchelfHook, makeWrapper
, alsaLib, xorg
, gnome3, gtk3, pango, gdk_pixbuf, cairo, glib, freetype
, gtk3, pango, gdk_pixbuf, cairo, glib, freetype
, libpulseaudio, xdg_utils
}:

1
pkgs/applications/audio/vocal/default.nix

@ -14,7 +14,6 @@
, libnotify
, sqlite
, gst_all_1
, libsoup
, json-glib
, libgee
, wrapGAppsHook

2
pkgs/applications/editors/android-studio/default.nix

@ -1,4 +1,4 @@
{ stdenv, callPackage, makeFontsConf, gnome2 }:
{ callPackage, makeFontsConf, gnome2 }:
let
mkStudio = opts: callPackage (import ./common.nix opts) {

2
pkgs/applications/editors/atom/default.nix

@ -1,4 +1,4 @@
{ stdenv, pkgs, fetchurl, makeWrapper, wrapGAppsHook, gvfs, gtk3, atomEnv }:
{ stdenv, pkgs, fetchurl, wrapGAppsHook, gvfs, gtk3, atomEnv }:
let
versions = {

2
pkgs/applications/editors/emacs-modes/elpa-packages.nix

@ -12,7 +12,7 @@ To update the list of packages from MELPA,
*/
{ fetchurl, lib, stdenv, texinfo }:
{ lib, stdenv, texinfo }:
self:

4
pkgs/applications/editors/emacs/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchpatch, fetchurl, ncurses, xlibsWrapper, libXaw, libXpm
{ stdenv, lib, fetchurl, ncurses, xlibsWrapper, libXaw, libXpm
, Xaw3d, libXcursor, pkgconfig, gettext, libXft, dbus, libpng, libjpeg, libungif
, libtiff, librsvg, gconf, libxml2, imagemagick, gnutls, libselinux
, alsaLib, cairo, acl, gpm, cf-private, AppKit, GSS, ImageIO, m17n_lib, libotf
@ -7,7 +7,7 @@
, withNS ? stdenv.isDarwin
, withGTK2 ? false, gtk2-x11 ? null
, withGTK3 ? true, gtk3-x11 ? null, gsettings-desktop-schemas ? null
, withXwidgets ? false, webkitgtk ? null, wrapGAppsHook ? null, glib-networking ? null
, withXwidgets ? false, webkitgtk ? null, wrapGAppsHook ? null
, withCsrc ? true
, srcRepo ? false, autoconf ? null, automake ? null, texinfo ? null
, siteStart ? ./site-start.el

2
pkgs/applications/editors/featherpad/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pkgconfig, qt5, fetchFromGitHub }:
{ stdenv, pkgconfig, qt5, fetchFromGitHub }:
with qt5;

2
pkgs/applications/editors/gobby/default.nix

@ -1,5 +1,5 @@
{ avahiSupport ? false # build support for Avahi in libinfinity
, stdenv, fetchurl, fetchFromGitHub, autoconf, automake, pkgconfig, wrapGAppsHook
, stdenv, fetchFromGitHub, autoconf, automake, pkgconfig, wrapGAppsHook
, gtkmm3, gsasl, gtksourceview3, libxmlxx, libinfinity, intltool, itstool, gnome3 }:
let

2
pkgs/applications/editors/quilter/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, fetchpatch, pkgconfig, meson, ninja, python3
{ stdenv, fetchFromGitHub, pkgconfig, meson, ninja, python3
, gtk3, desktop-file-utils, gtksourceview, webkitgtk, gtkspell3, pantheon
, libgee, discount, wrapGAppsHook }:

2
pkgs/applications/editors/retext/default.nix

@ -1,4 +1,4 @@
{ lib, stdenv, python3, fetchFromGitHub, makeWrapper, buildEnv, aspellDicts
{ stdenv, python3, fetchFromGitHub, makeWrapper, buildEnv, aspellDicts
# Use `lib.collect lib.isDerivation aspellDicts;` to make all dictionaries
# available.
, enchantAspellDicts ? with aspellDicts; [ en en-computers en-science ]

2
pkgs/applications/editors/texmacs/default.nix

@ -1,5 +1,5 @@
{ stdenv, callPackage,
fetchurl, guile_1_8, qt4, zlib, xmodmap, which, makeWrapper, freetype,
fetchurl, guile_1_8, qt4, xmodmap, which, makeWrapper, freetype,
tex ? null,
aspell ? null,
ghostscriptX ? null,

2
pkgs/applications/editors/vim/configurable.nix

@ -1,6 +1,6 @@
# TODO tidy up eg The patchelf code is patching gvim even if you don't build it..
# but I have gvim with python support now :) - Marc
{ source ? "default", callPackage, fetchurl, stdenv, ncurses, pkgconfig, gettext
{ source ? "default", callPackage, stdenv, ncurses, pkgconfig, gettext
, writeText, config, glib, gtk2-x11, gtk3-x11, lua, python, perl, tcl, ruby
, libX11, libXext, libSM, libXpm, libXt, libXaw, libXau, libXmu
, libICE

2
pkgs/applications/editors/vscode/generic.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchurl, makeDesktopItem
{ stdenv, lib, makeDesktopItem
, unzip, libsecret, libXScrnSaver, wrapGAppsHook
, gtk2, atomEnv, at-spi2-atk, autoPatchelfHook
, systemd, fontconfig

2
pkgs/applications/editors/vscode/vscode.nix

@ -1,4 +1,4 @@
{ stdenv, lib, callPackage, fetchurl, fetchpatch, isInsiders ? false }:
{ stdenv, lib, callPackage, fetchurl, isInsiders ? false }:
let
inherit (stdenv.hostPlatform) system;

2
pkgs/applications/editors/vscode/vscodium.nix

@ -1,4 +1,4 @@
{ stdenv, lib, callPackage, fetchurl, fetchpatch }:
{ stdenv, callPackage, fetchurl }:
let
inherit (stdenv.hostPlatform) system;

2
pkgs/applications/editors/vscode/with-extensions.nix

@ -1,4 +1,4 @@
{ stdenv, lib, runCommand, buildEnv, vscode, makeWrapper
{ lib, runCommand, buildEnv, vscode, makeWrapper
, vscodeExtensions ? [] }:
/*

2
pkgs/applications/editors/xmlcopyeditor/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, aspell, boost, expat, expect, intltool, libxml2, libxslt, pcre, wxGTK, xercesc }:
{ stdenv, fetchurl, aspell, boost, expat, intltool, libxml2, libxslt, pcre, wxGTK, xercesc }:
stdenv.mkDerivation rec {
name = "xmlcopyeditor-${version}";

2
pkgs/applications/gis/qgis/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, makeWrapper, symlinkJoin
{ lib, makeWrapper, symlinkJoin
, qgis-unwrapped, extraPythonPackages ? (ps: [ ])
}:
with lib;

2
pkgs/applications/graphics/animbar/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchurl, cmake, qt4, file, gcc }:
{ stdenv, lib, fetchurl, cmake, qt4, file }:
stdenv.mkDerivation rec {
pname = "animbar";

4
pkgs/applications/graphics/freecad/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, cmake, coin3d, xercesc, ode, eigen, qt4, opencascade, gts
, hdf5, vtk, medfile, zlib, python27Packages, swig, gfortran, fetchpatch
, soqt, libf2c, makeWrapper, makeDesktopItem
, hdf5, vtk, medfile, zlib, python27Packages, swig, gfortran
, soqt, libf2c, makeWrapper
, mpi ? null }:
assert mpi != null;

2
pkgs/applications/graphics/gcolor3/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitLab, gnome3, meson, ninja, gettext, pkgconfig, libxml2, gtk3, hicolor-icon-theme, wrapGAppsHook }:
{ stdenv, fetchFromGitLab, meson, ninja, gettext, pkgconfig, libxml2, gtk3, hicolor-icon-theme, wrapGAppsHook }:
let
version = "2.3.1";

2
pkgs/applications/graphics/gscan2pdf/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, perlPackages, makeWrapper, wrapGAppsHook,
{ stdenv, fetchurl, perlPackages, wrapGAppsHook,
librsvg, sane-backends, sane-frontends,
imagemagick, libtiff, djvulibre, poppler_utils, ghostscript, unpaper,
xvfb_run, hicolor-icon-theme, liberation_ttf, file, pdftk }:

2
pkgs/applications/graphics/image_optim/default.nix

@ -1,4 +1,4 @@
{ lib, bundlerApp, fetchurl, ruby, makeWrapper,
{ lib, bundlerApp, ruby, makeWrapper,
withPngcrush ? true, pngcrush ? null,
withPngout ? true, pngout ? null,
withAdvpng ? true, advancecomp ? null,

2
pkgs/applications/graphics/jpeg-archive/default.nix

@ -1,4 +1,4 @@
{ lib, stdenv, fetchFromGitHub, mozjpeg, makeWrapper, coreutils, parallel, findutils }:
{ stdenv, fetchFromGitHub, mozjpeg, makeWrapper, coreutils, parallel, findutils }:
stdenv.mkDerivation rec {
name = "jpeg-archive-${version}";

1
pkgs/applications/graphics/krita/default.nix

@ -12,7 +12,6 @@ let
major = "4.2";
minor = "1";
patch = null;
in

1
pkgs/applications/graphics/shotwell/default.nix

@ -1,6 +1,5 @@
{ stdenv
, fetchurl
, fetchpatch
, meson
, ninja
, gtk3

2
pkgs/applications/graphics/tesseract/tesseract3.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchFromGitHub, autoreconfHook, pkgconfig
{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig
, leptonica, libpng, libtiff, icu, pango, opencl-headers }:
stdenv.mkDerivation rec {

2
pkgs/applications/kde/knotes.nix

@ -1,5 +1,5 @@
{
mkDerivation, lib,
mkDerivation,
extra-cmake-modules, kdoctools,
kcompletion, kconfig, kconfigwidgets, kcoreaddons, kcrash,
kdbusaddons, kdnssd, kglobalaccel, kiconthemes, kitemmodels,

2
pkgs/applications/misc/buku/default.nix

@ -1,4 +1,4 @@
{ stdenv, python3, fetchFromGitHub, fetchpatch }:
{ stdenv, python3, fetchFromGitHub }:
with python3.pkgs; buildPythonApplication rec {
version = "4.2.2";

2
pkgs/applications/misc/cardpeek/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchFromGitHub, pkgconfig, autoreconfHook,
{ stdenv, fetchFromGitHub, pkgconfig, autoreconfHook,
glib, gtk3, pcsclite, lua5_2, curl, readline }:
let
version = "0.8.4";

2
pkgs/applications/misc/curaengine/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, fetchpatch, cmake, libarcus, stb, protobuf }:
{ stdenv, fetchFromGitHub, cmake, libarcus, stb, protobuf }:
stdenv.mkDerivation rec {
name = "curaengine-${version}";

2
pkgs/applications/misc/ddgr/default.nix

@ -1,4 +1,4 @@
{stdenv, fetchpatch, fetchFromGitHub, python3}:
{stdenv, fetchFromGitHub, python3}:
stdenv.mkDerivation rec {
version = "1.6";

1
pkgs/applications/misc/digitalbitbox/default.nix

@ -3,7 +3,6 @@
, curl
, fetchFromGitHub
, git
, libcap
, libevent
, libtool
, qrencode

6
pkgs/applications/misc/electron-cash/default.nix

@ -1,11 +1,5 @@
{ lib, fetchurl, python3Packages, qtbase, makeWrapper }:
let
python = python3Packages.python;
in
python3Packages.buildPythonApplication rec {
pname = "electron-cash";
version = "4.0.2";

2
pkgs/applications/misc/font-manager/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, meson, ninja, gettext, python3, fetchpatch,
{ stdenv, fetchFromGitHub, meson, ninja, gettext, python3,
pkgconfig, libxml2, json-glib , sqlite, itstool, librsvg,
vala, gtk3, gnome3, desktop-file-utils, wrapGAppsHook, gobject-introspection
}:

4
pkgs/applications/misc/gImageReader/default.nix

@ -6,8 +6,8 @@
# Gtk deps
# upstream gImagereader supports Qt too
, gtk3, gobject-introspection, wrapGAppsHook
, gnome3, gtkmm3, gtksourceview3, gtksourceviewmm, gtkspell3, gtkspellmm, cairomm
, gobject-introspection, wrapGAppsHook
, gtkmm3, gtksourceview3, gtksourceviewmm, gtkspell3, gtkspellmm, cairomm
}:
let

2
pkgs/applications/misc/ganttproject-bin/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchzip, makeDesktopItem, makeWrapper
{ stdenv, fetchzip, makeDesktopItem, makeWrapper
, jre
}:

2
pkgs/applications/misc/gremlin-console/default.nix

@ -1,4 +1,4 @@
{ pkgs, fetchzip, stdenv, makeWrapper, openjdk }:
{ fetchzip, stdenv, makeWrapper, openjdk }:
stdenv.mkDerivation rec {
name = "gremlin-console-${version}";

2
pkgs/applications/misc/k2pdfopt/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchzip, fetchurl, fetchpatch, cmake, pkgconfig
, zlib, libpng, openjpeg
, zlib, libpng
, enableGSL ? true, gsl
, enableGhostScript ? true, ghostscript
, enableMuPDF ? true, mupdf

2
pkgs/applications/misc/kitty/default.nix

@ -2,7 +2,7 @@
harfbuzz, fontconfig, pkgconfig, ncurses, imagemagick, xsel,
libstartup_notification, libX11, libXrandr, libXinerama, libXcursor,
libxkbcommon, libXi, libXext, wayland-protocols, wayland,
which, dbus, fetchpatch,
which, dbus,
Cocoa,
CoreGraphics,
Foundation,

4
pkgs/applications/misc/lutris/default.nix

@ -1,5 +1,5 @@
{ stdenv, pkgs, buildFHSUserEnv, makeDesktopItem, fetchFromGitHub, fetchpatch
, wrapGAppsHook, python2Packages, python3Packages }:
{ stdenv, pkgs, buildFHSUserEnv, makeDesktopItem, fetchFromGitHub
, wrapGAppsHook, python3Packages }:
let
qt5Deps = with pkgs; with qt5; [ qtbase qtmultimedia ];

2
pkgs/applications/misc/taskell/default.nix

@ -1,4 +1,4 @@
{ haskell, lib, haskellPackages, fetchFromGitHub }:
{ lib, haskellPackages, fetchFromGitHub }:
let
version = "1.4.3";

2
pkgs/applications/misc/termite/wrapper.nix

@ -1,4 +1,4 @@
{ makeWrapper, wrapGAppsHook, symlinkJoin, configFile ? null, termite }:
{ makeWrapper, symlinkJoin, configFile ? null, termite }:
if configFile == null then termite else symlinkJoin {
name = "termite-with-config-${termite.version}";

3
pkgs/applications/misc/ulauncher/default.nix

@ -1,12 +1,9 @@
{ stdenv
, fetchFromGitHub
, fetchurl
, python27Packages
, substituteAll
, gnome3
, gobject-introspection
, wrapGAppsHook
, gtk3
, webkitgtk
, libnotify
, keybinder3

2
pkgs/applications/misc/xcruiser/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, gccmakedep, xorg, imake, libXt, libXaw, libXpm, libXext }:
{ stdenv, fetchurl, gccmakedep, imake, libXt, libXaw, libXpm, libXext }:
stdenv.mkDerivation {
name = "xcruiser-0.30";

6
pkgs/applications/misc/yubioath-desktop/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, fetchFromGitHub
, qmake, qtbase, qtquickcontrols, qtsvg
, python3, pyotherside, ncurses
{ stdenv, fetchurl
, qmake, qtbase, qtquickcontrols
, python3, pyotherside
, pcsclite, yubikey-personalization
, yubikey-manager, makeWrapper }:

2
pkgs/applications/misc/zathura/pdf-mupdf/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, meson, ninja, fetchurl, fetchFromGitHub
{ stdenv, lib, meson, ninja, fetchFromGitHub
, pkgconfig, zathura_core, cairo , gtk-mac-integration, girara, mupdf }:
stdenv.mkDerivation rec {

2
pkgs/applications/networking/browsers/chromium/common.nix

@ -1,4 +1,4 @@
{ stdenv, llvmPackages, gn, ninja, which, nodejs, fetchurl, fetchpatch, gnutar
{ stdenv, llvmPackages, gn, ninja, which, nodejs, fetchpatch, gnutar
# default dependencies
, bzip2, flac, speex, libopus

2
pkgs/applications/networking/browsers/chromium/default.nix

@ -1,5 +1,5 @@
{ newScope, config, stdenv, llvmPackages, gcc8Stdenv, llvmPackages_8
, makeWrapper, makeDesktopItem, ed
, makeWrapper, ed
, glib, gtk3, gnome3, gsettings-desktop-schemas
, libva ? null

3
pkgs/applications/networking/browsers/firefox-bin/update.nix

@ -1,5 +1,4 @@
{ stdenv
, name
{ name
, channel
, writeScript
, xidel

2
pkgs/applications/networking/browsers/firefox/packages.nix

@ -1,4 +1,4 @@
{ lib, callPackage, stdenv, fetchurl, fetchFromGitHub, fetchpatch, python3, overrideCC, gccStdenv, gcc6 }:
{ lib, callPackage, fetchurl, fetchFromGitHub, python3, overrideCC, gccStdenv, gcc6 }:
let

1
pkgs/applications/networking/browsers/firefox/update.nix

@ -1,5 +1,4 @@
{ writeScript
, stdenv
, lib
, xidel
, common-updater-scripts

2
pkgs/applications/networking/browsers/midori/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, cmake, ninja, pkgconfig, intltool, vala, wrapGAppsHook, gcr, libpeas
, gtk3, webkitgtk, sqlite, gsettings-desktop-schemas, libsoup, glib-networking, gnome3
, gtk3, webkitgtk, sqlite, gsettings-desktop-schemas, libsoup, glib-networking
}:
stdenv.mkDerivation rec {

2
pkgs/applications/networking/browsers/tor-browser-bundle/default.nix

@ -21,8 +21,6 @@
, mediaSupport ? false
, ffmpeg
, gmp
# Extensions, common
, zip

3
pkgs/applications/networking/charles/default.nix

@ -20,8 +20,7 @@ let
startupNotify = "true";
};
attrs' = builtins.removeAttrs attrs ["version" "sha256"];
in stdenv.mkDerivation rec {
in stdenv.mkDerivation rec {
name = "charles-${version}";
inherit version;

2
pkgs/applications/networking/cluster/docker-machine/kvm2.nix

@ -1,4 +1,4 @@
{ stdenv, buildGoPackage, fetchFromGitHub, libvirt, pkgconfig, minikube }:
{ stdenv, buildGoPackage, libvirt, pkgconfig, minikube }:
buildGoPackage rec {
pname = "docker-machine-kvm2";

Some files were not shown because too many files changed in this diff

Loading…
Cancel
Save