Browse Source

hypothesis: disabled for Python 3.3

nixos-19.03
Frederik Rietdijk 5 years ago
parent
commit
a312abedeb
  1. 6
      pkgs/development/python-modules/hypothesis.nix

6
pkgs/development/python-modules/hypothesis.nix

@ -1,5 +1,5 @@
{ stdenv, buildPythonPackage, fetchFromGitHub, python
, pythonOlder, enum34
, pythonOlder, pythonAtLeast, enum34
, doCheck ? true, pytest, flake8, flaky
}:
buildPythonPackage rec {
@ -30,6 +30,10 @@ buildPythonPackage rec {
${python.interpreter} -m pytest tests/cover
'';
# Unsupport by upstream on certain versions
# https://github.com/HypothesisWorks/hypothesis-python/issues/477
disabled = pythonOlder "3.4" && pythonAtLeast "2.8";
meta = with stdenv.lib; {
description = "A Python library for property based testing";
homepage = https://github.com/DRMacIver/hypothesis;

Loading…
Cancel
Save