Browse Source

python37Packages.pyrsistent: 0.15.2 -> 0.15.4

Some tests are broken on 0.15.2 if used with pytest 5+ as discussed
in #64145. The issue is fixed in tobgu/pyrsistent#175 and released in
0.15.4.
openssl
László Vaskó 3 years ago committed by Jon
parent
commit
9d9aa6099f
  1. 4
      pkgs/development/python-modules/pyrsistent/default.nix

4
pkgs/development/python-modules/pyrsistent/default.nix

@ -20,6 +20,10 @@ buildPythonPackage rec {
checkInputs = [ pytestrunner pytest_4 hypothesis ];
postPatch = ''
substituteInPlace setup.py --replace 'pytest<5' 'pytest'
'';
meta = with stdenv.lib; {
homepage = https://github.com/tobgu/pyrsistent/;
description = "Persistent/Functional/Immutable data structures";

Loading…
Cancel
Save